Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Options
Go to last post
2 Pages<12
Posted on Mon, Jul 08 2019 23:00
by Seventh Sam
Joined on Sat, Dec 29 2018, Posts 171
Originally Posted by: crd Go to Quoted Post
You are getting much better performance than I am. I will have to take a dayto try and trouble shoot what is making my system choke at any buffer less than 1024. Are you able to run large sessions (full orchestra) at 128?


If it's all VI pro instruments (40-60 instances all in mirpro), then it will occasionally click here and there every 5 min or so (I think that's my entry level interface). Once I add kontakt, third party verbs, cfx, synths etc. there are clicks every min or so and I'll up it to 256. It's worth noting that I only use this buffer setting for live playing in parts. Once it's all settled and time for fine tuning, I crank it up to 2048.

I'm finding I live play less and less since integrating Reaticulate into my workflow, which is lovely - feels more like composing and less like DJing. I also use the "render take fx" function to get individual midi items into temporary WAV "takes" if a certain section is clicking too much.
Posted on Fri, Jul 19 2019 06:16
by crd
Joined on Wed, Dec 05 2018, Posts 4

I embarrassing realized that I was trying to run my VEPro through my wifi connection rather than the ethernet cable between my two computers. Now that I fixed that I am getting much better results (duh).

The feedback routing is working well for me, except sometimes the first channel stops sending midi to VEPro if I have an effects send on the channel. Does this happen to anyone else?

Posted on Sat, Jul 20 2019 15:57
by Seventh Sam
Joined on Sat, Dec 29 2018, Posts 171

Originally Posted by: crd Go to Quoted Post

I embarrassing realized that I was trying to run my VEPro through my wifi connection rather than the ethernet cable between my two computers. Now that I fixed that I am getting much better results (duh).

The feedback routing is working well for me, except sometimes the first channel stops sending midi to VEPro if I have an effects send on the channel. Does this happen to anyone else?

Another user found a bug with feedback routing.  If you have any of the feedback routing enabled tracks sending to anything else, the first (but only the first) track will not send MIDI if it's *above* the VEPro track in the track control panel.  If this is the case with you, try moving any tracks with VEPro instances to the very top of your project's track list and it should fix the problem.

- Sam

Posted on Sun, Jul 21 2019 08:40
by crd
Joined on Wed, Dec 05 2018, Posts 4

Moving it to the top solved it. Thank you! I am loving the workflow I'm developing with Reaper.

Posted on Mon, Dec 23 2019 03:00
by Headlands
Joined on Thu, Jan 07 2016, Posts 7

Thank you so much for this, Sam.

I'm new to Reaper after many years on Cubase and can't figure one thing out with your routing: Everything looks good but I can't figure out why I'm not hearing audio from any of the MIDI tracks. I'm seeing audio (colored red) on them, just not hearing it. I'm sure it's a stupid mistake but I just can't figure it out.

Posted on Mon, Dec 23 2019 17:51
by Seventh Sam
Joined on Sat, Dec 29 2018, Posts 171

Originally Posted by: Headlands Go to Quoted Post

Thank you so much for this, Sam.

I'm new to Reaper after many years on Cubase and can't figure one thing out with your routing: Everything looks good but I can't figure out why I'm not hearing audio from any of the MIDI tracks. I'm seeing audio (colored red) on them, just not hearing it. I'm sure it's a stupid mistake but I just can't figure it out.

When this happens to me, the two main culprits are:

1) I forgot to turn on "Input Monitoring" in the track itself (not the one with the Ensemble Pro Server plugin, but the track that's actually inputing MIDI and receiving audio back).  Depending on the theme you're using, you can find this in the TCP (Track Control Panel) or Mixer.

2) The Expression or Volume CC (11 and 7, respectively) are accidentally turned down for that particular instance of VI or Synchron Player.  I can't tell you how many times I've tweaked CC envelopes, forgot I had done so, and then freaked out thinking the audio wasn't working when the reality is that Expression was just set at 0 the whole time!

Does one of those two fix your problem?

- Sam

Posted on Mon, Dec 23 2019 19:35
by Headlands
Joined on Thu, Jan 07 2016, Posts 7

Originally Posted by: Seventh Sam Go to Quoted Post

When this happens to me, the two main culprits are:

1) I forgot to turn on "Input Monitoring" in the track itself (not the one with the Ensemble Pro Server plugin, but the track that's actually inputing MIDI and receiving audio back).  Depending on the theme you're using, you can find this in the TCP (Track Control Panel) or Mixer.

2) The Expression or Volume CC (11 and 7, respectively) are accidentally turned down for that particular instance of VI or Synchron Player.  I can't tell you how many times I've tweaked CC envelopes, forgot I had done so, and then freaked out thinking the audio wasn't working when the reality is that Expression was just set at 0 the whole time!

Does one of those two fix your problem?

- Sam

Yes, expression and volume CC are always ghosts in the closet, hahaha.

Thanks for the help!

It was total rookie routing error, it turns out...years on Cubase and getting used to Reaper. :-)

Posted on Mon, Dec 23 2019 21:21
by Seventh Sam
Joined on Sat, Dec 29 2018, Posts 171

Originally Posted by: Headlands Go to Quoted Post

Originally Posted by: Seventh Sam Go to Quoted Post

When this happens to me, the two main culprits are:

1) I forgot to turn on "Input Monitoring" in the track itself (not the one with the Ensemble Pro Server plugin, but the track that's actually inputing MIDI and receiving audio back).  Depending on the theme you're using, you can find this in the TCP (Track Control Panel) or Mixer.

2) The Expression or Volume CC (11 and 7, respectively) are accidentally turned down for that particular instance of VI or Synchron Player.  I can't tell you how many times I've tweaked CC envelopes, forgot I had done so, and then freaked out thinking the audio wasn't working when the reality is that Expression was just set at 0 the whole time!

Does one of those two fix your problem?

- Sam

Yes, expression and volume CC are always ghosts in the closet, hahaha.

Thanks for the help!

It was total rookie routing error, it turns out...years on Cubase and getting used to Reaper. :-)

Most welcome :)  Let me know if there's anything else you need.

Also, I tend to be a bit of a broken record on this, but check this out:

https://reaticulate.com/

This articulation management system (for REAPER) - if you like its workflow - will save you HOURS of time diddling with keyswitches.

- Sam

EDIT:

This post I made might be of use to you as well:

https://www.vsl.co.at/community/posts/m290245-For-REAPER-users--Articulation-Management-System-for-all-Strings--Woodwind-and-Brass-VI-Libraries#post290245

Posted on Tue, Dec 31 2019 00:12
by Headlands
Joined on Thu, Jan 07 2016, Posts 7

One question: I'm able to get this to work perfectly for the first port in VE Pro (which is Strings in my template), but I can't get any MIDI going to the second port (Brass in my template). I tried MIDI bus 2 and bus 1, with no luck. Is there something I might be missing? 

Posted on Tue, Dec 31 2019 01:10
by Seventh Sam
Joined on Sat, Dec 29 2018, Posts 171

Originally Posted by: Headlands Go to Quoted Post

One question: I'm able to get this to work perfectly for the first port in VE Pro (which is Strings in my template), but I can't get any MIDI going to the second port (Brass in my template). I tried MIDI bus 2 and bus 1, with no luck. Is there something I might be missing? 

Make sure the following settings match, as pictured:

https://imgur.com/x57kq5Z

Essentially:

When using MIDI Bus/Port #1, the following settings should be made:

In REAPER's Send configuration window:

MIDI: [All] and [Channel #]

In Ensemble Pro:

Port: 1 Channel: [Channel #]

Once you want to expand beyond 16 instances and use Bus/Port #2 and beyond, REAPER's syntax gets a little confusing.  I'll use examples:

Let's say you want the track to receive MIDI data on Bus #2, Channel 12.

- Set REAPER's Send configuration for that track to:

MIDI [All] -> [Bus 2, 2/12]

- Then, set Ensemble Pro's settings to:

Port: 2 Channel: 12

 

Hopefully that clears it up and fixes your problem!

- Sam

Posted on Tue, Dec 31 2019 01:19
by Seventh Sam
Joined on Sat, Dec 29 2018, Posts 171

Also, there's a little obscure pair of settings that might be the culprit of Bus 2 and beyond are not working.  Do the following:

- Open the Ensemble Pro Server FX window in REAPER.  Make sure you are using the VST3i version of the Ensemble Pro Plugin.  As far as I'm aware, Ports/Buses beyond #1 won't work in REAPER unless it's VST3 (this might have been fixed in REAPER 6).

- Click on the button in the top right part of the window that says something like "2/64" out.  It will open a window with a grid.

- On that new window, click the small button that says I/O, again in the top right.  You'll get a drop down menu.

- In that menu, you need to change a few settings.  They are:

  • Midi Input -> Map REAPER MIDI Buses to VST3 MIDI Buses
  • Midi Output -> Map VST3 MIDI Buses to REAPER MIDI Buses

Make sure both those are checked.  Once they are, Buses 2 and up will interact correctly with Ensemble Pro, allowing you to have 256 separate instruments in a single Ensemble Pro instance.  Yay!

Posted on Tue, Dec 31 2019 01:22
by Headlands
Joined on Thu, Jan 07 2016, Posts 7

Originally Posted by: Seventh Sam Go to Quoted Post

Also, there's a little obscure pair of settings that might be the culprit of Bus 2 and beyond are not working.  Do the following:

- Open the Ensemble Pro Server FX window in REAPER.  Make sure you are using the VST3i version of the Ensemble Pro Plugin.  As far as I'm aware, Ports/Buses beyond #1 won't work in REAPER unless it's VST3 (this might have been fixed in REAPER 6).

- Click on the button in the top right part of the window that says something like "2/64" out.  It will open a window with a grid.

- On that new window, click the small button that says I/O, again in the top right.  You'll get a drop down menu.

- In that menu, you need to change a few settings.  They are:

  • Midi Input -> Map REAPER MIDI Buses to VST3 MIDI Buses
  • Midi Output -> Map VST3 MIDI Buses to REAPER MIDI Buses

Make sure both those are checked.  Once they are, Buses 2 and up will interact correctly with Ensemble Pro, allowing you to have 256 separate instruments in a single Ensemble Pro instance.  Yay!

 

THAT was it - I had forgotten about that. Thank you again good sir.

Posted on Tue, Dec 31 2019 01:47
by Seventh Sam
Joined on Sat, Dec 29 2018, Posts 171

Originally Posted by: Headlands Go to Quoted Post

Originally Posted by: Seventh Sam Go to Quoted Post

Also, there's a little obscure pair of settings that might be the culprit of Bus 2 and beyond are not working.  Do the following:

- Open the Ensemble Pro Server FX window in REAPER.  Make sure you are using the VST3i version of the Ensemble Pro Plugin.  As far as I'm aware, Ports/Buses beyond #1 won't work in REAPER unless it's VST3 (this might have been fixed in REAPER 6).

- Click on the button in the top right part of the window that says something like "2/64" out.  It will open a window with a grid.

- On that new window, click the small button that says I/O, again in the top right.  You'll get a drop down menu.

- In that menu, you need to change a few settings.  They are:

  • Midi Input -> Map REAPER MIDI Buses to VST3 MIDI Buses
  • Midi Output -> Map VST3 MIDI Buses to REAPER MIDI Buses

Make sure both those are checked.  Once they are, Buses 2 and up will interact correctly with Ensemble Pro, allowing you to have 256 separate instruments in a single Ensemble Pro instance.  Yay!

THAT was it - I had forgotten about that. Thank you again good sir.

No worries.  I guess the trade off for REAPER's flexibility is the interface is a little...unintuitive :)

I recommend saving those settings into a track template so you never have to deal with it again.

- Sam

Posted on Tue, Jun 09 2020 19:22
by Rellek
Joined on Tue, May 12 2015, Posts 1

Thank you for your original post Sam.

I was close to pulling my hair out over this.

Many thanks!   

Posted on Wed, Jun 10 2020 20:29
by Seventh Sam
Joined on Sat, Dec 29 2018, Posts 171

Originally Posted by: Rellek Go to Quoted Post

Thank you for your original post Sam.

I was close to pulling my hair out over this.

Many thanks!   

You're welcome!  Glad to have helped.

2 Pages<12
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.