Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
VE Pro 4881: "This file has been created in a newer version"
Last post Thu, Apr 08 2010 by Karel, 6 replies.
Options
Go to last post
Posted on Wed, Apr 07 2010 13:59
by Dom
Joined on Sat, Nov 13 2004, London, Posts 222

I can't get VE Pro to work anymore, all of a sudden, without me having changed anything. When I load the Logic file, I the slave displays the message "This file has been created in a newer version of VE Pro. Please update."  I can click "OK" then VE Pro crashes (on the slave).

However, both DAW and slave have 4881 installed. 

DAW

Logic 9.1.1, OSX 10.5.8, Mac Pro 8 core, VE Pro 4881 AU

Slave

VE Pro Server 4881. Windows XP64, 6 instances of VE Pro, preserved

Sorry this is a bit of an urgent one, as I am missing a deadline....

Posted on Wed, Apr 07 2010 16:04
by Karel
Joined on Mon, Jan 19 2009, Belgium, Posts 2173

This sounds like the project file has gone corrupt somehow. Did you keep a backup of the metaframe project?

Karel Bassez
Software Engineer
Vienna Symphonic Library
Posted on Wed, Apr 07 2010 17:22
by Dom
Joined on Sat, Nov 13 2004, London, Posts 222

Thanks Karel. Do you think that's really the case? I do have a backup but it's old and would need a lot of rebuilding. Could it be re-saved from the state it is now, or at least the individual instances saved separately, then a new metaframe created, then those saved instances loaded into it again?

Just to be clear again. The message "This file was created in a newer version" doesn't appear when trying to load the metaframe. The metaframe loads fine, with all its instances. The message appears when the host is trying to connect to it. It's quite a large metaframe - around 16GB,

I currently have it running again, but this thing happens now every few days, and will take out half a days work. I get it running again by saving a Logic file with all the instances disconnected, then load the VE frame on the server, then manually reconnect each instance.

Posted on Wed, Apr 07 2010 17:33
by Karel
Joined on Mon, Jan 19 2009, Belgium, Posts 2173

What I recommend is to load the metaframe and manually connect all Server Interface plugins in Logic to the Server instances in the metaframe. Make sure that all Server Interfaces are not decoupled. Then save the project in Logic. That should ensure the project is saved properly with Logic as well for further use. If the problem keeps reappearing you might be running out of memory perhaps?

Karel Bassez
Software Engineer
Vienna Symphonic Library
Posted on Thu, Apr 08 2010 09:04
by Dom
Joined on Sat, Nov 13 2004, London, Posts 222

The problem has been reappearing. I doubt it's a RAM issue: on the the server there are still 8GB free, and on the host around 9GB free.

The problem starts often many hours after the Logic file has been loaded, and working fine,  and days after the metaframe has been loaded. One of the instances may then stop working, as if it's lost a connection. My instinct is then to remedy the situation by reloading the Logic file, which then starts the sequence of events described above.

I've only just really understood the decouple function now, so would having decouple activated potentially reduce the occurrence of this problem? I always save all the data with the metaframe anyway. However, I never had the impression that my Logic save times were slow anyway.

Posted on Thu, Apr 08 2010 11:44
by Karel
Joined on Mon, Jan 19 2009, Belgium, Posts 2173

Until the upcoming VE Pro update is released (very soon), I recommend running all your VE Pro Server Instance plugins decoupled and saving things on the server side. When decoupled, the master host will only save the server connection information and the preserved name to connect to, and not the viframe project.

Karel Bassez
Software Engineer
Vienna Symphonic Library
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.