Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Options
Go to last post
3 Pages123>
Posted on Tue, Nov 29 2011 14:46
by Ege
Joined on Sat, Jan 22 2005, Washington, DC, Posts 104

Hoping a guru here knows the answer. 

1.  I can't understand the new
requirement for VE Pro 5 that "Logic requires adding Utility - I/O
plugin on the same track as an Input plugin (AUDIO and EVENT Input
plug-ins).  Enable its output and then bypass it to force the track into Live mode."  VE Pro 5 Manual, p. 33.

I cannot understand what I am supposed to do.

Normally,
when I set up VE Pro, I follow the procedure outlined in
"Orchestral_Templates-VEPRO_with_LogicPro9" found in the "Needful
Things" section of the VSL "User" website area.  This procedure sets up VE Pro as an
external instrument, with individual tracks for the various instruments below.  So, in a normal case, I would have a maximum of 16 tracks:  one VE Pro track and 15 individual instrument tracks (for the instances of Vienna Instrument player set up in VE Pro's mixer).

WHERE do I place this I/O plugin?  Does it get added
as an input to the VE Pro instance (only once), or is it added to EACH
of the individual instruments that show up as tracks BELOW the VE Pro instance (in other words, I add it as many as 15 times)?

2.  Also, and unrelated to the first question (I think), by what procedure do I avoid the 16 instances per AU limit of OSX using VE Pro 5?  Before, if I needed more than 15 instruments (see above set up), I would just an ANOTHER instance of VE Pro.  Can I now, somehow, add a much larger number of instruments within VE Pro 5, with a corresponding LARGE number of tracks below my initial VE Pro external instrument that I set up using the procedure described above?  In other words, I would have ONE VE Pro 5 track set up as an external instrument, and, say, 25 tracks below?  (If that's clear at all).  I can't see how that would be done, because following the external instrument procedure, you must specially set up a "multi-instrument" within the Logic Environment, and THAT instrument is limited to 16 instruments.  Where do I get the additional 9 instruments?

Steve

IMac, 2.9 GHz Intel 4 Core i5, 32 GB, OSX 10.10.1
Posted on Tue, Nov 29 2011 22:46
by cefnfaes
Joined on Fri, Dec 07 2007, Posts 11

Thank you Steve for asking the very questions for which I also need answers. I look forward to a detailed and clear response from some of the very knowledgeable people out there !

Regards

Jeremy

Posted on Tue, Nov 29 2011 23:55
by Karel
Joined on Mon, Jan 19 2009, Belgium, Posts 2173

It is avoided by using multiple AU instruments, namely the main VE Pro instrument plugin and Event Input instrument plugins, which can be assigned to a VE Pro instrument plugin.

The I/O Utility trick is a workaround to force the Event Input track in Live mode at all times, which is a requirement for proper functionality in Logic. You just have to put it as insert effect on the same track that has the Event Input instrument plugin.

So for each additional Event Input plugin you get an additional 16 MIDI channels in the form of an extra MIDI port. This does come with some consequences as Logic will still treat the Event Input plugin track as a separate instrument track of course.

Karel Bassez
Software Engineer
Vienna Symphonic Library
Posted on Wed, Nov 30 2011 11:39
by eljodon
Joined on Sat, Dec 04 2010, Valencia, Ca, Posts 34

I'm sorry, could you be more clear for a simple minded person like me? So I need to change the way I set it up, which I thought it worked better for me than the way is stated in the VE Pro 4 manual. I also use the multi instrument and connect it to a transformer then to the AU instrument. I used to do it when I used the Spectrasonics plugins. Could I just open up another instrument channel and use the Event input plugins and instead of having the cable on the main one, attach the cable to the instrument channel with the Event input plugin and also place an I/O Utility on it? I hope my post makes sense!!!Thanks

-Mac Pro 2.93Ghz 8 core,24 gigs RAM,4 TB Raid,(4)1 Tb audio drives Pro Tools 10 HD 4,(3) I92 io,Sync io, Apogee Big Ben,Apogee PSX-100 2010 Mac Pro 3.46 GHz 12 core 48 gigs, Areaca SANS, (4) 1 TB SSD, RAID (4) 650 gig Velociraptor RAID. (2) Motu 2408 Mrk 3 (4) 1 Tb SSD, RAID with(4)650 gig Velociraptors, Cubase 10 (2) Motu 2408 Mk 3 -Mac Pro 2.66 Ghz 12 Core,48 Gig RAM, Samsung 1 Tb SSD 850 EVO RAID 0,(4) 600 Gigs WD Velociraptor RAID, (4) WD black 1 TB RAID O,Areca 1213-4i, Newer Tech MAXPower RAID mini SAS 6G-2e, VE Pro 5,Ableton Live 9,Altiveb 7, Vienna Cube & App Strings extended,East West Hollywood Strings,SD2,EWOL,Symphonic Choirs,etc.UAD PCI quad SSL X Rack, API,Avalon,Chandler Limited,Avalon Marshall Plexi 69/69, Metro/Friedman 68 Plexi ,Friedman BE100, Suhr PT100,ENGL Powerball 2,VOX AC-30, Fractal Axe FX 2 and lots of guitars & Basses!
Posted on Wed, Nov 30 2011 15:57
by Ege
Joined on Sat, Jan 22 2005, Washington, DC, Posts 104

Karel --

Thanks for your prompt response, but I'm afraid I still am confused, as I need to know the PROCEDURE, in a little more detail than you have outlined.

1.  As to this "Event Input Instrument plugin", which is NEW to VE Pro 5, exactly HOW do I set it up? Well, let us look first, of course, to the VE Pro Manual, p. 16.  As we know, following the procedure in User-Needful Things for Logic users, I have previously set up the VE Pro instance as, say, my first track.  When set up (discussed in my first post), I have ONE non-multi-timbral software instrument track (for the VE Pro instance), and, say, 15 tracks below, set up as EXTERNAL instruments, and assigned to the multi-instrument in the Environment.  These 15 tracks refer to 15 instances of Vienna INSTRUMENTS Pro, inserted in VE Pro.  (For those of you as confused as I am explaining this (and I have done it about 20 times I think), there is a video which shows the procedure for Logic setup, only using Kontakt rather than VE Pro.  Search Youtube for "Kontakt, Environment, Logic."  Here is one: http://www.youtube.com/watch?v=WnwYxbzLZSk, not the one I originally found, but it takes you through what you need to do.  Substitute VE Pro for Kontakt as the first, non-multi-timbral instrument that you insert in your Logic project.)

There are two additional tricks:  do NOT enable instrument 1 in the multi-instrument in the Environment (that will be assigned to VE Pro track itself, which will contain no MIDI information), the remaining 2 - 16 are available for the external instrument tracks below.  These external tracks are your VI Pro instances within VE Pro.  You must ALSO (trick two) insert a transformer in between the multi-instrument and the VE Pro channel, to convert CC 7 to some other control number (enabling separate control of volume for each VI Pro instance within VE Pro).  Read the explanation in Needful Things within the VSL User tab after you have viewed the video, and you will understand these additional procedures for the Environment multi-instrument and the transformer.  You save the whole set up as a template so you don't have to keep doing it over and over again (when this template works).

So there were have it.  Now, back to the new VE Pro manual, p. 16.  Where does this new "Event Instrument Plugin" go?  Page 16 of the VE Pro manual instructs us to add it as an Insert on the VE Pro channel strip in the Arrange window (to the left of the main, large grey area where the tracks go, the vague grey plug under "Inserts").  Insert it as a plug-in within VE Pro (the first track we created, above).  I do so: "Inserts-Audio Units-VSL-Vienna Ensemble Pro Audio Input-Stereo".  A PURPLE Audio Input pops up, and I Assign it to the VE Pro server that I started before starting Logic (just as I Assigned the initial instance of VE Pro in track one to that server).

But this is not what is supposed to happen.  Recall, I am FOLLOWING a RECOMMENDED procedure to set up VE Pro in Logic (the complicated procedure using the Environment).  Recall ALSO that the VE Pro instance is NOT multi-timbral.  If I DO NOT follow this procedure in Logic, I cannot INDIVIDUALLY control volume with CC 7.  Note, further, that p. 16 of the manual, illustrating the use of a "Event Instrument Plugin", shows a GREEN "Event Input" plugin popping up, not a PURPLE "Audio Input" as I have.  If I REVERT to the setup of VE Pro as a multi-timbral instrument (with no fancy Environment and separate external instruments), I lose individual control of instrument VOLUME, do I not?  Rather limited compositional possibilities there!

Now I get that we are talking about Automation (or Track Based, rather than Region based, in Logic-speak) control.  Okay, so, again, HOW do I control, say, the violins as, say, the third VI Pro instance within VE Pro, but not all the other instances at the same time?  That is, on what TRACK does the automation control occur?  In the usual case in Logic, one uses a key command to bring up Track Based Automation for a given track for the instrument in question and automates away.  HOW is this accomplished using this new plugin? WHERE does the automation occur?  Is the "Event Input Instrument plugin" for Automation of VE Pro parameters ONLY (such as power panning), while individual TRACKS within Logic are for Automation of individual VI Pro instruments within VE Pro (as is normally the case)?

Is it the case that we can still use the old, VE Pro 4 procedure and still use CC based (Region based) control under VE Pro 5, or is this incorrect (that is, follow the recommended procedure in User-Needful Things)?  The advantage to the old procedure is that under Region Based Automation, the Event Window, at the right of the Arrange window, can still be used for precise event editing.  There IS a special Automation event window that can be used for precise Automation editing if one wishes to use Track Based Automation, but I find it cumbersome to use, as it floats about separate from the Arrange window.

Are you saying that under VE Pro 5, to get Automation in Logic, we SEPARATE VI Pro INSTRUMENT tracks (with Region Based MIDI data) from the VE Pro AUTOMATION track, which contains Automation data for ALL instruments (in tracks below) within a given VE Pro instance?  Before, Automation for each track was contained within each track, not on some different track, and it was reasonably easy to figure out which track you were automating.  Are we supposed to keep a list of which automation numbers in the VE Pro Track control which Instrument tracks?  If so, you are talking about several dozen, if not hundreds of -- given the new complexity of VI Pro 2, different parameters in ONE track which I must sort out to control the tracks below.  I can see myself deciding whether Automation parameter number 257 in the VE Pro track controls the horns or the zylophone in the 19th track below.  Under the old system, I go to track 19 and automate it directly.

I believe I had a second question.

2.  In days of yore, with VE Pro 4, to get an additional battery of 15 (not 16) instruments, one simply instanced an ADDITIONAL software track and created the external tracks below.  I mentioned this is my original post.  This works.  How do I get additional instruments using this NEW procedure, and, even as explained, don't I have to create an ADDITIONAL instance of VE Pro, just as in days of yore?  So is the procedure simply to duplicate the original set up?  And again, on WHAT TRACK does the Automation go, and which instance of VI Pro WITHIN VE Pro am I then automating? usw.

As for the "Utility-I/O", where does one put this (VE Pro or VI Pro external track?), and how is this different from the trick of creating a phantom Audio track in Logic, so as to AVOID having a given software track go LIVE when enabled within Logic and blowing your CPU, because, when a track is enabled, Logic turns on every plug-in, all the way down the line? To avoid this unhappy result, we record enable an Audio track we never use.

A request.  Could we have Paul, as VSL Explainer-In-Chief, provide an additional VIDEO for us Logic users, speaking sehr langsam, showing:  (1) the recommended procedure for setting up VE Pro 5 within Logic (is the Environment procedure still recommended, if, as appears to be the case, use of that procedure ELIMINATES the ability to automate tracks, because the Event Instrument Plugin may not be used -- an Audio Input pops up instead), (2) where the Event Instrument Plug-In goes (which track), (3) how to use Automation within Logic for a given VI Pro instance (which track gets automated and how), (4) how to Automate VE Pro 5 ITSELF, and (5) what we do with the "Utility I/0" plug in.

For some reason at this point, and having spent the better part of a rather longish morning and several cups of coffee trying to compose this attempt to clarify my questions, the word "daunting" occurs to me.

A picture, or better a video, would be worth a thousand words.

Steve

IMac, 2.9 GHz Intel 4 Core i5, 32 GB, OSX 10.10.1
Posted on Wed, Nov 30 2011 16:02
by Cyril Blanc
Joined on Thu, Dec 19 2002, Paris France, Posts 2628

Hello

Could you put a Logic song for downloading

Thanks

Cyril

MacPro 2010 12 core 2.93 ghz 64 GB Mac OS X 10.11 2722 Rocket Raid Sata III card with 8 x ssd
VSL lib on a Raid 0 of 4 x 256 GB ssd Sata III - Raid 0 of 4 x 64 GB for other libs
System on a 1 TB ssd
Audio Motu PCI system 84 ins / 64 outs
Kbd : P80 Yamaha, S88 and S25 Komplete Kontrol, DX7
I-Controls Pro, 2xMidi expression pedals
Synth : many....
---
Macbook pro Retina 2.7 ghz 16 GB
---
Mac Mini server 10.10 (server EyeTV, Itunes, WEB, and Backup )
--
Logic X , Dorico, Band In A Box, ORB Composer
VSL : MIR PRO, Appassionata Strings I, Solo strings , Wind and Brass Complete, Dimension Brass, Overdrive
Kontakt, Omnisphere, QLSO, QLSC, CS 80, Arturia V5, Maximo, Realivox Blue. CS 80 V3, The Orchestra, Art Conductor 5, Genesis Children Choir, Lunaris, Lacrimosa

Final Cut pro
Camera full HD
Posted on Wed, Nov 30 2011 18:07
by Ege
Joined on Sat, Jan 22 2005, Washington, DC, Posts 104

Cyril

Happy to do so, but you will have to tell me how to do that.

Steve

IMac, 2.9 GHz Intel 4 Core i5, 32 GB, OSX 10.10.1
Posted on Wed, Nov 30 2011 18:13
by Karel
Joined on Mon, Jan 19 2009, Belgium, Posts 2173

The VE Pro Event Input plugin is an instrument AU, just like the main VE Pro Server Interface plugin. So instead of adding a second VE Pro Server Interface plugin, you add a VE Pro Event Input plugin and assign it to an existing connected VE Pro Server Interface plugin. That is basically all there is to it.

Karel Bassez
Software Engineer
Vienna Symphonic Library
Posted on Wed, Nov 30 2011 18:32
by Cyril Blanc
Joined on Thu, Dec 19 2002, Paris France, Posts 2628

Hello Karel

May be it is the vapor pf the French Champagne we are having on our all inclusive holidays, It is not very clear Confused

Can you put a Logic song with an example of 32 VI 

If you could fix the PDF of the manual so we can zoom on the image that will help !

Thanks in advance

Best

Cyril

P.S I will be home next week and I will do trials

MacPro 2010 12 core 2.93 ghz 64 GB Mac OS X 10.11 2722 Rocket Raid Sata III card with 8 x ssd
VSL lib on a Raid 0 of 4 x 256 GB ssd Sata III - Raid 0 of 4 x 64 GB for other libs
System on a 1 TB ssd
Audio Motu PCI system 84 ins / 64 outs
Kbd : P80 Yamaha, S88 and S25 Komplete Kontrol, DX7
I-Controls Pro, 2xMidi expression pedals
Synth : many....
---
Macbook pro Retina 2.7 ghz 16 GB
---
Mac Mini server 10.10 (server EyeTV, Itunes, WEB, and Backup )
--
Logic X , Dorico, Band In A Box, ORB Composer
VSL : MIR PRO, Appassionata Strings I, Solo strings , Wind and Brass Complete, Dimension Brass, Overdrive
Kontakt, Omnisphere, QLSO, QLSC, CS 80, Arturia V5, Maximo, Realivox Blue. CS 80 V3, The Orchestra, Art Conductor 5, Genesis Children Choir, Lunaris, Lacrimosa

Final Cut pro
Camera full HD
Posted on Wed, Nov 30 2011 19:47
by Talino
Joined on Sat, Jul 17 2010, Posts 260

I've paid for the upgrade but haven't installed it yet because of this, and because I'm mid-project.

However, since the main reason for my upgrading was the proposed solution to the 16 MIDI channel limitation — and after reading all the above (and the manual) — I'm wondering if it's at all compatible with my way of working in Logic.

For each bunch of 16 instruments (VSL VIs, LASS patches loaded in Kontakt, etc) I have a VEP instance which communicates with a VEP plugin inserted on a Software Instrument in Logic. The latter plays what is essentially the NET1/2 outputs of the VEP instance. All other NET outputs are received in Logic via AUX channels.

Now, I'm *playing* each and every instrument through custom Multi-Instrument objects which are connected (in the Environment) to the Software Instrument, triggering the proper MIDI instruments in VEP. These are the only tracks that appear in Logic's Arrange Window. I only add the actual Software Instrument (or AUX objects) as a track when I need to do some automation.

From reading the above, I'm wondering how the VEP 5 solution integrates into this, as there is a very clear separation between MIDI and audio in my setup. How will the Event Input handle additional MIDI channels when the MIDI data itself is played on a Multi-Instrument track, not a Software Instrument track?

A screencast would be most helpful since apparently I'm not the only one finding this very confusing.

Thanks.

MASTER: Cubase Pro 10.0.20, iMac 27 2015 i7 4.0 (17,1) 24gb RAM, OS X 10.14.4, RME Fireface UC. SLAVE: Mac Pro 2009 Quad 2.66 (4,1), 28gb RAM, OS X 10.11.6, Vienna Ensemble Pro 7, samples on OWC Accelsior SSD.
Posted on Wed, Nov 30 2011 20:19
by Ege
Joined on Sat, Jan 22 2005, Washington, DC, Posts 104

I would like to second your, and my, request, for CLEAR guidance on HOW one sets up VE Pro 5 in Logic 9.  I sounds as though Talino has the same setup, with VE Pro 4, that I have, viz., the one set out in the User Area under Needful Things:  one software instrument track for VE Pro, configured an NON-multi-timbral instrument, a multi-instrument set up in the Environment and cabled to the VE Pro channel strip just set up, and then, back in the Arrange window, additional, EXTERNAL tracks that are assigned to the multi-instrument just set up in the Environment, each of these tracks having its own MIDI channel, using the Library tab to do the assigning.

I cannot understand whether this VE Pro Event Plug-in gets (1) its own, separate track (the way we used to do it in VE Pro 4, when we put in another instance, as a non-multi-timbral instrument, of VE Pro, in order to create an additional 15 instruments, of (2) whether the Event Plugin is inserted, as a plugin (not a separate instrument with its own track), to the EXISTING VE Pro instance.  If the latter, (2), do I then create an ADDITIONAL multi-instrument in the Environment to get my additional External Instrument tracks?  To WHAT is this new multi-instrument in the Environment cabled?  Just as important, WHERE is the Automation to take place, that is, in what track?  All in ONE track -i the VE Pro Track, or, as it should be, in each instrument track, so that there are up to an equal number of External tracks for instruments and Automation tracks? And another Automation question, where does the Automation for the VE Pro ITSELF take place? If (1), then on the Event Plug In Track, if (2) on the Ve Pro track?

Finally, again, IF I am to insert the Event Plugin as a Plug-In (not as an instrument with its own track) into an existing VE Pro instance, then, under the set up I describe above, and which I believe Talino has as well, the Plug-in pops up as an "Audio" plugin, NOT an EVENT plug-in as it appears in the VE Pro 5 manual.  This occurred on a new, otherwise empty project which I set up for testing purposes.

Perhaps Paul could provide an explanation that users like me could more easily follow.  Again, a VIDEO would be VERY helpful (hint).

I have not reached the stuttering and silence problems mentioned in another post, because I am reluctant to commit projects to this new software until some clarification (and possibly a maintenance release of VE Pro 5) made available.

BTW, I, too, paid for the Upgrade, site unseen, based on VSL's reputation and my prior experience with the company.  I am sure this will be sorted out, even if it turns out that there are no software issues, just an "understanding issue" by some users like me.

Steve

IMac, 2.9 GHz Intel 4 Core i5, 32 GB, OSX 10.10.1
Posted on Wed, Nov 30 2011 22:05
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 11305

Hi, 

I´m showing the Event Input Plug-in at around 4:20 in the VE PRO 5 Overview Video

There is not more to it....

All relevant information for Logic Users can be found on the pages 16 ff and 33.

Of course there will be more demos to come, but unfortunately the day only has 24 hours....

I´d be happy to hear about better explanation for this feature from fellow users!

Best, 

Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Thu, Dec 01 2011 09:07
by cojoncio
Joined on Tue, Apr 20 2010, Spain, Posts 74
Master: i9 7900x OS X 10.12 Digital Performer
Slaves: i7 3930k. Windows 7 - Mac Pro 12 core. OS X 10.12
Posted on Thu, Dec 01 2011 10:05
by Talino
Joined on Sat, Jul 17 2010, Posts 260

Thanks a lot for taking the time to write this very clear explanation. Can't wait to check it out but I'll wait until my project done... [sigh]

MASTER: Cubase Pro 10.0.20, iMac 27 2015 i7 4.0 (17,1) 24gb RAM, OS X 10.14.4, RME Fireface UC. SLAVE: Mac Pro 2009 Quad 2.66 (4,1), 28gb RAM, OS X 10.11.6, Vienna Ensemble Pro 7, samples on OWC Accelsior SSD.
Posted on Thu, Dec 01 2011 13:46
by cojoncio
Joined on Tue, Apr 20 2010, Spain, Posts 74

Cool. I hope it helps you. I also hope it's clear enough. English is not my mother language :)

Post your results to see if there's something else I can do.

Master: i9 7900x OS X 10.12 Digital Performer
Slaves: i7 3930k. Windows 7 - Mac Pro 12 core. OS X 10.12
Posted on Thu, Dec 01 2011 14:39
by Karel
Joined on Mon, Jan 19 2009, Belgium, Posts 2173

The I/O Utility plugin is required if the I/O buffer size and Process Buffer Range setting are not identical in Logic (which is almost always). Process Buffer Ranges: Small = 512, Medium = 1024, Large = 2048. Otherwise you will get artifacts and dropped MIDI messages depending on which track is selected in Logic.

Karel Bassez
Software Engineer
Vienna Symphonic Library
Posted on Fri, Dec 02 2011 22:49
by Ege
Joined on Sat, Jan 22 2005, Washington, DC, Posts 104

Cojoncio --

Thank you for your clear statement of the set up.  I did, indeed, get 30 channels to work.  The inability to individually control volume through CC7 remains, as ALL instruments for a given instance of VE Pro (or the VE Event Input) are controlled at once.  It is for this reason that I use the envirnonment approach, rather than the multi-timbral approach.

Unfortunately, problems of SILENCE have emerged, with NO tracks providing audio output.  I installed the latest (9753) version of VE Pro, and all was well, UNTIL I tried to install a 3rd set of 16.  The VE Pro Manual provides no guidance on this (in case you want more than 30 tracks), so I tried repeating the process for a second set, as you did with the first two, making the second instance of the Event Input plugin a MIDI in 4.  In this configuration, the third set of 16 (with the VE Pro 5 itself instanced), was silent, but showing input from the VI Pro instruments in the track, while the FOURTH set of instruments produced sound! 

Then, for some reason, I got no sound at all, although If I open up the VE Pro interface, I can play the keyboard window and hear sound!

So, at present, I am stuck using no more than 30 tracks and dare not try more.

We could use a little more help here.

Again, thanks for your very helpful post.

Steve

IMac, 2.9 GHz Intel 4 Core i5, 32 GB, OSX 10.10.1
Posted on Sat, Dec 03 2011 01:38
by Karel
Joined on Mon, Jan 19 2009, Belgium, Posts 2173

Did you correctly put the Logic track that has the Event Input plugin into Live mode?

Karel Bassez
Software Engineer
Vienna Symphonic Library
Posted on Sat, Dec 03 2011 03:14
by Ege
Joined on Sat, Jan 22 2005, Washington, DC, Posts 104

Karel

On BOTH Event Input plugins, I added the Utility-I/O and set it for output 1-2 (clicking on the radio button to light it up), and then Bypassed both.

This is what I did:

To test things out, I started with a new, blank project.  I followed the advice of poster Cojoncio in this thread and got things to work -- at least for a while.  As stated, what I did FIRST was set up a VE Pro instance as a multi-timbral software instrument and then add an additional 15 tracks, and SECOND add ANOTHER multi-timbral software instrument, but instance the Event Plugin (instead of a VE Pro instance) and set it to MIDI in 2 (which your directions in the Manual do not discuss), THEN I get the full 30 channels (since I reserve channel one on both Instruments 1 and 2 for the VE Pro and Event Input plugins), and they work properly.  In other words, I had TWO groups of 16 tracks, the first 8 labled "inst 1"; the second labled "inst 2".  The VI Pro instances within VE Pro were set to MIDI In 1 and MIDI In 2, and each instrument was properly set to its own channel, e.g., MIDI 1, channel 2, MIDI 1, channel 3, MIDI 2, channel 2, MIDI 2, channel 3, etc.

I then tried to add additional tracks by adding additiona AU instances.  First, I tried to use just the Event Plug in to create my additional groups of 16.  That didn't work, as explained below, so then I decided to just duplicate what I had done to get the first 32 track, but use MIDI In 3 and 4.

I first tried to get a THIRD group of sixteen by setting up the multi-timbral software instrument, by instancing the Event Plug-In only, but found that when the green Event Plugin window opened there was nothing to Assign it to.

So I tried another approach.  I tried duplicating what I had done with the first set of 32 tracks, but using MIDI IN 3 and MIDI In 4:

Again, the procedure was:

1.  Software multi-timbral instrument - VE Pro with 16 tracks

2.  Software multi-timbral instrument - Event Plug-in Assigned to the first instance in the VE Pro Server (shows up as "[1]"), Input to MIDI 2, an additional 16 tracks gained (32 so far).

3.  Third Software multi-timbral instrument - VE Pro with 16 tracks  (I now have a total of 48 tracks) (unable to assign to MIDI 3 when the VE Pro popup appears, unlike Event Plug-In windows).  ==> I cannot figure how to assign to MIDI In 3 for this AU.

4.  Fourth Software multi-timbral instrument - Event Plug-in Assigned to the second instance in the VE Pro Server (shows up as "[2]"), Input to MIDI 4

5.  Added Utility-I/O Plug-in to 2 and 4, above, clicked radio button to activate output, and Bypassed.

6.  Added VI Pro instances within VE Pro and assigned to MIDI 1, 2, 3, 3.  I had trouble here, because one of the VE Pro windows did NOT have the VI Pro instances I had set up in (3) above -- the second VE Pro instance.  So I added ADDITIONAL VI Pro instances and set them at MIDI IN 3 (for the second VE Pro instance).

I recorded a short strip of music in a Region.  I played the Region in 1, 2, 3, and 4.  For groups of 16 1, 2 and 4, in each case, ALL instrument volume meters in every track (i.e., in each group of 16) showed a signal in the small meter that appears at the beginning of each track, and I could hear sound in the track being played. All 16 lighted up at once in each group.  So in the 1, 2 and 4 groups of sixteen tracks, it appeared to work (I could hear the Region played).

In 3 (the one with the second VE Pro instanced), the track in which I inserted the Region with MIDI notes showed the meter at the beginning of the track working, but I got no sound.  Also, NONE of the OTHER instrument 3 tracks showed activity in the meters.  In other words, the other 15 tracks showed no sign of activity.

When I opened the VE Pro Mixer windows for 1, 2, 3 and 4, and then opened up the VI Pro instances I had added within each, I was ABLE to play the keyboard window with the mouse and hear sound.  In other words, until I tried to record and play something,it appeared that all was well in each of the 64 tracks.

At some point, ALL tracks STOPPED sounding and there was SILENCE,
even though I had not changed any of the setup.  It had something to do
with playing the music.  Even the FIRST set of tracks did not work. 
HOWEVER, when I opened up individual VI Pro instrument instances within
VE Pro the keyboard still played when I used the mouse and I could hear sound.

At the present time,I don't know how to set the SECOND instance of VE Pro to MIDI input 3, and am generally at a loss as to how I am to exceed the limit of 32 tracks.

System:  OSX 10.6.8.  2.8 GHZ Intel Core 2 Duo IMac, 6GB RAM,   VE Pro 9753 (latest version from your website).  Logic 9.1.5.

I would be happy to upload some screenshots if that would help.  You will have to provide me with an email address or show me how to add a graphic file to one of these posts on the forum.

Karel -- I know you have your hands full.  Rather than responding to my specific problem, it would be more helpful to me (and perhaps others), to either AMEND the VE Pro Manual or, better, put together a VIDEO, showing the SUCCESSFUL set up of, say 64 tracks within Logic, making sure to tell us, as Cojoncio did, EXACTLY what specific steps need to be taken and buttons need to be pressed to get the system to work.  Part of the problem is language -- this is why pictures of the various steps would be best, then everyone knows what you are talking about.

I have more than abstract interest in this, because I have just ordered an Apple Mini Server for the spefic purpose of handling VE PRO and the Vienna Instrument library.  It arrives in a few days.

Thanks for your attention.

Steve

IMac, 2.9 GHz Intel 4 Core i5, 32 GB, OSX 10.10.1
Posted on Sat, Dec 03 2011 17:35
by eljodon
Joined on Sat, Dec 04 2010, Valencia, Ca, Posts 34

I also use the enviroment approach, I usually take a long time to upgrade, since I can't afford to have down time. I made the mistake of upgrade, so now I have to go back to Pluge Bidule and musiclab midiLan! The horror!

-Mac Pro 2.93Ghz 8 core,24 gigs RAM,4 TB Raid,(4)1 Tb audio drives Pro Tools 10 HD 4,(3) I92 io,Sync io, Apogee Big Ben,Apogee PSX-100 2010 Mac Pro 3.46 GHz 12 core 48 gigs, Areaca SANS, (4) 1 TB SSD, RAID (4) 650 gig Velociraptor RAID. (2) Motu 2408 Mrk 3 (4) 1 Tb SSD, RAID with(4)650 gig Velociraptors, Cubase 10 (2) Motu 2408 Mk 3 -Mac Pro 2.66 Ghz 12 Core,48 Gig RAM, Samsung 1 Tb SSD 850 EVO RAID 0,(4) 600 Gigs WD Velociraptor RAID, (4) WD black 1 TB RAID O,Areca 1213-4i, Newer Tech MAXPower RAID mini SAS 6G-2e, VE Pro 5,Ableton Live 9,Altiveb 7, Vienna Cube & App Strings extended,East West Hollywood Strings,SD2,EWOL,Symphonic Choirs,etc.UAD PCI quad SSL X Rack, API,Avalon,Chandler Limited,Avalon Marshall Plexi 69/69, Metro/Friedman 68 Plexi ,Friedman BE100, Suhr PT100,ENGL Powerball 2,VOX AC-30, Fractal Axe FX 2 and lots of guitars & Basses!
3 Pages123>
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.