Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Pro Tools 12, VE Pro 6 and High CPU
Last post Fri, Feb 22 2019 by cojoncio, 6 replies.
Options
Go to last post
Posted on Mon, Nov 20 2017 06:43
by jmgotsoul
Joined on Fri, Aug 04 2017, Los Angeles, Posts 7

I am a fairly new VE Pro user. I was first having an issue with VE Pro crashing but I have resolved that by reducing the number of instanes of Kontakt that I have loaded. I now have a VE Pro template that seems to be stable. I have a corresponding template in Pro Tools 12 that is built to work with my VE Pro template. I have noticed that when my Pro Tools template loads up, the CPU jumps up anywhere between 1500% and 1750%. If it's too high the audio is garbled and it basically doesn't work. Here is some information on my configuration:

My Computer:

  • Mid-2012 Mac Pro running macOS Sierra 10.12.6
  • 128 GB RAM
  • Two 3.33 GHz 6-core processors (24 virtual cores)
  • Three 2TB SSD SATA drives. One of the drives contains all of the libraries loaded into VE Pro.
  • Pro Tools and VE Pro are currently running on the same computer.

My VE Pro template:

  • Seven instances.
  • Per instance: 3 threads, 16 MIDI ports, 32 audio outputs, 2 audio inputs.
  • Each channel has one instance of Kontakt.
  • Most instances of Kontakt have one or more libraries of the same kind of instrument. Ex: Violins 1, Horns, Oboes, etc. There are some instances where this is not the case.
  • All instruments are purged so that by default no samples are loaded.
  • Multiprocessor support in Kontakt is turned off.
  • Each instance of Kontakt can route to up to 16 stereo outputs. For instances where all of the libraries are the same type of instrument, they all route to the same stereo output (st. 1). For the ones where they aren't the same instrument, each library routes to it's own stereo output.

My Pro Tools template:

  • One MIDI track for every instrument loaded into VE Pro.
  • One aux track for each output that is used from each VE Pro channel.
  • Seven aux tracks have the VE Pro plugin inserted.
  • Each VE Pro plugin is configured to be connected, preserved and decoupled with 2 buffers.
  • The template is configured with a 24-bit bit rate and 96KHz sample rate.
  • Pro Tools is configured with a buffer size of 1024.

I have fully verified this high CPU usage is definitely when my Pro Tools template loads up. I execute the following steps:

  1. Start VE Pro
  2. Load my VE Pro template
  3. Load at the CPU usage (it is consistently a low number)
  4. Start Pro Tools
  5. Load my Pro tools template
  6. Look at the CPU usage (at this point it will be significantly higher)

I can get around this by disconnecting the VE Pro plugins that I am not using but I was wondering if anyone might have some suggestions or thoughts as to why the CPU usage goes so high?

Julian Montgomery
Posted on Tue, Nov 21 2017 06:13
by jmgotsoul
Joined on Fri, Aug 04 2017, Los Angeles, Posts 7

Some additional information I discovered today...

As I stated, once I have VE Pro and Pro Tools up and running my CPU usage can be very high. What I discovered today is if I go into VE Pro and disable a few channels, the CPU usage is drastically reduced. An example today is the CPU usage was around 1700% and after randomly disabling 4 channels the CPU usage went down to around 400%. If I then turn around and re-enable the channels the CPU usage remains low. I tried this out 3 times and every single time I saw the same behavior.

I have no explanation for this but I wanted to add this information in case it helps someone to help me.

Julian Montgomery
Posted on Tue, Feb 12 2019 21:23
by Eric Owyoung
Joined on Fri, Aug 24 2018, Posts 1

I'm having the same strange issue!  Did you ever find a solution?

Posted on Wed, Feb 13 2019 09:35
by Rithem
Joined on Tue, Aug 20 2013, Posts 2

Hey All,

I hope paul reads this... I have some info that surely will help look further into the problem.

I have been bulding my template for the last 3 months. It is very solid, except for this problem. 

There is a bottleneck somewhere and in CAN be found. 

So: 

Master: Mac Pro 12 core, 128GB Ram, Sierra, Only SSD. Pro Tools 12

Slave: Mac Pro 12 core, 128GB Ram, Sierra, Only SSD.

Template: ca 90 returns/auxes. The last 300 are all midi tracks. 

Amount of AAX plugins in use: 2. To be exact "VEP local" And "VEP Slave"

VEP Buffer 1 or 4, doesnt make a difference. 

22 CPU meters show max 6% when playback stopped. 2 show 100%

Total shows 100. This when keeping Playback engine buffer size on 256. 

Bringing that down to 1024 gives a 55% total and playback is possible. 

(Who wants to make music on 1024?)

NOW THIS looks like an problem in Pro Tools, where something syncing up with VEP doesnt work like it should, right? Paul? 

Thanks in advance!

 

Warm regards,     Jan 

Rithem attached the following image(s):
ptuncool.png (26kb) downloaded 0 time(s).

You cannot view/download attachments. Try to login or register.
Posted on Fri, Feb 22 2019 02:31
by Falcowe
Joined on Mon, Nov 06 2017, Nashville, Posts 5

Hey everyone,

So I wanted to chime in here. In building my own template in ProTools I have found out many things and I ran into problems like this as well. First to respond to the OP Julian, since its working some of the time I would guess that this is CPU bound. And since you are running VEPro and PT on the same computer I would guess that your computer can't handle the load at reasonable buffer sizes. Also since you can disconnect/turn off plugins and it works would also indicate that your CPU isn't able to handle the whole template you are trying to use. To add to this you are running all of your samples off of one drive, which yes I can hear you furiously typing, is SSD but remember that the SATA interface on what I assume is a 2012 MacPro 5,1 is 3 Gb/s add to that (depending on the quality of your SSD) delays in the response times of the SSDs and you just add more stress to your CPU which is trying to do this with the "DAW-that-wins-the-award-for-not-playing-nicely-with-others". I do have a question for you though, you said you have a dual CPU Cheesegrater with 2 3.33GHz CPU's... I couldn't find that as a shipping system built by Apple from the 5,1 lineup. Did you put in "aftermarket" CPU's or is this a stock config? Are you sure that is your base clock or is that the turbo clock speed? I would also be slightly concerned about RAM speed, but I haven't really looked into what speed causes bottlenecks. But its low enough that I would look into it. And finally, I would try setting up your template at 48kHz, in fact I would guess this might solve half of your problem since at 96k you have half the time you would at 48k putting twice the strain on your CPU. The higher your sample rate the less time your CPU has to do the same amount of work, the less time your SSD has time to respond, the less time your RAM has to respond. // Oh and in regards to your follow up post. Were these channels virtual instruments? Reverbs? Any correlation to what you disabled? And what if you started using those VI's, plugins again? Did CPU usage increase? Maybe something in Kontakt is loading, and when you turn it off and then on again it isn't loading until its used? Or maybe its something to do with ProTools and Dynamic Plugin Processing? Do you have that enabled? Maybe try disabling it and seeing what happens?



Jan - I saw this same behavior (if not so extreme) when I was troubleshooting VEPro and PT. And I still do see this uneven core usage reported by PT today when everything is working. However when it didn't work it was because PT was unable to handle the Project I was trying to playback. But since you said that it doesn't matter what VEPro buffer you set I would guess that your slave machine is hitting above 80% CPU usage? Or maybe higher? Whenever this happen for me (i.e. I put a synthetic load on my slaves and run an active VEPro project) I hear dropouts of instruments, pop and clicks, or a playback error, combine with high CPU spikes reported by PT. And its always because my slave CPU usage is too high. Also if you are also running a 5,1 MacPro then I would guess in addition to high CPU usage slow 3Gb/s SATA interfaces, and a single SSD for samples as contributing factors to inoperablility. But a few questions for you as well, are you running 5,1 MacPros? What are their specs (especially CPU)? Dumb question, but are you running a gigabit network on all machines (built in NICS on 5,1 MacPros are Gigabit, just want to make sure you aren't running through a 100 Mbps switch or anything like that causing a bottle neck)? The lowest setting for VEPro I would set is project at 48kHz sample rate, VEPro at buffer 2, ProTools at buffer 256. Anything lower I have found to be unstable or unusable. And finally remember that AVID/ProTools doesn't play well with others, so maybe this is a PT glitch, have you tried the standard trouble shooting steps? Trashing Prefs, rebooting? Uninstall and reinstall? I'm having no problems here running 512 MIDI tracks and 250 voices on my system, so it does work... but it can be a pain to get it to work.

 

Sorry for the long post, hope it was helpful.

-Walter

ProTools 2018.12 Ultimate - DAW Machine: Windows 10, Intel 7920X 4.3GHz, NVIDIA GTX1070, 64GB 3200MHz - Slave 1: Windows 10, AMD 1950X 4.2GHz, NVIDIA GT710, 64GB 2666MHz - Slave 2: Windows 10, Intel 7820X 4.7GHz, NVIDIA GT710, 64GB 3666MHz.
Posted on Fri, Feb 22 2019 10:20
by cojoncio
Joined on Tue, Apr 20 2010, Spain, Posts 74

Originally Posted by: jmgotsoul Go to Quoted Post

Some additional information I discovered today...

As I stated, once I have VE Pro and Pro Tools up and running my CPU usage can be very high. What I discovered today is if I go into VE Pro and disable a few channels, the CPU usage is drastically reduced. An example today is the CPU usage was around 1700% and after randomly disabling 4 channels the CPU usage went down to around 400%. If I then turn around and re-enable the channels the CPU usage remains low. I tried this out 3 times and every single time I saw the same behavior.

I have no explanation for this but I wanted to add this information in case it helps someone to help me.

 

This is something to do with mac OSX. I run into this problem anytime. I'm on Digital peformer 9.5 and 10. As jmgotsoul and others pointed in this forum, some channels must be disabled and then enabled to make it work without reaching a massive percentage of usage. This problem only happens when the DAW connects the VEP template. Otherwise the percentage is low. And as I said before, it only happens in Mac. My Windows server doesn't need to have channels disabled/enabled.

It's not a big deal. Load VEP template(s), launch DAW, disable/enable a few channels in your VEP and then you're ready to go. I need to do this every time I open different projects, but working with preserved instances this workaround only takes less than a minute or so.

Master: i9 7900x OS X 10.12 Digital Performer
Slaves: i7 3930k. Windows 7 - Mac Pro 12 core. OS X 10.12
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.