Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
VEP7, BBCSO and Sibelius
Last post Fri, Jan 31 2020 by IDontHaveOne, 1 replies.
Options
Go to last post
Posted on Fri, Jan 31 2020 16:06
by IDontHaveOne
Joined on Mon, Jan 13 2020, Posts 1

Hi everyone,

After spending the past two weeks fiddling and trying, I may have arrived at the point where I've gone insane. In which case, huzzah.

I recently bought a new studio PC, an AMD Threadripper 3960X processor with 128GB DDR4-3000 RAM, running Windows 10. All disks in the machine are M2, Samsung Evo Plus disks. I use an MOTU Ultralite-MK4 audio interface.
All drivers are up to date, all software is up to date.

I also purchased Spitfire's BBCO Symphony Orchestra, and love its sound. I originally tried to get all the plugins loaded directly into Sibelius, but that was hardly a success; as BBCSO requires a plugin per instrument, I ended up with about 55 different VST2 plugins in Sibelius (Sibelius does not support VST3). So, I decided to get myself VEP7 to handle all the VST loading and configuration, and I must say I am very happy with it! 
VEP software and Sibelius run on the same machine.

However, even with all this, I still run into audio glitches in Sibelius. I'm reworking a Beethoven score with about 15-16 instruments, all BBCSO instruments used through VEP. I have one VEP instance loaded into Sibelius, and about 9-10 VEP Event Plugins to address the virtual instruments. In VEP Server, I have one instance with a total of 55 plugins. Multithreading in VEP is presently at 16 threads per instance, though I have already changed this from 1 to 48 and everything in between, without avail.

When playing back the score, there is a point where the instruments come to a crescendo, and after this, regular as clockwork, there is a glitch. The same sort of glitching occurs later in the score as well. It's not the samples, I've listened to everything separately. As my machine should be able to handle this setup quite easily, I've tried a variety of sample rates, buffer settings, et cetera. Adding loads of buffer makes it go away, but that hardly seems like a solution (also because it introduces quite some latency in Sibelius).

I've been in touch with Spitfire on this, but not fix yet there. It seems to me that my machine should have no problem whatsoever working like this. I downloaded ProcessExplorer to have a look at CPU usage in more detail, and noticed that one or two CPUs were pushed to the max during that specific crescendo, while the rest seems to be picking their noses.. I've added a picture of this. 

Am I going insane, or is there an issue going on here? Is there some multithreading issue I am missing? Is this the Spitfire plugin perhaps? Anyone else out there who might have similar experiences?

IDontHaveOne attached the following image(s):
CPUU0020usageU0020Beethoven.png (58kb) downloaded 0 time(s).

You cannot view/download attachments. Try to login or register.
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.