Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Options
Go to last post
Posted on Thu, Aug 06 2020 06:30
by brett
Joined on Fri, Aug 19 2005, Australia, Posts 87
Hi
 
I recently purchased Synchron Percussion I Drums and the Bass drum has a strange ringing that I can only describe as that high pitched sound you get when you lower the bit rate. I thought it was restricted to the Bass drum but it is actually all of my Synchron library instruments, it's just more noticeable with low frequencies (with high frequency sounds the ringing is masked).  For example, the ringing is also present in Big Bang Dorado and Eridanus.
 
I've attached a WAV file to illustrate.  Is it some sort of weird sample rate mismatch or something?  This sound is not present in any of my Vienna Instruments or Kontakt libraries
 
Suggestions?
Thanks - Brett
 
 
ps - I've also asked support but have yet to hear back.
File Attachment(s):
BDU0020ringing.wav (3,447kb) downloaded 7 time(s).

You cannot view/download attachments. Try to login or register.
Posted on Thu, Aug 06 2020 08:48
by brett
Joined on Fri, Aug 19 2005, Australia, Posts 87

I've just discovered that working in Cubase at 44.1kHz fixes the problem.  However, I have to work and deliver at 48kHz.  Can the Synchron player work at 48kHz?

I've tried hosting the Synchron player in Cubase directly or in VEP and the ringing is present with the sample rate set to 48kHz but not at 44.1kHz.

When using the Synchron player in stand-alone the same is true - if I go into preferences and set the sample rate to 48kHz (and my RME interface Hammerfall DSP Settings changes the sample rate to reflect this as you'd expect) the ringing is present.  Switching back to 44.1kHz in the standalone application (with my RME interface Settings mirroring this as normal) and the ringing is gone

Like I said in my earlier post, I don't have this behavior in the Vienna Instruments plugin

Help!

Brett

Posted on Sat, Aug 08 2020 02:13
by brett
Joined on Fri, Aug 19 2005, Australia, Posts 87

Update:

Increasing the sample rate to 88.2kHz or 96kHz in the standalone Synchron player makes the high digital buzzing much worse, to the extent that the original sample being played is unrecognisable. 

It's like there is a huge mismatch between the Synchron player and the audio interface (RME Hammerfall DSP Multiface II).

No such problems in the Vienna Instruments standalone player

Brett

ps - tested in the just released v1.1.1949 too

Posted on Sat, Aug 08 2020 13:20
by bbelius
Joined on Sat, Mar 14 2015, Posts 837

Hi Brett,

I could not reproduce this issue. Could you please add on which operating system and what version of it you are running?

Best, Ben

Ben
Vienna Symphonic Library
Posted on Sat, Aug 08 2020 21:55
by brett
Joined on Fri, Aug 19 2005, Australia, Posts 87

Thanks Ben.  I really appreciate your reply

I'm using Windows 10 Pro, version 1903, OS build 18362.30 (my DAW builder has it locked down so there are no unexpected updates). 

Perhaps I could try a much earlier version of Synchron player to see if there is something missing in the OS that the newer players rely on? Is there any specific targeted component update I would need to install for compatibility with current Synchron player versions?

Brett

Posted on Sat, Aug 08 2020 23:07
by bbelius
Joined on Sat, Mar 14 2015, Posts 837

I'm currently running the same OS version. Have you tried uninstalling the RME ASIO driver, rebooting and re-installing them?

Ben
Vienna Symphonic Library
Posted on Sat, Aug 08 2020 23:49
by brett
Joined on Fri, Aug 19 2005, Australia, Posts 87

Hi Ben.

As you suggested I just tried uninstalling the RME drivers, rebooting and re-installing and rebooting again.  There's no change.  And as I mentioned above, if I switch the sample rate to 88.2kHz or 96kHz it sounds even worse than at 48kHz - more like 6-bit or 8-bit samples, despite the sample rate of the RME and Synchron player matching.

Everything still works fine at all sample rates with the stand alone Vienna Instruments player, although during stress testing this player (forcing multiple sample rate changes in the preferences) I did manage to reproduce the digital buzzing sound but toggling the engine on and off fixed this.  Short answer, is that I can play all Vienna Instruments libraries perfectly at any sample rate but the Synchron player only plays cleanly without digital artifacts at 44.1kHz.  Is there a 'reset engine' setting or 'restart engine' setting on the Synchron player?

As an experiment I tried installing the oldest version of the Synchron player I had an archive of (v1.1.1559) but there was no difference.

Any other suggestions?  This is becoming time sensitive now because I'm keen to integrate my recent Synchron purchases into my template for an upcoming commission.

Thanks again for your assistance Ben.  Much appreciated.

Brett

Posted on Sun, Aug 09 2020 00:52
by bbelius
Joined on Sat, Mar 14 2015, Posts 837

Hm, I'll talk to my colleagues on monday about this.
Could you switch the playback engine in Synchron Player Standalone to your on-board sound-card, just to rule out any driver/soundcard issues?

Ben
Vienna Symphonic Library
Posted on Mon, Aug 10 2020 03:52
by brett
Joined on Fri, Aug 19 2005, Australia, Posts 87

Thanks Ben!

Want to hear something weird?  As I have onboard sound disabled, to test your suggestion I installed ASIO4All to bypass the RME driver.

ASIO4All works perfectly at 44.1kHz AND at 96kHz BUT the digital ringing is present at 48kHz
The RME works perfectly at 44.1kHz but gets progressively worse at higher sample rates BUT if I toggle the preferences wrench without changing anything I can get the RME to work at 96kHz perfectly (This is a new discovery).  So on my system it's a problem with upsampling to 48kHz only.

My concern is that VSL will say 'it's a driver issue' and RME will say 'it's a Synchron player issue'.  Well, clearly it's not just a driver issue because there are problems with both RME and ASIO4All drivers at 48kHz in my system.  And because there's no problem with the Vienna Instruments player at 48kHz it's true that it is a Synchron player issue. 

It feels like that there is a problem with the Synchron player upsampling from the native 44.1kHz to 48kHz in some systems, and this can be demonstrated with multiple ASIO drivers.

I've attached a video with me illustrating the behaviour I described above and you can clearly hear the digital ringing at 48kHz and not at 44.1kHz even through my iPhone's crappy mic.  Listening to the movie through headphones makes it even clearer. The same behaviour is exhibited by the RME driver and the ASIO4All driver so is driver independent.

Looking forward to hearing more

Brett

File Attachment(s):
SynchronU0020PlayerU0020upsamplingU0020issue.mov (27,079kb) downloaded 9 time(s).

You cannot view/download attachments. Try to login or register.
Posted on Fri, Aug 14 2020 09:19
by MS
Joined on Wed, Feb 19 2003, Vienna, Austria, Posts 1760

Hi Brett,

first of all - ensure to close down the Standalone and delete your Synchron Player Standalone preferences file:
%APPDATA%\VSL\Vienna Synchron Player Standalone.ini

This will ensure that we're starting from a fresh situation.

Then, select the RME driver only, choosing your preferred samplerate and latency. Please note that using a samplerate other than 44.1kHz will just cause a higher CPU usage and worse sound, since everything has to run through a samplerate converter.

Switching samplerates with the RME driver should be possible from the preferences window, without any strange artifacts as you have reported.

Regarding ASIO4ALL, I have tested this driver together with RME Fireface UCX, and I cannot make it work at all when switching between samplerates, regardless if I'm doing so in a VSL product or simply just in Cubase or Nuendo. I would not recommend anyone using this driver, if you already have a proper soundcard with a proper ASIO driver. 

--
Martin Saleteg
Software Developer
Vienna Symphonic Library GmbH
Posted on Sat, Aug 15 2020 08:44
by brett
Joined on Fri, Aug 19 2005, Australia, Posts 87

Firstly, thanks for much for the reply Martin

Originally Posted by: MS Go to Quoted Post
first of all - ensure to close down the Standalone and delete your Synchron Player Standalone preferences file:
%APPDATA%\VSL\Vienna Synchron Player Standalone.ini

There was a 'Vienna Synchron Player.ini' and 'Vienna Synchron.ini'.  I backed up and deleted both. I had to point the player to correct 'volume scan path' for my presets to appear.

However, regarding the sample rate issues, deleting the preferences made no difference.  The digital 'bit-crushing'-like artifacts are present only at 48kHz but not at 44.1kHz, 88.2kHz or 96kHz .  In other words the behaviour of the Synchron player is still identical to the quicktime attached to my earlier post.

I posted my findings over at VI-control (linked to here) and there are other users who are experiencing the exact same digital artifacts only at 48kHz.  This means it is not something that is unique to my system.  Ben has promised me over there that he would look into it, informing me that has been assigned my tech support case.

Originally Posted by: MS Go to Quoted Post
Please note that using a samplerate other than 44.1kHz will just cause a higher CPU usage and worse sound, since everything has to run through a sample rate converter.

I didn't realise your real-time sample rate conversion resulted in noticeably worse sound working at a sample rate other than 44.1kHz.  I know plenty of us working in film and television who work at 48kHz (this is not unusual) and trade off the modest CPU hit for the convenience of receiving and delivering files at the same sample rate as the the edit suite and mix stage. I will do some tests with VI Pro to see if the sound is noticeably improved working at 44.1kHz (Obviously I can't test the Synchron player because unlike VI Pro it does sound noticeably worse at 48kHz as described above)

Originally Posted by: MS Go to Quoted Post
Regarding ASIO4ALL, I have tested this driver together with RME Fireface UCX, and I cannot make it work at all when switching between samplerates, regardless if I'm doing so in a VSL product or simply just in Cubase or Nuendo. I would not recommend anyone using this driver, if you already have a proper soundcard with a proper ASIO driver.

As mentioned above, I only tested the ASIO4All driver to rule out my RME driver as being the culprit.  I would never advocate using ASIO4All in a professional situation.  The digital sample-rate related artifacts were present using both drivers only at 48kHz, and only using the Synchron player, not VI Pro or Kontakt either standalone or within Cubase. 

Thanks for your suggestion above RE the 'ini files.  If you have any other ideas I'd love to know. Please read the thread over at vi-control for more information - https://vi-control.net/community/threads/synchron-player-strange-high-ringing-sound-issues-running-at-48khz.96889/

Brett

Posted on Mon, Oct 26 2020 20:09
by brett
Joined on Fri, Aug 19 2005, Australia, Posts 87

Hi Martin

Any update on a fix for this issue?  As I mentioned in my previous post working at 48kHz is standard in film and television so dropping back to 44.1kHz is not a solution.

Thanks - Brett

Posted on Mon, Nov 16 2020 08:20
by brett
Joined on Fri, Aug 19 2005, Australia, Posts 87

Just a quick head up for those affected, VSL has discovered the cause of the issue and is working on a fix.  No release date as yet.  Thanks to Andreas at support for all his help.

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.