Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Routing in Ableton Live per manual: no MIDI getting through
Last post Mon, May 17 2021 by blipson, 5 replies.
Options
Go to last post
Posted on Sun, May 16 2021 09:07
by blipson
Joined on Fri, Jul 03 2020, Posts 6

MacOS X 10.15.7, VEP 7. Following the notes in the documentation regarding routing in Ableton Live, I start the VEP server, instantiate VEP in an Ableton MIDI track, and everything connects OK. External MIDI goes to that MIDI track via IAC 1, and I can see the MIDI activity on the correct channels in the track's MIDI From. When I arm that track, VEP plays with everything routed to channel 1 as Ableton is known to do. Per the VEP manual, I then create an external instrument in Ableton, and under its "MIDI From," I put the VEP track, and then under its "MIDI To" I put the VEP track, then the VEP track channel I want to output to. I arm the external instrument track and disarm the VEP track, but no MIDI gets directed into the instance of VEP. I see the MIDI activity in the VEP track, but no activity in VEP's window (no piano keys get pressed). If I press the keys manually, VEP plays through Ableton as I've set up, so the audio routing is correct, just this MIDI issue.

In VEP's Master Bus, the MIDI input is set to the default first choice, which is "VE Pro Plugin MIDI In 1." I've attached a screenshot that shows one of the external instruments' MIDI settings (I've actually got two instruments going in VEP). I can't get a screenshot that shows the dropdown to show the ongoing MIDI channel activity, but those lights are blinking as they should for channels 1 and 2. Any clues as to how to trace down where Ableton is sending MIDI to?

File Attachment(s):
2.png (562kb) downloaded 6 time(s).

You cannot view/download attachments. Try to login or register.
Posted on Sun, May 16 2021 12:38
by Macker
Joined on Tue, Aug 21 2018, London, Posts 337

What MIDI are you expecting your External Instrument tracks in Ableton to receive from VEP/Post FX, and why?

If you're looking to route various channels from that IAC Bus into VEP, I'd suggest you assign the "MIDI From" in all the External Instrument tracks directly to the IAC Bus, then simply select the IAC Bus channel you want each External Instrument track to handle. You'd also need to assign only one channel of the IAC Bus feed into the VEP track otherwise you'll get duplicated MIDI hitting instruments in VEP.

Posted on Sun, May 16 2021 16:44
by blipson
Joined on Fri, Jul 03 2020, Posts 6

I'm trying to get MIDI from my external sequencer into VEP via Ableton, not receive from VEP/Post FX. I should have made that clearer because I can't grasp how what you're advising me to do addresses my problem, either due to my miscommunicating my problem, or just not understanding well enough what you're saying.

My external sequencer sends to Ableton on all the 16 channels of IAC bus #15, but Ableton doesn't pass on the channel information to the plugins in its MIDI tracks. Instead, Ableton merges all MIDI info it receives into channel 1. But I want to have different instruments in VEP on different channels so that I can sequence them separately via the 16 channels of IAC Bus #15.

That part of the manual named "Important Notes for Ableton Live Users" describes a workaround for getting channel information delivered externally to Ableton passed on to VEP (instead of merging everything to channel 1), but perhaps that's also something I'm misunderstanding.

Posted on Sun, May 16 2021 21:58
by Macker
Joined on Tue, Aug 21 2018, London, Posts 337

Ok then my guess was correct, it's just a straightforward thing you want to do. The problem you're having is due to your track input routing assignments in the External Instrument tracks in Ableton, as shown in your screen shot. If you follow my suggestions above it should all work as you intended.

The VEPro manual is perfectly correct in what it shows of the method of using External Instruments for routing MIDI channels into, and audio channels out from, VEPro in Ableton. Strictly speaking it's not a "workaround"; the same method is shown in Ableton's user manual for routing to and from any multitimbral instrument plugin (such as Kontakt) in Ableton.

Of course the VEPro manual doesn't specify what your MIDI input assignments should be for the external Instrument tracks in Ableton, because that's entirely up to the user and is outside the scope of the VEPro manual. Likewise, I believe it's fair to say that the general topic of Ableton's track input routing is outside the scope of this forum.

I suggest the excellent Ableton Live user manual may help you with the topic of track input routing; or alternatively one of the many online forums and video tutorials for Ableton Live.

Posted on Mon, May 17 2021 02:15
by blipson
Joined on Fri, Jul 03 2020, Posts 6

OK when I assigned the "MIDI From" in all the External Instrument tracks directly to the IAC Bus as you suggested, it worked. I did, though, have to additionally arm the two external instruments while also dis-arming the VEP track, which I didn't do the first time, so I thought your solution didn't work. I must have been construing things backwards, which is actually worse than not understanding at all. I must say, I still don't fully understand how this  all coordinates, though the Ableton manual section on the External Instrument device is also a big help. With that and now this working paradigm, I expect I'll be able to make things work after this. Thanks.

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.