Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Great Rieger Organ mixer panning issue?
Last post Mon, Jun 28 2021 by Andreas8420, 9 replies.
Options
Go to last post
Posted on Fri, Jun 25 2021 16:35
by Angelus
Joined on Mon, Jul 23 2007, Wiltshire, UK, Posts 57

There seems to be an issue with the pannning of the GRO's internal mixer. I noticed this when I was trying to replicate an organ with remote divisions in different parts of a church.

So, use the GRO's Mix page pan control for the Hauptwerk, say, to move the sound to the left. Now save the project and re-open it. On checking the pan control, it will be exactly as it was before the save, panned to the left. However, the mixer internally has not applied this panning and the sound is at the normal location for that manual. Now touch one of the handles of the pan control and move it very slightly. The pan is now applied again and the sound will jump to the left.

Posted on Fri, Jun 25 2021 16:43
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12791

Hi Angelus, 

Thanks for reporting! Which host are you working with, on which OS?

Thanks, 
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Fri, Jun 25 2021 16:50
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12791

Hi again, 

Just checked in Logic Pro on macOS 10.15.7, with the Power Panner... project loads as it was saved, with the sound panned to the left. 

Best,
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Fri, Jun 25 2021 17:46
by Angelus
Joined on Mon, Jul 23 2007, Wiltshire, UK, Posts 57

This is the bit where I'm almost too embarrassed to say...

Cakewalk on Windows 7

If it hadn't been saving correctly I would have expected the panner appearance not to be saved either, so given that it was saved but the actual sound location was at default made me suspect GRO - but with enough doubt to put a question mark in the thread title! I guess I can just record a little automation to set the panning where I want it, I'll give that a try later.

[Edit] And it just seems to be the panning affected, everything else seems to save/restore OK.

Posted on Sun, Jun 27 2021 13:39
by Andreas8420
Joined on Mon, Dec 02 2019, Vienna, Posts 64

Hello Angelus,

Thank you for your follow-up! I can confirm the same behavior on my Windows 10 machine - I will forward this info to our developer team.

EDIT: This seems to only happen with the VST3 plugin. Please try the VST2 plugin and let us know if panning works as intended, there.

Best regards,
Andreas

Technical Support - Vienna Symphonic Library
Posted on Sun, Jun 27 2021 20:47
by Angelus
Joined on Mon, Jul 23 2007, Wiltshire, UK, Posts 57

Thanks, Andreas. I only installed the VST3 version, and when I run the installer again it says, "Click Install to begin with installation, or click Back if you want to review or change any settings", but there is no Back button.

Posted on Mon, Jun 28 2021 09:31
by Andreas8420
Joined on Mon, Dec 02 2019, Vienna, Posts 64

Hi Angelus,

The installer works here as intended if I rerun it on my Win 10 computer. I can go back and forth between all steps, and I can choose the plugin formats. Possibly this is caused by using an outdated Windows version (Win 7). Since Microsoft dropped all Windows 7 support 1 1/2 years ago, we can not develop or test software for Windows 7 at this point anymore - leave alone optimize it. Please contact us via email at . Thank you!

Best regards,
Andreas

File Attachment(s):
gro_installer_win.png (1,280kb) downloaded 2 time(s).

You cannot view/download attachments. Try to login or register.
Technical Support - Vienna Symphonic Library
Posted on Mon, Jun 28 2021 12:57
by Angelus
Joined on Mon, Jul 23 2007, Wiltshire, UK, Posts 57

Originally Posted by: Andreas8420 Go to Quoted Post

Microsoft dropped all Windows 7 support 1 1/2 years ago, we can not develop or test software for Windows 7 at this point anymore - leave alone optimize it.

I understand, I was a Windows software developer myself for 25 years, though that's partly why I am now a Windows 10 refusenik!

Anyway, I guess I can uninstall and reinstall the player and see what happens.

[EDIT] Well, that was pretty painless, and as you said, the pan settings for the VST2 player are correctly restored now. The NRPN offset for stop selection has changed, it was 911 for the VST3 plugin and now it's 928, but as that's an undocumented feature I guess I can't complain! How about moving it up to a nice, round 1,000 though? That way you can change mixer and various other parameters as you please without affecting stop selection.

Posted on Mon, Jun 28 2021 17:36
by Andreas8420
Joined on Mon, Dec 02 2019, Vienna, Posts 64

Thank you, Angelus! I passed your finding on to our developer team! :-)

Best,
Andreas

Technical Support - Vienna Symphonic Library
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.