Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Options
Go to last post
2 Pages<12
Posted on Fri, Nov 12 2021 02:09
by jbm
Joined on Fri, Jan 16 2004, Posts 1159

Ack! I was so excited until I realized it wasn't VI Pro 2.... Can the fix implemented here apply to VI and VE Pro?

Posted on Fri, Nov 12 2021 03:22
by JoelW
Joined on Wed, Jun 02 2021, USA, Posts 7

The AU plugin from v1536 (beta) crashes with segfault and doesn't load in Logic Pro X for me -- The Logic Pro X host running under rosetta2 or natively. MacOS 12.0.1 (M1; arm64).

Posted on Fri, Nov 12 2021 14:30
by Sovereign
Joined on Sun, Nov 05 2017, Posts 20

Originally Posted by: JoelW Go to Quoted Post

The AU plugin from v1536 (beta) crashes with segfault and doesn't load in Logic Pro X for me -- The Logic Pro X host running under rosetta2 or natively. MacOS 12.0.1 (M1; arm64).

That beta works fine for me in Studio One.

Posted on Fri, Nov 12 2021 15:29
by J.H.
Joined on Mon, Jun 02 2014, USA, Posts 26

After a week straight of working day and night, I finally was able to revert my MacOs and data to where I needed it to be. Everything works again for me. Had literally 10 long calls with Apple Support and even had to drive out of state twice to a service center.  (We kept finding solutions that got us 80% of the way there, but then would encounter an issue that would force me to pursue a different route.) I had to take significant time off from my day job. Ooof. It's been a loooong week but I'm happy it's over and I can now perform my gig this weekend.

The funny thing is, I didn't really intentionally upgrade to Monterey in the first place (where this whole problem began). I was in the App Store and downloaded MacOS Catalina 10.15, but after it downloaded, Apple then prompted me to install Monterey (not 10.15). Which I wasn't 100% cognizant of at the time. My mistake, but it felt like Apple misdirected me there.

I encountered this same thing this past week while trying to fix all my versioning issues. When I got to the point of downloading Catalina 10.15 or Big Sur 11.0, my computer would afterwards prompt me to download Monterey. To ACTUALLY install Catalina or Big Sur, you had to take a kinda weird route.

All of this is to say is that I think a lot of people will be having this issue in VSL, because even if they know they shouldn't download the latest MacOS yet, the system itself seems to kinda push users towards it.

Posted on Fri, Nov 12 2021 15:36
by J.H.
Joined on Mon, Jun 02 2014, USA, Posts 26

I will add that while the VI Pro plugin is now working for me in MainStage, the standalone VI Pro application crashes upon loading. I have not investigated this yet, as I don't really need the standalone app.

I am now on MacOS 11.6.1

Posted on Fri, Nov 12 2021 16:14
by jbm
Joined on Fri, Jan 16 2004, Posts 1159

Yeah, brand new machine here, so no downgrade options.

Posted on Fri, Nov 12 2021 16:19
by jbm
Joined on Fri, Jan 16 2004, Posts 1159

A couple of questions: 1) @JoelW, Is there any chance you could try it on the latest 12.1 beta—just in case the segfault is a system thing on Apple's end (i.e., in 12.0.1), not the VI?, and 2) where do the betas come from—are you guys testers, or is there a public repo for downloading them?

EDIT: Ah, sorry, I see that the Synchron Piano that was posted earlier is 1536. No use to me, unfortunately, as I'm on VI Pro 2.

Posted on Sat, Nov 13 2021 07:04
by JoelW
Joined on Wed, Jun 02 2021, USA, Posts 7

Originally Posted by: JoelW Go to Quoted Post

The AU plugin from v1536 (beta) crashes with segfault and doesn't load in Logic Pro X for me -- The Logic Pro X host running under rosetta2 or natively. MacOS 12.0.1 (M1; arm64).

I can confirm that this beta version works well on a Intel (x86_64) mac with MacOS 12.0.1 as either a AU or VST3 plugin. On a M1 mac (arm64), it crashes. Looks like it's almost there.. Looking forward to a fix that works on both platform...

Reply to @jbm: I didn't have a chance to try Monterey 12.1, but I'm pretty sure it will not work on M1 macs either because this is the plugin's problem. 

Posted on Sat, Nov 13 2021 08:55
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 13299

Hi everybody, 

Just sending out the links for our beta versions to everybody who contacted us. 

We will release these versions on monday, and of course we'll be happy about your feedback!

If you'd like to check those beta versions, please get in touch via , I'll send the links to you asap. 

Best, 
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Sat, Nov 13 2021 10:09
by StasPraha
Joined on Tue, Mar 15 2016, Posts 13

Hi Paul, it works perfectly, thanks for your effort

have a nice day Stan

Posted on Sat, Nov 13 2021 18:28
by JoelW
Joined on Wed, Jun 02 2021, USA, Posts 7

I can confirm that the new beta version (Synchron Piano 1538 and Synchron Player 2053, etc.) works well for me --- on a M1 mac with Logic Pro 10.7. Thanks VSL team for the fix and your support!

Posted on Sun, Nov 14 2021 16:20
by jbm
Joined on Fri, Jan 16 2004, Posts 1159

Up and running with the UI again, on VI Pro 2, build 18664. Brilliant work from Paul and the VSL dev team!

Obviously this is Rosetta for now, but I'm not losing any sleep over it. :)

Posted on Sun, Nov 14 2021 20:53
by fatis12_24918
Joined on Sat, Dec 16 2006, Posts 326

Tested Betas on my Mac Mini M1 environment with Logic 10.7.1 and other platforms: all looks pretty nice (I love the new MacOS 12 graphic, the VSL GUI shines in it).

Functionality up to now didn't give any trouble, hopefully all was just around graphic management.

Looking forward to official release next week, great responsiveness guys!

Posted on Mon, Nov 15 2021 17:34
by Tomboman
Joined on Sun, Mar 01 2015, Posts 1

I can see the Synchron Player etc is now updated - thank you very much!

Vienna Imperial is still build 778 from 2019

Any news when this will be updated as well? I use this on a daily basis

 

Thank you very much and again thanks for all the help!

 

Thomas

Posted on Mon, Nov 15 2021 18:25
by Jerome
Joined on Mon, Jul 10 2006, Los Angeles, CA, Posts 299

Happy to report that on a brand new install of Monterey (latest MacBook Pro M1 Max) the Vienna Instruments plug-in is now properly recognized by Logic (it wasn't showing up in the plug-in manager before today's update).

The GUI looks fine as well, although obviously I didn't know it wasn't working before since VI wasn't recognized at all :)

Thanks everyone at VSL for the quick turnaround, much appreciated!

Jerome

Posted on Mon, Nov 15 2021 22:17
by Gordon
Joined on Tue, Aug 19 2003, Canada, Posts 1

Great!

Downloaded, updated and everything is working well, we're back in action!

Thanks Paul [and the team] for update and the quick turnaround. Much appreciated.

G.

Originally Posted by: Paul Go to Quoted Post

Hi, 

I hope we can present working versions this week, but I'm afraid I can't make any promises. 

I will keep you up to date in this thread!

Best, 
Paul

Gordon Mcghie
Trigger Music Inc.
http://www.cgbros.ca
250-899-0329
Posted on Thu, Nov 18 2021 09:50
by Cyril Blanc
Joined on Thu, Dec 19 2002, Paris France, Posts 2722

+1

Do not forget to install all the updates in My VSL dated of 15 November

Originally Posted by: SparkleHedgehog Go to Quoted Post

MacBook Pro 2019 16" + 2 x Odisseey G9 49" Big Sur

MacPro 2010 12 core 2.93 ghz 64 GB Mac OS X 10.11 2722 Rocket Raid Sata III card with 8 x ssd

Kbd : P80 Yamaha, S88 and S25 Komplete Kontrol, DX7
I-Controls Pro, 2xMidi expression pedals
Synth : many....
--
Logic X , Dorico, Band In A Box, ORB Composer
VSL : MIR PRO, Appassionata Strings I, Solo strings , Wind and Brass Complete, Dimension Brass, Big Band Orchestra series, Many Synchronised libs
Kontakt, Omnisphere, QLSO, QLSC, CS 80, Arturia V5, Maximo, Realivox Blue. CS 80 V3, The Orchestra 2, Art Conductor, Genesis Children Choir, Lunaris, Lacrimosa

Final Cut pro
Camera full HD
Posted on Mon, Nov 29 2021 10:42
by engineering
Joined on Fri, Feb 07 2003, Hollywood, Posts 2

Same here VSL  does not work with logic 10.7.1 - Monterey 

Posted on Mon, Nov 29 2021 11:12
by Cyril Blanc
Joined on Thu, Dec 19 2002, Paris France, Posts 2722

Originally Posted by: engineering Go to Quoted Post

Same here VSL  does not work with logic 10.7.1 - Monterey 

 

Update all VSL software and IT WILL WORK

MacBook Pro 2019 16" + 2 x Odisseey G9 49" Big Sur

MacPro 2010 12 core 2.93 ghz 64 GB Mac OS X 10.11 2722 Rocket Raid Sata III card with 8 x ssd

Kbd : P80 Yamaha, S88 and S25 Komplete Kontrol, DX7
I-Controls Pro, 2xMidi expression pedals
Synth : many....
--
Logic X , Dorico, Band In A Box, ORB Composer
VSL : MIR PRO, Appassionata Strings I, Solo strings , Wind and Brass Complete, Dimension Brass, Big Band Orchestra series, Many Synchronised libs
Kontakt, Omnisphere, QLSO, QLSC, CS 80, Arturia V5, Maximo, Realivox Blue. CS 80 V3, The Orchestra 2, Art Conductor, Genesis Children Choir, Lunaris, Lacrimosa

Final Cut pro
Camera full HD
Posted on Mon, Nov 29 2021 15:10
by fatis12_24918
Joined on Sat, Dec 16 2006, Posts 326

Yes indeed, updates were fixing all the issues on my systems (both Intel and M1): always use the last version of course.

2 Pages<12
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.