Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Extremely high CPU-usage with Synchron Player for iLok
Last post Wed, Jun 22 2022 by Seth H, 15 replies.
Options
Go to last post
Posted on Tue, Apr 19 2022 18:15
by Anima79
Joined on Tue, Nov 05 2019, Posts 3

Hello

during the weekend I made the switch iLok , redownloaded all my librarys, deleted all prior versions of the Synchron Player (Piano and the normal one) and installed everything again. So far, everything is running fine except one rather important thing: the CPU-usage is skyrocketing through the roof even when playing only one single voice (for example when playing the new "Hello" instrument, that nice flute). I changed nothing regarding the hardware, my system has the following specs:

AMD Ryzen 7 3700X 8-Core Processor 3.60 GHz
32.0 GB RAM @ 3200 MHz
Gigabyte x570 Board
Focusrite Scarlett 2i4 2gen interface (48k @ 256 Latency, since 128 is simply unplayable at the moment)
Windows 11 - 64bit
All drivers are up-to-date. 

Any ideas what could cause this behavior? As much as I would like the transition to iLok, this situation is not so great ... 

Thanks in advance and greetings from Switzerland

Michael

Edit for clarification: Playing one single note (!) of e.g. the flute at a buffer size of 128 uses about 90% of the CPU (!). 

Posted on Wed, Apr 20 2022 11:58
by dorremifasol
Joined on Fri, Oct 22 2010, Barcelona, Posts 59

Hi. Yes, I have the same problem.

Synchron Pianos seems to play about 200 voices using only 1/4 of the load in Cubase, but Synchron Player takes a huge lot of CPU in some cases, like with the new Fujara flute. A single note of it takes almost the all the CPU bar (a full core), and Smart Orchestra has become completely unusable for me, where I could play many instances before on the same system on the eLicenser version.

My specs are Intel i9 9900kf and 48gb RAM.

Cheers,

Alberto

Intel i9 9900KF, 48Gb RAM, Windows 10 64bit, Cubase 12 / Nuendo 11
Posted on Fri, Apr 22 2022 20:09
by Mavros
Joined on Mon, Apr 19 2021, Switzerland, Posts 26

Same issue on a Mac. MBP M1 Max 64 GB Monterey, Logic Pro latest version

Thé same pièces which had no issues at all before now regularly give system overload when you first playback and instruments play their first notes, a workaround is to go back ton the start of the piece and playback again till the next overload. After all instruments have played their first notes, you can play the pieces from start to finish without issues and navigate back and forth. 

Posted on Tue, Apr 26 2022 08:45
by Mavros
Joined on Mon, Apr 19 2021, Switzerland, Posts 26

I will try the same piece in Cubase. It is a bit tiresome as I have to set up the instrument rack for 10 instruments and add the expression maps to each track to make it perform in a similar way using the key switches provided by the midi export from Logic which sometimes is a bit buggy.

in Logic I managed to improve the situation a bit by setting the number of threads and cores used to the maximum instead of automatic. No more overloads but sometimes instruments still kick-in only after 2-3 notes when played back the first time. What I noticed is that the system  activity monitor independent from the DAW actually does not show high CPU usage, the peaks are just shown in the Logic internal activity monitor. 

Question is of course if this have anything to do with the switch to iLok or is it the latest Synchron player update which under the hood had some significant changes. 

Posted on Wed, Apr 27 2022 11:11
by Mavros
Joined on Mon, Apr 19 2021, Switzerland, Posts 26

I tested in both Cubase and Dorico. Cubase, with its usual illogic, none intuitive way of working  ignores the articulation keyswitch midi notes when you have the official VSL expression maps linked to the tracks. So you have to remove them from the track to make them work. As in Logic there is an audio performance peak when a VSL instrument kicks in which causes some clicks. After one playback this does not occur anymore.

Dorico works perfectly with the keyswitches but also has some clicks when a VSL Synchron instrument kicks in. You always have to run a piece till all instruments have played a few notes to eliminate the clicks.

I played also with the Synchron player settings Force enable all slots or Force disable all slots. There is no effect on the peaks. Force enable does improve that first notes when an instrument kicks in sound which also is an issue I only have with Synchron libraries.

By the way I have 4096 samples preload and 4 steaming and loading threads in the settings. Maybe that should be changed to solve this issue. The 100% peak shows only on one high performance cores/threads in Logic.

Posted on Tue, May 03 2022 11:27
by Anima79
Joined on Tue, Nov 05 2019, Posts 3

Originally Posted by: Mavros Go to Quoted Post

Question is of course if this have anything to do with the switch to iLok or is it the latest Synchron player update which under the hood had some significant changes. 

Yes, that is indeed the question. I didn't find a workaround until now. The Synchron Player is not usable for me at the moment. Gladly I've been on vacancies with my familiy during the last week. Any other news on this issue? 

Posted on Tue, May 03 2022 13:28
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 13436

Hi, 

We are currently investigating if that could be connected to processing a lot of MIDI CC data.

Did you send in some of your projects to yet? The smaller, the better, so we can reproduce this and then take it from there. 

Best, 
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Thu, May 05 2022 21:30
by Anima79
Joined on Tue, Nov 05 2019, Posts 3

Hi Paul

in my case, the problem occurs even when I use simply the standalone application. Even when I click a key on the keyboard onscreen with my mouse (!) I can reproduce this. I think this is a strong case against the MIDI CC-theory. 

Strangely, not all libraries seem to be affected. For example, the Big Bang Library works like it should, Synchron FX Strings and Synchronized Dimension Strings however are heavily affected. The free flute is the worst of all.  

I am happy to help in your investigation, I am just a little short of spare time the coming days, sorry. (Wife has to do night shifts in the hospital and I have the kids around ... )

Best wishes

Michael

Posted on Fri, May 27 2022 00:10
by mikeheels
Joined on Thu, May 21 2015, Posts 39

Same here with a new MB Pro 14 M1 Pro.

It also crashes Studio One and makes the computer restart. Both running natively (AU) or under Rosetta (VST3)



Mac Pro 2013 6-core 64 GB Ram
OSX 10.15.6
Motu M4
Posted on Fri, May 27 2022 00:11
by mikeheels
Joined on Thu, May 21 2015, Posts 39

Same here with a new MB Pro 14 M1 Pro.

It also crashes Studio One and makes the computer restart. Both running natively (AU) or under Rosetta (VST3)



Mac Pro 2013 6-core 64 GB Ram
OSX 10.15.6
Motu M4
Posted on Sat, May 28 2022 07:37
by jensi
Joined on Tue, Feb 24 2015, Italy, Posts 11

Hi,

I have the same problem. Has it been fixed?

Thanks

Posted on Wed, Jun 01 2022 08:28
by laurof
Joined on Mon, Apr 13 2015, Posts 3

Originally Posted by: Paul Go to Quoted Post

Hi, 

We are currently investigating if that could be connected to processing a lot of MIDI CC data.

Did you send in some of your projects to yet? The smaller, the better, so we can reproduce this and then take it from there. 

Best, 
Paul


Hi,
I'm new to VSL super professional libraries and because of sound quality I'm super happy. But I'm scared of Synchron Player's huge CPU power consumption that I noticed.
I hope this can be fixed.
Best
 
Lauro

 
Posted on Sun, Jun 05 2022 21:42
by frave
Joined on Sat, Apr 18 2020, Posts 8

Hi guys, same problem here!
The loaded instances take 45-50% of cpu only on idle.
Any news about this?

Thanks

Posted on Wed, Jun 08 2022 12:26
by dagreb
Joined on Tue, May 03 2016, Posts 3

Hi all,

I also have big problems with the synchronous pianos, impossible to use the different microphones as I should normally be able to do. I use the Vienna Ensemble. I have a very powerful PC since it is also used for gaming, and I have no problem with games: AMD Ryzen 9 5900x / 64GB Ram. I have already made the settings proposed in other posts to improve things, but as soon as I put 4 or 5 microphones, the CPU is overloaded. There are major optimization issues.

Posted on Wed, Jun 22 2022 00:36
by Seth H
Joined on Tue, Feb 23 2021, Los Angeles, CA, Posts 11

I am having the same issue.  I am using the Synchron Harp, Strings Pro and Oboe d'Amour on a pretty large project.  ALL of my other AUs are playing fine and without any issues except for the Synchron Strings Pro.  It is bogging down the system badly and it's so frustrating.  Since switching over to iLok this has been the one constant CPU issue with VSL and it's really frustrating.  Any news or updates would be great.  I have tried all the things people here have mentioned and still no resolution.

Thanks,

Seth

MacPro - Latest version

128gbRAM, separate 2TB SSD drive solely dedicated for only VSL products.  Logic Pro - latest version.

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.