Welcome Guest! To enable all features please Login or Register.



Forum Jump  
exs/vsl horror story HELP!!
Last post Wed, Mar 28 2007 by irvind, 9 replies.
Go to last post
Posted on Fri, Mar 16 2007 14:18
by Morpheus
Joined on Mon, Dec 15 2003, Edinburgh, Posts 24
here we go again...

for some reason my logic system is hanging when it tries to load some songs i've been working on.

all the other smples used in the song load fine - the vsl ones cause the app to crash.

ive tried...

disk warrior on the drive with the samples

moving the instruments to the recommended place (library// blah blah)

relinking the samples with exs manager 2.9

updating the mac OS from 10.4.6 to 10.4.7

logic is at 7.2.0 already...

any thoughts about this??

the autoload loads fine until it gets to the vsl samples in it, then hangs - same with any songs i've been working on.

i have changed nothing at all in the system recently - this happened out of the blue.

h e l p !

Posted on Sat, Mar 17 2007 11:35
by musos
Joined on Sun, Dec 08 2002, Johannesburg, South Africa, Posts 916
For a start, you should get past Logic 7.2.0 - I remember there were some issues with this version. Get at least 7.2.1 or 7.2.3

What happens if you load a non-vsl song, and then try to open a VSL instrument? Does it load? It seems to me that Logic is still looking for samples, even though you've re-linked the instruments. The songs may have references which are still "unresolved". If Logic hangs but doesn't crash, try waiting a reallylong time (eg a few hours while you sleep) - this may work.

Very strange......

Posted on Sat, Mar 17 2007 12:41
by Morpheus
Joined on Mon, Dec 15 2003, Edinburgh, Posts 24
hi colin,

i've tried logic 7.2.1 - no change at all

I've also updated to 10.4.7 and QT 7.1.5 - also diskwarrior and repaired permissions etc

i've tried loading the VSLs into a non-VSL song...

logic appears inert

force quit shows that logic is not responding


after an hour or so (per instrument) it moves on to the next one, reporting "General Error 36"

the instrument doesn't play back and logic is frozen.

All the other maintence and diagnostic stuff I've done means the rest of the system is going at lightning speed though...

I really don't get it.

any more thoughts?

I can't really let it run while I'm sleeping, because I'm in the middle of a feature score and as a result I'm, er, NOT sleeping...

Posted on Sat, Mar 17 2007 12:52
by cm
Joined on Fri, Dec 20 2002, vienna, Posts 9146
a few ideas ...
- check and if needed repair permissions on your system volume
- make sure the lokation your exs instruments reside now is read&write
- check if EXS manager has really relinked samples to instruments

if nothing helps, move the instruments to a backup-location, then copy them step-by-step (say instrument groups) back to logic's favourite instruments folder to see for which instruments the problem occures.

try the same with freshly un-rared (eg. from the DVDs) instruments to make sure the exs files have not been corrupted

hth, christian
and remember: a CRAY is the only computer that runs an endless loop in just four hours ...
Posted on Sun, Mar 18 2007 20:43
by musos
Joined on Sun, Dec 08 2002, Johannesburg, South Africa, Posts 916
Hi Max,

cm's advice is good....

A while back I installed an update to Palm Desktop. The installer changed the permissions on almost every folder on my hard drive [Indifferent] and many apps suddenly stopped working, properly or at all. I spent hours changing permissions and slowly things went back to normal.

My point is that something you least expect has possibly made some changes which are causing your problems. The fact you get an error message after an hour tells me Logic is maybe searching for broken links.

Try cm's strategy - this should get you going again.

Regards - Colin
Posted on Mon, Mar 19 2007 08:32
by Morpheus
Joined on Mon, Dec 15 2003, Edinburgh, Posts 24
hi cm, hi colin,

thanks for your replies -

i have tried repairing the disk permissions on the system drive - no change there...

The sampler instruments are in their default place, applications/support/logic/samper instruments which I assume is read/write ?

To summarise...I have also tried...

updating logic to 7.2.1
updating the OS to 10.4.7
updating quicktime to 7.1.5

relinking with the EXS manager 2.9

doing extended scans of the drive with all the samples on it (350 GB of a Lacie 500GB FW drive)

I think I am on the trail of this though...

I have tried loading up some VSLs into new songs, and they work fine, with the exception of the set of instruments I was using on this film - UNFORTUNATELY!!! - these still cause chaos.

So I'm assuming the EXS manager has fixed, er, something.

Thinking about anything that I've done differently from my normal way of working, I can only think that this has come about because I put the computer to sleep over night - which normally I just leave on, and this has trashed the set that were loaded at that time?

Serves me right for trying to be green and save time in the morning....

Any thoughts on how I might fix this if this were the cause? (short of re-installing I mean...)

Currently I'm working without the sample drive mounted, so the arrangements just report they can't find the sampes when they open up - and I replace them with, gulp, the logic factory ones javascript:emoticon('[[Indifferent]]'). Ouch!

If I mount the drive and they try to load the ?corrupt? samples the computer locks up still...

thanks for all your thoughts...


Crying [[Indifferent]]
Posted on Mon, Mar 19 2007 09:56
by marnix
Joined on Tue, Mar 16 2004, Vienna, Posts 1015
Hi Morpheus,

After extensively scratching my head trying to figure out what might cause your problem, I looked up the error code you were prompted with at http://www.appleerrorcodes.com/

Assuming that it was error -36 (no positive error numbers beyond 30 and below 7100!), I found it listed as a file system error there (In/Out error)

A search in the Mac Help only brought up a support article titled "Mac OS X 10.4: Error -36 alert displays when connecting to a Samba or Windows server"

Although all this is not very specific, it clearly indicates that something went wrong with the file system on your harddisc.

So cm´s suggestion to copy the content of your disc to a different location, especially the files that give you trouble, and perhaps trying to relink them again from there with EXS Manager might be a good idea IMO. At least we can rule something out if this does not work!

Before you do that though, please make sure that your permissions to _all_ the files on your harddisc are set to read & write. To do this, please select your HD in the finder and hit command-I to open the Info window. Under "Ownerships & Permissions"/Details, click the button "Apply to enclosed items..."

Anyway, I am positive we will eventually be able to sort out this issue!

Best, Marnix
Posted on Mon, Mar 19 2007 14:58
by agoz
Joined on Sun, Aug 31 2003, Posts 108
Hi Morpheus,
just as an idea, did you have Logic open when you relinked your instruments?
This might explain the:

"I have tried loading up some VSLs into new songs, and they work fine, with the exception of the set of instruments I was using on this film - UNFORTUNATELY!!! - these still cause chaos."

If this is the case, please relink again without Logic running at the same time.

(why this? Logic sometimes will write back to disk the instruments you loaded, when you quit it. If you relink your library with Logic running, there's a possibility that Logic will write back to disk the "non-relinked" instruments)

Best Regards
Andrea at Redmatica
Posted on Wed, Mar 28 2007 09:31
by irvind
Joined on Mon, Dec 29 2003, Glasgow, UK, Posts 257

I've had similar, but not identical, problems in the past, where Logic will hang during load-up of VSL instruments on a song that previously worked no problem. However I worked out that not allowing some of the bigger samples to load (by hitting Apple>Period [full-stop]) keys at least allowed the song to load. Once the song had loaded I'd go to the relevant EXS instruments and load up the appropriate samples, and bingo, no more problems.

It sounds like your prob is a bit different, but I thought I'd mention it anyway in case it helps...
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.