Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
CPU usage of Vienna Ensemble in Logic when freezing a track
Last post Thu, Jun 11 2009 by Louisc, 6 replies.
Options
Go to last post
Posted on Tue, Jun 09 2009 12:19
by Louisc
Joined on Fri, Sep 10 2004, Posts 13

Hello All,

This question may have been asked before, but I couldn't find a clear discussion concerning my problem in this forum.

I am using Logic 8.0.2 on my dual G5 CPU running under Mac OS X 10.5. I am running out of CPU and tried freezing tracks to minimize the problem (which is supposed to be the solution since plug-ins aren't supposed to use CPU when a track is frozen). That didn't help at all.

I was initially using separate VI but thought that might be a problem of overall resource usage. I tried to switch to VE to pack all VIs into a more compact environment, but that didn't change anything. It even seemed to make things worse. I looked at the CPU consumption using the "Activity Monitor" utility, and it looks like the amount of CPU used by the VE doesn't change at all even when a track is frozen. Pressing the "Stop Engine" button didn't change anything either.

Can anybody help explaining this or, even better, suggest a solution or a workaround?

Thanks

Posted on Tue, Jun 09 2009 13:11
by cgernaey
Joined on Mon, Apr 04 2005, Detroit-Michigan, Posts 1062

Logic does not allow you to "freeze" multi-timbral instruments so VE is not going to help you CPU wise, it's going to make it worse.  I seriously hope they address this in Logic 9 or an update to Logic 8.  Even if you run VE as seperate instruments, it's not going to help you anymore then running seperate VI's that I know of.  Although it does allow you to pan instruments better then Logic does.

Doing single instances of VI and then freezing them is the best you can do for now (unless you can build a second machine and run VE3 over the network to take the load off of your sequencer).

But all in all, if freezing is not helping your CPU, you have other issues (not sure what they are but you do).  Because I freeze 10-15 tracks on a project and go from 100% CPU (unfrozen) to about 10% if not less CPU on a MacBook Pro (older one).

Maestro2be

Windows 10 Pro 64-bit, 128GB RAM, AMD 3970X 32-core
Gigabyte TRX40 Aorus Xtreme, Radeon RX 5500 XT
Studio One 5.1.1, Cubase 10.5, Nuendo 10
RME Multiface 2, All NVMe SSD Drives (OS & Samples)
Posted on Wed, Jun 10 2009 01:47
by Louisc
Joined on Fri, Sep 10 2004, Posts 13

Hello Maestro2be,

Thanks for your feedback. I was afraid I would get a reply like yours. Apparently, freezing a track is not a solution and I'm not sure at this point what would be. I'll try to think of something and keep you posted if I can think of anyhing.

Thanks again,

Louisc

Posted on Wed, Jun 10 2009 14:36
by cgernaey
Joined on Mon, Apr 04 2005, Detroit-Michigan, Posts 1062

Be sure to turn off your airport connection and other things that you don't need while working in Logic to free up resources.  I love Freezing tracks but it really gets annoying after a while because you can't edit anything while frozen.  Then you edit one note and have to sit and wait for it to freeze again.  It works, but I will be happier when I have a machine powerful enough that I don't have to freeze a track until I am completely done with it.

Also, when you are playing back have you opened up activity monitor to see what processes etc are using what % of CPU?  I also suggest you go to apple.com/support and under logic 8 pro, there is a thread on how to "spread loads over multiple cores".  If you don't follow exactly how they do it, you could be using way more power on fewer cores then you should be.  Just an idea.

One more thing to keep in mind.  If you are running all your samples from one drive and your template is large this could be killing you too.  Be sure you are not putting your VSL Library on your system drive where Logic is loaded.  It runs your plug-ins etc from that drive and also records to that drive.  If your Hard drives are over whelmed it will translate into CPU power which will completely slam your Logic environment.  So be sure you have those things seperated for maximum stability/performance.

Make sure your audio drivers are all the most current and also be sure that your latency settings are ideal.  To change your latency settings for VSL you actually have to open the stand alone version outside of logic and then set it.  Try increasing buffer sizes etc and see if it helps at all.

I will let you know if I think of anything else.  Hope this helps some.

Maestro2be

Windows 10 Pro 64-bit, 128GB RAM, AMD 3970X 32-core
Gigabyte TRX40 Aorus Xtreme, Radeon RX 5500 XT
Studio One 5.1.1, Cubase 10.5, Nuendo 10
RME Multiface 2, All NVMe SSD Drives (OS & Samples)
Posted on Wed, Jun 10 2009 22:46
by julian
Joined on Fri, Jan 07 2005, UK, Posts 720

I've found the only way to reduce CPU usage when running VSL stuff is to bypass the plug-in. Of course this doesn't help when you have frozen the track as the plug-in cannot be bypassed. There is a way round in that you could bounce the track (or import the frozen files - you would probably have to copy these as un-freezing and bypassing the plug-in may delete the freeze file! ) and play back via an audio track in the arrange at the same time bypassing the plug-in. Then if you need to make subsequent changes you can just un-bypass the plug-in.

Freezing a VSL instrument will make only minor (or zero) difference to cpu usage (only to disc usage - if it is running a lot of voices). In fact just having the VSL instance loaded creates the main CPU hit even if t is not playing back midi data. So currently the workround above is the only way to relieve CPU overloads.

Julian

Posted on Thu, Jun 11 2009 02:28
by Louisc
Joined on Fri, Sep 10 2004, Posts 13

Hello Julian,

Thanks for your input. I was starting to think a little bit in the same direction as what you are suggesting and I'm glad you explained your procedure in a simple and straighforward manner.

I tried what you suggested. I froze the VE track(s) and bypassed the plugin after that. I imported the frozen file (I had to convert it to a 16-bit "core audio" file with Soundtrack Pro as Logic would not import the 32-bit floating-point format of the frozen file) and used it as an audio track. It works as it should.

It's too bad that such a convoluted procedure had to be performed for such a simple requirement. Freezing a track should simply shut down the VE plugin until it is required again. That's the whole idea behind freezing a track. I hope this is resolved someday (soon).

Thanks for your help. I can at least continue to do some useful work now.

Louisc

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.