Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
MIDI TIMING (Latency) Midi arriving early
Last post Fri, Sep 07 2018 by daviddln, 22 replies.
Options
Go to last post
2 Pages12>
Posted on Wed, Feb 29 2012 14:59
by ddk
Joined on Sat, May 24 2003, Posts 57

Hi

I am on a Mac using Cubase 6 (64bit) 

and find when I play in midi it always is a bit too early.

I have tried different buffer setting on my audio card and in VE-PRO but nothing seems to help.

I have tried two different midi interfaces (MOTU midi express 128 and The midi on my RME radat card)

When I play in midi parts what I hear when I play it in is not what I hear when I play it back.

Thanks in advance for your help,

Dave

Posted on Wed, Feb 29 2012 15:20
by DG
Joined on Wed, May 12 2004, Posts 8608

 What buffers have you tried? What sample player are you using?

DG

Nuendo 6.03, 4.3
2 x Intel Xeon x5675 3.07GHz Hex Core
48GB RAM
Windows 7 (x64)Pro
RME Multiface II
Intensity
ATI HD5400 series graphics card
Posted on Wed, Feb 29 2012 16:16
by ddk
Joined on Sat, May 24 2003, Posts 57

I have tried putting VE-PRO at 2 and 1

and have tried 192, 256, 512 on my RME card.

thanks for the help,

Dave

Posted on Wed, Feb 29 2012 21:40
by ddk
Joined on Sat, May 24 2003, Posts 57

I am having trouble when playing in parts live

so is there a test that I could run to simulate me playing in parts live?

so that I could be more scientific compared to me just playing in 8th notes live and seeing were the notes fall.

thanks for the help,
David 

Posted on Sat, Mar 03 2012 01:06
by civilization 3
Joined on Sat, May 16 2009, SF Bay Area, Posts 1942

I found that happening when I have compensate for record delay enabled in device setup in Cubase. VEP is compensating for its latency already.

MacBookPro 18,3
Apple M1 Pro: 2.3 GHz 8-core i9

Mac OS 12.3.1
VE Pro 7.1298, Nuendo 11.0.41
Posted on Sat, Mar 03 2012 02:59
by ddk
Joined on Sat, May 24 2003, Posts 57

ok I will try to turn that off.

thanks, anyone else have any ideas??

dave

Posted on Mon, Mar 19 2012 01:39
by ddk
Joined on Sat, May 24 2003, Posts 57

I found that happening when I have compensate for record delay enabled in device setup in Cubase. VEP is compensating for its latency already. 

So How do I turn off the above 

is that only cubase on a pc? I don't see it in Device setup

Posted on Sun, Mar 25 2012 02:50
by ddk
Joined on Sat, May 24 2003, Posts 57

Anyone out there using a Mac  that has midi ariving

Posted on Mon, Apr 02 2012 22:18
by benbartlett
Joined on Thu, Apr 26 2007, Posts 162

See this thread at the Steinberg Cubase forum:

http://www.steinberg.net/forum/viewtopic.php?f=19&t=20516

Posted on Mon, Apr 02 2012 22:40
by ddk
Joined on Sat, May 24 2003, Posts 57

Thanks for the link

anyone who uses Cubase should check their midi TIming. And report any problems to Steinberg to try to get this fixed.

I thought it was Ve-pro but it is not 

Thanks to the great Ve-pro tech support I found out that it is imposible for Ve-pro to move midi early

Posted on Mon, Apr 02 2012 22:52
by ddk
Joined on Sat, May 24 2003, Posts 57

Cubase useres make sure you check out page 3 has a QT movie of someone showing the problem

http://www.steinberg.net/forum/viewtopic.php?f=19&t=20516

this is the same problem I have had for a very long time but I did not know it was cubase I thought it was VE-PRO

Posted on Tue, Apr 03 2012 10:01
by vosk
Joined on Tue, Jul 08 2008, Posts 141

I have a PC but.. You can try this:

1.copy file "ignoreportfilter" from Cubase folder (on PC this file is located:  C:\Program Files\Steinberg\Cubase 6\midi port enabler ), and put this file beside Cubase (in the same folder where Cubase)

2.start Cubase

3.Go to Devices > Device Setup and select MIDI Port Setup (left side)

4.In the list of midi-ports uncheck (remove mark) all "DirectMusic" ports (You should also see the midi-ports with [...])

5.Restart Cubase and try!

Posted on Tue, Apr 17 2012 09:41
by civilization 3
Joined on Sat, May 16 2009, SF Bay Area, Posts 1942

'ignore port filter' is not relevant to mac OSX. nor 'directmusic'.

MacBookPro 18,3
Apple M1 Pro: 2.3 GHz 8-core i9

Mac OS 12.3.1
VE Pro 7.1298, Nuendo 11.0.41
Posted on Tue, Apr 17 2012 09:49
by civilization 3
Joined on Sat, May 16 2009, SF Bay Area, Posts 1942

---

MacBookPro 18,3
Apple M1 Pro: 2.3 GHz 8-core i9

Mac OS 12.3.1
VE Pro 7.1298, Nuendo 11.0.41
Posted on Tue, Apr 17 2012 09:56
by civilization 3
Joined on Sat, May 16 2009, SF Bay Area, Posts 1942
ddk wrote:

I found that happening when I have compensate for record delay enabled in device setup in Cubase. VEP is compensating for its latency already. 

So How do I turn off the above 

is that only cubase on a pc? I don't see it in Device setup

MacBookPro 18,3
Apple M1 Pro: 2.3 GHz 8-core i9

Mac OS 12.3.1
VE Pro 7.1298, Nuendo 11.0.41
Posted on Fri, Feb 07 2014 11:16
by VSL
Joined on Tue, Dec 02 2014, Posts
0
Hi, sorry to bump an old thread but thought I would let people know as we had a customer with this problem and after much trial and error we managed to fix it.

We setup an external midi device to output notes at 120bpm and then sync by ear to the Cubase click track, the result, every note consistently before the beat. We finally settled up the following settings in Cubase - Preferences - Record MIDI

'Snap Midi Parts To Bars' off and 'Audio Latency Compensation Active By Default' on

Ran the test again and bang on the beat.

Hope this helps some people.
Posted on Fri, Feb 07 2014 15:05
by ddk
Joined on Sat, May 24 2003, Posts 57

Hi

I am the one who started this thread

Unfotunatly I tried your fix and my midi is still early.

Anything else you may have changed to get it to work??

thanks,

David

Posted on Fri, Feb 07 2014 15:17
by ddk
Joined on Sat, May 24 2003, Posts 57

What are your settings in the VST Audio System

Do you have ASIO-Guard   ON??

Do you have Adjust for Record Latency    ON??

trying to see if you have some setting on or off that is different from my setup

thanks

Dave

Posted on Sat, Apr 30 2016 11:05
by daviddln
Joined on Tue, Feb 25 2014, Posts 236

Hi Dave

 

Did you find a solution? I have the same problem and it's driving me crazy.

Thanks

David

iMac 21.5, i7 4770S, 3,1 Ghz, 16 GB RAM
Komplete Kontrol S-88, Focusrite Clarett 4Pre
Logic Pro X, Finale 26
Posted on Sun, May 01 2016 20:41
by 1offby
Joined on Sat, Mar 05 2016, Posts 19

Hello

I have encountered issues like this in a variety of setups. Unfortunately truly analyzing the issue requires engaging seriously with the concept of "time" as both a musical value (tempo-relative, perceptual) and as an exact "position" vis-a-vis, for example, a computer's cpu clock or a DAW sequencer grid.

To start let's clarify "early". In this thread we are discussing live (human or machine) MIDI output into a DAW. Since each MIDI event is sent into the DAW for processing these events cannot be "early." They are sent at some exact time. 

So, we are looking at how the DAW transport has translated these live MIDI events into a position in the DAW session timeline. This positioning is finalized after live input and the transport are sopped. MIDI events input to the DAW are timestamped with an exact time that is somehow related to the cpu clock, and that time is digested by the DAW into a transport location.

In this case the result is that the transport location is consistently "early" in musical time. Since human perception of musical synchrony is widely varied, the usual situation is that the human player has played early, sees the recording is early, and assigned this issue to software.

I suggest that, in most cases, if it's desired that live input start "exactly" on some point in the transport, use quantize either on input or after recording. It's a waste of energy to expect either human performance or the DAW's translation of that performance to adhere to a grid without explicitly telling that DAW what to do.

In an earlier test on this thread human error was compensated for using machine output. OK. So the DAW is placing these incoming MIDI events early. How early? If it is a fairly common rhythmic structure and just a few ticks early, would applying quantize solve the issue? If so, quantize.

Sometimes quantize is undesireable or unrealistic, for example when complex rhythms are needed or the user simply wants the MIDI to appear accurate "right away." In this case adjusting buffer settings, or changing live input options, can help make the translation from livi MIDI input to sequencer gird tighter.

I think some DAW and application designers choose to apply latency compensation at the point of MIDI print-to-sequencer-grid rather than after MIDI execution and before audio output. Rewire implementations, for example, consistently output MIDI early to compensate for audio latency. In Logic X some software instrument plugins hold live MIDI input for an audio buffer duration, causing late MIDI. It would be nice if audio latency compensartion happened only in the audio thread and never in the MIDI processing area.

These inaccuracies can be hadged against but never fully removed. Consider the complexity--the DAW and the plugin softwares within the DAW has to rectify CPU clock time and musical transport time, and also has to process incoming MIDI input that will arrive at an unknown time. As a result all software has to "fudge" something. The result is not dissimlar to a solo performer, say an oboist, playing to an audience in a large concert hall. The oboe is making sound at a mesaurable point in time. Acoustics, human perception, and the speed of sound invariably result in each audience member interpreting the oboe's output at microscopically different times.

I suggest here that most "early" or "late" seeming MIDI input is the result of natural human timing. In cases where the "early" or "late" representations of live MIDI input are the result of machine or software behavior some tolerance for necessary processing activity should be tolerated by the user. I'd guess that 99% of this can be immediately solved by quantization. The remaining 1% may simply require the user to manually position the MIDI data.

2 Pages12>
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.