Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
incoming network connections
Last post Mon, Dec 14 2015 by Paul, 35 replies.
Options
Go to last post
2 Pages12>
Posted on Wed, Aug 08 2012 18:40
by michael.matthews
Joined on Sat, Aug 23 2003, Montréal / Berlin, Posts 281

I am now getting this message in Mountain Lion:

"Do you want the application “Vienna Ensemble Pro Server (64-bit).app” to accept incoming network connections?"

What should I do? It keeps coming back no matter whether I answer yes or no.

Thanks!

Michael

Posted on Sat, Sep 01 2012 13:55
by Randy Thorderson
Joined on Sun, Jun 03 2012, Posts 2

Michael,

I fought this problem for hours, trying various approaches I found online. I had the problem when I first installed VEP 5.0, and somehow fixed it. But when I upgraded to 5.1, the problem was even more persistent.

I found a solution...the problem is that VEP somehow lost its proper permissions signature. You can verify this by opening a command prompt and typing...

    codesign -vvv "/Applications/Vienna Ensemble Pro/Vienna Ensemble Pro Server.app"

...or if you are running the 64-bit version...

    codesign -vvv "/Applications/Vienna Ensemble Pro/Vienna Ensemble Pro Server (64-bit).app"

...my response for this was...

    /Applications/Vienna Ensemble Pro/Vienna Ensemble Pro Server (64-bit).app: code or signature modified

That is a bad answer. It means that something changed and now OSX can't authenticate the App. I tried uninstalling/reinstalling VEP (I think this is what fixed it in 5.0) with no success.

I found this fix, and it worked perfectly...

    http://silvanolte.com/blog/2011/01/18/do-you-want-the-application-to-accept-incoming-network-connections/

Basically, you create a new Certificate, then assign that certificate to VEP (overriding the broken Authentication). As a novice UNIX guy, the only bit I tripped up on was the need to use quotes in the command line because the file path had spaces in it. Other than that, the solution worked perfectly for me.

Hope this works for you!

Cheers!

Randy

Posted on Mon, Sep 03 2012 19:09
by michael.matthews
Joined on Sat, Aug 23 2003, Montréal / Berlin, Posts 281

This is great info, Randy. Thanks very much!

Michael

Posted on Tue, Sep 04 2012 16:25
by MS
Joined on Wed, Feb 19 2003, Vienna, Austria, Posts 1762

This will be fixed with the next VEPro update.

--
Martin Saleteg
Software Developer
Vienna Symphonic Library GmbH
Posted on Sun, Dec 16 2012 17:22
by dbudde
Joined on Sun, Mar 02 2003, Seattle,WA USA, Posts 450

VE Pro still has this problem.  Is there still a plan to fix it.

Posted on Thu, Feb 06 2014 08:29
by michael.matthews
Joined on Sat, Aug 23 2003, Montréal / Berlin, Posts 281

I am now getting the problem again with the new version of VE Pro.

Michael

Posted on Fri, Feb 07 2014 17:51
by michael.matthews
Joined on Sat, Aug 23 2003, Montréal / Berlin, Posts 281

Is anybody else receiving this request for permission to allow incoming network connections?

Michael

Posted on Fri, Feb 07 2014 17:59
by dbudde
Joined on Sun, Mar 02 2003, Seattle,WA USA, Posts 450

It's been a problem for me on every version of VE Pro.

Posted on Mon, Feb 24 2014 08:32
by michael.matthews
Joined on Sat, Aug 23 2003, Montréal / Berlin, Posts 281

Are there any updates on fixing this problem?

Thanks

Michael

Posted on Tue, Feb 25 2014 16:07
by wgturner
Joined on Sat, Dec 03 2005, Posts 86

If you go to System prefs (OSX)/security and privacy/firewall.... what do you see?  I'll bet your firewall is on.  For some reason recently, I went there and noticed my firewall was turned off, so I turned it back on.  All of a sudden VEPro started giving me this message in a popup window.  When I clicked OK to allow the connection and it then worked.  If you turn your firewall off, I bet this message goes away...

So, my question is - should I be running OSX with firewall off??

- Greg

Posted on Wed, Feb 26 2014 08:10
by michael.matthews
Joined on Sat, Aug 23 2003, Montréal / Berlin, Posts 281

Thanks for the suggestion, Greg. I do have my firewall on, but VEPro is alreadly listed there as one of the approved applications. 

Michael

Posted on Wed, Feb 26 2014 15:58
by wgturner
Joined on Sat, Dec 03 2005, Posts 86

Just checked - when I turn my firewall on, and VEPro 64-bit (the one I use) is also listed, I get the same message:  'Do you want the app .... blah, blah, blah.....Deny/Allow'.  When I turn my firewall off, it works without that 'Deny/Allow' popup coming up.  So, this does seem to be a VSL issue then.

- Greg

Posted on Wed, Feb 26 2014 20:40
by michael.matthews
Joined on Sat, Aug 23 2003, Montréal / Berlin, Posts 281

Thanks for checking that, Greg. 

I guess I will put up with it until I hear something from the Vienna team. I don't want to run without my firewall on.

Michael

Posted on Tue, Mar 11 2014 15:55
by michael.matthews
Joined on Sat, Aug 23 2003, Montréal / Berlin, Posts 281

In the lastest update I am still getting this request to allow VEP to accept incoming network connections. Can someone from the VE team please let me know if there is a way to make this stop?

Thanks.

Michael

Posted on Tue, Mar 11 2014 16:27
by Cyril Blanc
Joined on Thu, Dec 19 2002, Paris France, Posts 2700

I have the same problem with the EyeTV software, they told me to erase everyting and to re-install !!!!!! Stick out tongue

MacBook Pro 2019 16" + 2 x Odisseey G9 49" Big Sur

MacPro 2010 12 core 2.93 ghz 64 GB Mac OS X 10.11 2722 Rocket Raid Sata III card with 8 x ssd

Kbd : P80 Yamaha, S88 and S25 Komplete Kontrol, DX7
I-Controls Pro, 2xMidi expression pedals
Synth : many....
--
Logic X , Dorico, Band In A Box, ORB Composer
VSL : MIR PRO, Appassionata Strings I, Solo strings , Wind and Brass Complete, Dimension Brass, Big Band Orchestra series, Many Synchronised libs
Kontakt, Omnisphere, QLSO, QLSC, CS 80, Arturia V5, Maximo, Realivox Blue. CS 80 V3, The Orchestra 2, Art Conductor, Genesis Children Choir, Lunaris, Lacrimosa

Final Cut pro
Camera full HD
Posted on Tue, Mar 11 2014 17:30
by wgturner
Joined on Sat, Dec 03 2005, Posts 86

I can confirm the same - no difference from before. 

- Greg

Posted on Wed, Mar 12 2014 14:22
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12879

Hi, 

I asked our developers and they promised to look into it, but they can´t make any promises right now.

Best,

Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Wed, Mar 12 2014 15:45
by michael.matthews
Joined on Sat, Aug 23 2003, Montréal / Berlin, Posts 281

Thank you, Paul.

Michael

Posted on Fri, Mar 14 2014 16:57
by wgturner
Joined on Sat, Dec 03 2005, Posts 86

Thanks, Paul.  In the meantime, we're just going to have to click the 'allow' button.   Man, that's a lot of work........... Crying

- Greg

Posted on Wed, Mar 19 2014 23:58
by cm
Joined on Fri, Dec 20 2002, vienna, Posts 9117

IMO the problem is the *firewall for dummies* configuration in the dialog for the OS X firewall (obviously since a few versions).

usually in a firewall you can select to allow:

- connections to certain applications

- connections from certain IPs

- connections to certain ports

- or any combination of the above three.

(the same for outgoing connections)

i'm sure you can still set all this using terminal, though i could not find any info about this on the net. possibly they have just done too much when fixing this issue http://support.apple.com/kb/HT6011

 

also apple explicitly mentions that blocking acces to a certain application can prevent regular access to another application http://support.apple.com/kb/PH14191

 

what a bummer ...

and remember: a CRAY is the only computer that runs an endless loop in just four hours ...
2 Pages12>
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.