Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Options
Go to last post
Posted on Fri, Aug 17 2012 14:11
by Felix Bartelt
Joined on Fri, Oct 22 2004, Berlin, Posts 372

Somehow I have quite a delay, when I play VE PRO instruments live on my keyboard, which means VE is useless for me, if I want to play live. When I play quantized sequences, everything is perfect on time. But as soon as my keyboard comes in, I get a very audible delay. 

This can´t be a problem of the keyboard or its connection, cause when I play other instruments, I don´t have this delay. 

Any ideas?

Thanks for helping!

Posted on Fri, Aug 17 2012 14:44
by Karel
Joined on Mon, Jan 19 2009, Belgium, Posts 2173

Which host are you using for the VE Pro plugin? As much information as possible about your setup is required in order to identify the problem.

Karel Bassez
Software Engineer
Vienna Symphonic Library
Posted on Fri, Aug 17 2012 14:45
by DG
Joined on Wed, May 12 2004, Posts 8608

Are you using MIR?

DG

Nuendo 6.03, 4.3
2 x Intel Xeon x5675 3.07GHz Hex Core
48GB RAM
Windows 7 (x64)Pro
RME Multiface II
Intensity
ATI HD5400 series graphics card
Posted on Fri, Aug 17 2012 15:16
by Felix Bartelt
Joined on Fri, Oct 22 2004, Berlin, Posts 372

I´m using Logic 9 on a Mac with OS 10.6.8. 

The problem occurs with or without MIR. I´ve just made this test: One instance of VE PRO and one normal VI played parallel. The VE PRO was that much delayed, that I heard two seperate notes. 

Posted on Fri, Aug 17 2012 15:32
by DG
Joined on Wed, May 12 2004, Posts 8608

Have you got delay compensation switched on in the VE Pro Preferences?

What latency have you set for MIR in the VE Pro Preferences?

DG

Nuendo 6.03, 4.3
2 x Intel Xeon x5675 3.07GHz Hex Core
48GB RAM
Windows 7 (x64)Pro
RME Multiface II
Intensity
ATI HD5400 series graphics card
Posted on Fri, Aug 17 2012 19:05
by Felix Bartelt
Joined on Fri, Oct 22 2004, Berlin, Posts 372

Delay compensation is switched on. 

Latency was at 0 and is now at 128. 

I still here a slight delay. 

Posted on Fri, Aug 17 2012 19:53
by DG
Joined on Wed, May 12 2004, Posts 8608

AFAIK there are two things responsible for latency compensation. VE Pro (assuming that you're using the server version) has to report the latency to Logic, and Logic has to act upon it. It is usually the last of these that seems to cause problems. Sometimes things can be fixed by hitting play, stopping and hitting play again. Other than that I can't help, because I have no problems with the latency compensation.

DG

Nuendo 6.03, 4.3
2 x Intel Xeon x5675 3.07GHz Hex Core
48GB RAM
Windows 7 (x64)Pro
RME Multiface II
Intensity
ATI HD5400 series graphics card
Posted on Fri, Aug 17 2012 20:51
by Felix Bartelt
Joined on Fri, Oct 22 2004, Berlin, Posts 372

So do you have no audible delay at all, when you play a note on your keyboard?

My latency is slightly better now, but I still hear a little delay. 

Posted on Fri, Aug 17 2012 21:49
by DG
Joined on Wed, May 12 2004, Posts 8608

None at all. Just one more thing; in the VE Pro server interface have you set the buffer to "none"?

DG

Nuendo 6.03, 4.3
2 x Intel Xeon x5675 3.07GHz Hex Core
48GB RAM
Windows 7 (x64)Pro
RME Multiface II
Intensity
ATI HD5400 series graphics card
Posted on Sun, Aug 19 2012 22:16
by Felix Bartelt
Joined on Fri, Oct 22 2004, Berlin, Posts 372

Where can I set the buffer? Are you talking about the latency, where you can choose between 0, 128, 256, etc...?

This is set to 128. I tried to set it to 0, but Logic causes the problem, that you get no MIR-wet-signal, if set to 0.

Posted on Sun, Aug 19 2012 22:19
by DG
Joined on Wed, May 12 2004, Posts 8608

No, I'm talking about the VE pro server interface. As you don't know what I'm talking about, I think that there is a very high probablity that it is set to something like 2 x buffers.

DG

Nuendo 6.03, 4.3
2 x Intel Xeon x5675 3.07GHz Hex Core
48GB RAM
Windows 7 (x64)Pro
RME Multiface II
Intensity
ATI HD5400 series graphics card
Posted on Sun, Aug 19 2012 23:18
by Felix Bartelt
Joined on Fri, Oct 22 2004, Berlin, Posts 372

How do I get to that setting? When I start the "Vienna Ensemble Pro Server" and click on "preferences", I can choose between settings for "server", "plugins" oder "Vienna MIR Pro", but I can´t find anything, where I can change the "buffers". 

Posted on Sun, Aug 19 2012 23:28
by DG
Joined on Wed, May 12 2004, Posts 8608

Not the server, the server interface. The connector you load into your sequencer to connect to VEP.

DG

Nuendo 6.03, 4.3
2 x Intel Xeon x5675 3.07GHz Hex Core
48GB RAM
Windows 7 (x64)Pro
RME Multiface II
Intensity
ATI HD5400 series graphics card
Posted on Mon, Aug 20 2012 10:40
by Felix Bartelt
Joined on Fri, Oct 22 2004, Berlin, Posts 372

Now I found it. It´s set to 2 buffers. Should I change that?

Posted on Mon, Aug 20 2012 10:57
by DG
Joined on Wed, May 12 2004, Posts 8608

If you want less latency, yes. However the lower the latency, the greater the chance of pops and clicks.

DG

Nuendo 6.03, 4.3
2 x Intel Xeon x5675 3.07GHz Hex Core
48GB RAM
Windows 7 (x64)Pro
RME Multiface II
Intensity
ATI HD5400 series graphics card
Posted on Tue, Aug 21 2012 11:59
by Felix Bartelt
Joined on Fri, Oct 22 2004, Berlin, Posts 372

Now I got it. Somehow the problem dissapeared by itself. Thanks anyway!

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.