Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
MIR Plug-in - no audio for the second instance until restart
Last post Mon, Nov 12 2012 by MS, 6 replies.
Options
Go to last post
Posted on Sat, Oct 27 2012 20:12
by TobiasWagner
Joined on Mon, May 26 2003, New York, Posts 50

Hey Guys,

While I abslutely LOVE the new MIR plug-in, I have come across a little problem using it in Logic on audio-tracks. If I instanciate it on one track it works just fine. As soon as I add an instance on a second (or more) audio track I get no sound from that track until I bypass the plugin. In order to fix the problem I quit Logic and re-open that session. Then everything is working again.

Performance of my Mac Pro is not an issue. I usually use all available instances of my MIR Pro24 without problems. I'm on OS X 10.7.4 with Logic 9.1.7, 24GB RAM in an old soon-retiring Mactopus.

Any clues?

Many thanks,

Tobias

UPDATE: As soon as any MIR-Plugin is either moved in Logic's mixer (i.e. to a lower slot), or a new MIR instance is added, only the first instance will put out sound. The other are all muted until the session is restarted.

Posted on Sat, Oct 27 2012 23:13
by Karel
Joined on Mon, Jan 19 2009, Belgium, Posts 2173

I assume you have the latency of MIR Pro set to 0 in its preferences, which will only work in Logic if your I/O Buffer Size and Process Buffer Range are set to the same value (512 = Small, 1024 = Medium, 2048 = Large). Otherwise it's best to set the MIR Pro latency to a non-zero value that is larger than the I/O Buffer Size.

Karel Bassez
Software Engineer
Vienna Symphonic Library
Posted on Sat, Oct 27 2012 23:48
by TobiasWagner
Joined on Mon, May 26 2003, New York, Posts 50

Hi Karel,

Thank you for your response. In fact, the latency of MIR was set to 512, as was Logic's. I now set the MIR's to 1024, leaving Logic's untouched. Still, the problem persists: I moved an instance of the MIR one slot down and lost that channel's signal. Have to restart Logic now to get it back. It feels more like a bug than anything else.

However [takes a deep breath], the other day I had no problems with multiple MIR instances in another session of a different project, opening or moving instances, and still getting sound from each one. The thing is, the sessions aren't all that different. I use a lot of UAD plugins in either case. One session gives me problems, the other doesn't.

Best,

Tobias

Posted on Wed, Oct 31 2012 21:25
by TobiasWagner
Joined on Mon, May 26 2003, New York, Posts 50

Hey Guys,

I really need some help on this one! There are several sessions where I don't have sound coming back from the MIR as soon as I have a second instance inserted. It's actually somewhat arbitrary: earlier, I had two instances up and running, and it failed on the third. Since then, I can only listen to one channel of MIR coming back to Logic's mixer, even if I take all instances out and start from scratch.

 Opened a backup session and had two instances running fine. Inserted a third one, and that one went mute. Then took out two instances and re-inserted one on that last channel that didn't work, and then it sounded (two instances running). A third one on a different channel went mute again. So I went back and cleared two instances and tried another channel, and only got dry signal, but at least sound. The top-most instance in Logic's arrange window always seems to work fine, not matter whether the other do or not. It's really hard to trouble-shoot.

THEN, I took one instance that wasn't working and turned Room-Tone button ON and OFF. It suddenly started putting signal through again, with reverb!! Unfortunately, with that I lost the ability to edit the WIDTH parameter in the MIR application for that channel! I did that with each instance that wasn't working and got the sound back, at the sacrifice of the width button for each channel (you can't even drag the sliders or enter numerical values in the parameters box as it is greyed-out). For someone determined to use the MIR under these circumstances, you need a good therapist to recover.

 Tried all kinds of different buffer sizes in Logic and MIR, restarting Logic, rebooting the Mac, repairing permissions and rebuilding the directory using diskwarrior. I'm running out of ideas. To my gut instinct this problem has BUG written all over it.

 Please help. I have two film-projects due tomorrow morning, having to mix and master all night. I would love to use the MIR as it really ties in my live-instruments with the rest of the ensemble. It's nothing less but GREAT when it works.

 Best,

Tobias

Posted on Mon, Nov 12 2012 06:45
by dinobass
Joined on Thu, Jul 26 2007, Posts 2

Same thing happened to me tonight with Digital Performer 7.24.  I downloaded the trial version of MIR Pro: first instrument worked fine but a second and third did not output any sound.  I came here, saw this post, and restarted DP: all instruments worked!  I use OSX 10.6.8 with an 8 core MacPro 3,1 with 18G RAM.

Posted on Mon, Nov 12 2012 14:18
by MS
Joined on Wed, Feb 19 2003, Liechtenstein, Posts 1732

Could you please zip up the MIR Pro logs (which you can find in /Users/yourusername/Library/Application Support/VSL/Vienna MIR Pro/logs) and send to , marked with "To Martin", so I can investigate what is going on.

Thanks,

--
Martin Saleteg
Software Developer
Vienna Symphonic Library GmbH
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.