Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
LOW MEMORY warnings - Did I buy a dud computer???
Last post Fri, Mar 20 2015 by civilization 3, 7 replies.
Options
Go to last post
Posted on Wed, Mar 11 2015 08:11
by twistiejoe
Joined on Mon, Nov 04 2013, Posts 28

Hey computer and VE experts,  can you help me out?

I'm using VE Pro on a slave machine, an old 2006 Mac Pro Tower 1,1, Quad Core, running OS 10.6.8, which I upgraded with 32GB of RAM and a 1TB SSD. 

I'm loading a few samples, and I can barley load any before I get LOW MEMORY warnings, and it begins to purge samples. I check out how my RAM is being used in Activity Monitor, and I have 25GB free! My computer isn't using all my RAM!

I've been trying to get help on forums - apparently I need to load in 64Bit Kernel (whatever that means), but apparently this computer can't actually do that ... but there is conjecture about it.

So what can I do? Does any one have advice? Will I need to buy a new machine or is there some way I can load this computer in 64Bit and have it use all of my RAM???

Thanks!

Main Machine: iMac 2.8Ghz, 16GB RAM, OSX 10.8.5
Slave Machine: MacPro 2,1. 2x 2.66 Quad-Core Intel Xeon, 32GB RAM OSX 10.6.8, samples streamed via SAMSUNG 1TB EVO (on SATA I though).
DAW: LogicX
Posted on Wed, Mar 11 2015 08:45
by kenneth.newby
Joined on Wed, Mar 19 2014, Posts 119

You need a 64-bit system to be able to address all of that RAM.  32-bits systems can only make use of 4 Gigabytes of RAM.  The SSD should not be an issue though.

Posted on Wed, Mar 11 2015 09:02
by twistiejoe
Joined on Mon, Nov 04 2013, Posts 28

What are my options then? 
I've been told by someone on an Apple forum that I can hack my macine to run in 64 and upgrade my OS with some kind of hacking ... thing ... but it's a bit beyond my expertise ... i think? Unless you know that it's easy and does in fact work?

Or ... do I try and get money for this machine and buy something new?
I'm considering going to a place called reanimac and seeing if they can help trade or something? I'm in Los Angeles...
Any advice would be greatly appreciated!

Main Machine: iMac 2.8Ghz, 16GB RAM, OSX 10.8.5
Slave Machine: MacPro 2,1. 2x 2.66 Quad-Core Intel Xeon, 32GB RAM OSX 10.6.8, samples streamed via SAMSUNG 1TB EVO (on SATA I though).
DAW: LogicX
Posted on Wed, Mar 11 2015 09:36
by marnix
Joined on Tue, Mar 16 2004, Vienna, Posts 993

Hello twistiejoe,

First thing I´d do is to run a RAM-testing utility like Memtest, which is still available for MacOS 10.6.8 - http://www.memtestosx.org/index.php/2-admin/2-memtest-osx-422

You don´t need to boot up in 64-kernel mode (which your machine indeed cannot...) to launch applications in 64-bit with 10.6.8 - just select the applications icon in the Finder, type Cmd-I to open the respective Info window and make sure the "Open in 32-bit" box is unchecked there.

Have you launched VE Pro Server 64-bit or 32-bit on your slave Mac?

Best, Marnix

Posted on Wed, Mar 11 2015 20:04
by twistiejoe
Joined on Mon, Nov 04 2013, Posts 28

Marnix! You are absolutely right! I feel so silly now
I wasn't running VE Pro in 64bit, and now it's working.

My problem now is that, because I'm on 10.6.8, some libraries don't work in Kontakt because they require a Kontakt update, but that's only possible to be uploaded in OS 10.7

But I'm worried I'll lose my applications and things if I upgrade to 10.7 ... hmm. what do to?

Main Machine: iMac 2.8Ghz, 16GB RAM, OSX 10.8.5
Slave Machine: MacPro 2,1. 2x 2.66 Quad-Core Intel Xeon, 32GB RAM OSX 10.6.8, samples streamed via SAMSUNG 1TB EVO (on SATA I though).
DAW: LogicX
Posted on Fri, Mar 20 2015 23:33
by civilization 3
Joined on Sat, May 16 2009, SF Bay Area, Posts 1749

Some of the NI that purportedly will not work will actually work. If you see minimum system 10.8, they did in fact change something in the way the kernel is handled and they totally can't work. However for a while it was only the installer that wouldn't work, and it wouldn't work normally. Extracting the files, if you know where to put them, they totally work, work perfectly. I think Kontakt at 5.4 is where its boundary lies. Reaktor 5.9.2, iirc. But I was using everything current up to a certain point. Everything new is never going to work under Snow Leopard and probably Lion. But I skipped Lion so I can't speak from experience.

There is an application called Pacifist that extracts the things inside the .pkg. Actually for the most part extract to default location suffices.

MacBook Pro 16,1: 2.3 GHz 8-core i9
64GB 2667MHz DDR4
OSX 10.15.6
VE Pro 7, Cubase Pro 11.0.10
Posted on Fri, Mar 20 2015 23:38
by civilization 3
Joined on Sat, May 16 2009, SF Bay Area, Posts 1749

The one thing I cannot use under 10.8.5, that I would have to update, is Final Cut Pro at the version I'm at.
A number of things bundled with the OS are replaced, Calculator and Address Book and all of this.
You have to refer to the vendor websites if there are things you don't know about.
But I really doubt anything you have working under Snow Leopard from NI is going to be broken by moving to 10.7, they merely made installers to have a minimum system "10.7"  in the property list for most of it.

MacBook Pro 16,1: 2.3 GHz 8-core i9
64GB 2667MHz DDR4
OSX 10.15.6
VE Pro 7, Cubase Pro 11.0.10
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.