Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
osascript
Last post Thu, Jan 31 2019 by Richard Ford, 11 replies.
Options
Go to last post
Posted on Thu, Jun 04 2015 17:56
by Kenneth Bauer
Joined on Sun, Dec 01 2013, California, Posts 1

I keep getting this message "osascript wants to make changes. Type your password to allow this."  I'd like to rid myself of it.  Should I uninstall VSL and do a clean install?

File Attachment(s):
osascript.pdf.zip (54kb) downloaded 20 time(s).

You cannot view/download attachments. Try to login or register.
Posted on Sat, Dec 23 2017 20:57
by fatis12_24918
Joined on Sat, Dec 16 2006, Posts 269

Same here. :(

Any answer?

Posted on Wed, Feb 28 2018 03:41
by Crescendo
Joined on Wed, Jul 16 2008, Posts 42

I am getting this osascript message now too every time I start VE-Pro 6 (latest version).
This happened right after I made a fresh install with Mac OS Sierra (used El Capitan before).

I would appreciate some help how to get rid of it.

Posted on Wed, Feb 28 2018 04:51
by Tensivity
Joined on Sun, Dec 16 2012, San Francisco California USA, Posts 272

Odd, I use VE Pro 6 with macOS High Sierra and have never seen this message.

Posted on Thu, Mar 01 2018 16:17
by marnix
Joined on Tue, Mar 16 2004, Vienna, Posts 983

Hi everybody,

OK, so it seems that some application (perhaps JBridge?) has altered a configuration file.

Please select "Go to folder..." in the Finders "Go" Menu, type in "/etc" and confirm.
Now please select "sysctl.conf" in this folder, open the file with your favourite text editor (f.i. Text Edit) and add the following:

kern.maxfiles=2200000
kern.maxfilesperproc=2000000

Then please save the sysctl.conf file to its original location and restart your computers - does that get you rid of the osascript message?

Best, Marnix

Posted on Sun, Mar 04 2018 07:47
by Crescendo
Joined on Wed, Jul 16 2008, Posts 42

Originally Posted by: marnix Go to Quoted Post

Now please select "sysctl.conf" in this folder,

no such file... I did a system wide search (including protected system files) and it seems not to exist.

There is only a sysctl.conf.5 within usr/share/man/man5/ - I don't think it is what we are looking for.

Posted on Sun, Mar 04 2018 13:04
by marnix
Joined on Tue, Mar 16 2004, Vienna, Posts 983

Hi Crescendo,

the /etc folder resides on root level, is by default invisible and will indeed not yield any results during a system wide search.

Have you tried to access it by selecting "Go to folder..." in the Finders "Go" Menu, typing in "/etc" and confirming?

Best, Marnix

Posted on Mon, Mar 05 2018 01:33
by Crescendo
Joined on Wed, Jul 16 2008, Posts 42

Originally Posted by: marnix Go to Quoted Post

Hi Crescendo,

the /etc folder resides on root level, is by default invisible and will indeed not yield any results during a system wide search.

Have you tried to access it by selecting "Go to folder..." in the Finders "Go" Menu, typing in "/etc" and confirming?

Best, Marnix

The file was not in there. I don't use spotlight since it never finds anything (I ue Find Any File, way better). I did some research and I found the file in the location you mentioned - but only on my backup drive. A little while ago I made a clean re-install of the system and backed everything up. While doing that I moved from El Capitan to Sierra. The new system installation obviously did not produce a "sysctl.conf". It must therefore be specific to VE-Pro. Since it is in such a exotic location I would not have known that it belongs to VE-Pro and therefore did not know it needs to be copied along with all the other files in Application Support, Preferences etc...

Now, since "sysctl.conf" is back at its place I can open VE-Pro and the message about osascript has not appeared again so far.

Posted on Mon, Jun 04 2018 16:45
by Rasound
Joined on Mon, Dec 05 2016, Posts 15

I getting also this osascript message now every time when I start my Logic X pro project or even VE-Pro 6,

the file "sysctl.conf" is at its place in "/etc" folder and it's looks like this:

kern.maxfiles=50000
kern.maxfilesperproc=50000
kern.maxfiles=2200000
kern.maxfilesperproc=2000000

but the osascript message appears anyway:(

osascript wants to make changes, enter your password to allow this.

I would very appreciate if some help how to get rid of it

Thanks in advance

Posted on Tue, Jun 05 2018 12:11
by marnix
Joined on Tue, Mar 16 2004, Vienna, Posts 983

Hi Rasound,

Please simply erase the entries

kern.maxfiles=50000
kern.maxfilesperproc=50000

leaving just the

kern.maxfiles=2200000
kern.maxfilesperproc=2000000

Then re-save the sysctl.conf to its original location and restart your computer - does that get you rid of the osascript message?

Best, Marnix

Posted on Thu, Jan 31 2019 13:54
by Richard Ford
Joined on Thu, Nov 25 2010, Posts 38

I'm still getting this issue - every time I switch on my Mac and run VEPro 6 for the first time I get the old chestnut osascript wants to make changes.

I've deleted JBridge completey (at least I think I have - I've removed the entire folder from Applications)  - and I've re-written (yet again) the /etc/sys.conf so it now only has the lines:

kern.maxfiles=2200000
kern.maxfilesperproc=2000000

But is still does it - I uninstalled everything Vienna and re-installed several months ago to try and fix this problem - (it didn't) I really haven't got the time to do that all again right now and don't have much confidence that it would do much anyway.

So for about a year or more I have lived with this annoyance - but it really gets on my nerves that I have do this every single day - since I have been getting this issue I have updated my OS (currently High Sierra) updated Cubase a couple of times, updated latest Vienna programs - but it still does it.

 

Are there any answers to this problem out there that actually solve the problem?

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.