Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Wha'ts the clicks/pops at low buffer samples?
Last post Mon, Jul 13 2015 by Cyril Blanc, 8 replies.
Options
Go to last post
Posted on Sat, Jul 11 2015 19:45
by rockman413
Joined on Thu, Dec 23 2010, China, Posts 77

I'm using PT as master and VE pros,  if I set playback engine of PT to maybe 56 samples(256 samples no problem) , I'll hear a lot of clicks/pops when playback ,  while the CPU usage is low and memory usage is low...   I thought this is a CPU spike problem however the cpu usage is only 10% and no core has reached over 50%.  Where is this clicks/pops come from?  

 (I'm using Kontakt inside VE pro, there're clicks/pops with multi core disabled in Kontakt and VE pro multi thread enabled ,  and Multi core enabled and ve pro multi thread to 1 per instance )

This is a technical question.~

Posted on Sat, Jul 11 2015 20:41
by Cyril Blanc
Joined on Thu, Dec 19 2002, Paris France, Posts 2724

Where are your samples, on what suport ?

MacBook Pro 2019 16" + 2 x Odisseey G9 49" Big Sur

MacPro 2010 12 core 2.93 ghz 64 GB Mac OS X 10.11 2722 Rocket Raid Sata III card with 8 x ssd

Kbd : P80 Yamaha, S88 and S25 Komplete Kontrol, DX7
I-Controls Pro, 2xMidi expression pedals
Synth : many....
--
Logic X , Dorico, Band In A Box, ORB Composer
VSL : MIR PRO, Appassionata Strings I, Solo strings , Wind and Brass Complete, Dimension Brass, Big Band Orchestra series, Many Synchronised libs
Kontakt, Omnisphere, QLSO, QLSC, CS 80, Arturia V5, Maximo, Realivox Blue. CS 80 V3, The Orchestra 2, Art Conductor, Genesis Children Choir, Lunaris, Lacrimosa

Final Cut pro
Camera full HD
Posted on Sun, Jul 12 2015 04:38
by rockman413
Joined on Thu, Dec 23 2010, China, Posts 77

Originally Posted by: Cyril Go to Quoted Post

Where are your samples, on what suport ?

 

I use kontakt instruments, and all instument samples has been loaded into Memory, so I don't think it's a problem of Harddrive.  Not sure if this answers your question.

Posted on Sun, Jul 12 2015 18:17
by Cyril Blanc
Joined on Thu, Dec 19 2002, Paris France, Posts 2724

To check this  you can monitor the disk I/O in Activity Monitor

Depending of your setup in Kontakt, it will load part or all the samples of your instruments into memory

When you get click and pops this mean your software does not have time to read all the samples.

If you see disk I/O during play you can improve this usind a sata III interface and a ssd

Originally Posted by: rockman413 Go to Quoted Post

Originally Posted by: Cyril Go to Quoted Post

Where are your samples, on what suport ?

 

I use kontakt instruments, and all instument samples has been loaded into Memory, so I don't think it's a problem of Harddrive.  Not sure if this answers your question.

MacBook Pro 2019 16" + 2 x Odisseey G9 49" Big Sur

MacPro 2010 12 core 2.93 ghz 64 GB Mac OS X 10.11 2722 Rocket Raid Sata III card with 8 x ssd

Kbd : P80 Yamaha, S88 and S25 Komplete Kontrol, DX7
I-Controls Pro, 2xMidi expression pedals
Synth : many....
--
Logic X , Dorico, Band In A Box, ORB Composer
VSL : MIR PRO, Appassionata Strings I, Solo strings , Wind and Brass Complete, Dimension Brass, Big Band Orchestra series, Many Synchronised libs
Kontakt, Omnisphere, QLSO, QLSC, CS 80, Arturia V5, Maximo, Realivox Blue. CS 80 V3, The Orchestra 2, Art Conductor, Genesis Children Choir, Lunaris, Lacrimosa

Final Cut pro
Camera full HD
Posted on Mon, Jul 13 2015 08:43
by rockman413
Joined on Thu, Dec 23 2010, China, Posts 77

Originally Posted by: Cyril Go to Quoted Post

To check this  you can monitor the disk I/O in Activity Monitor

Depending of your setup in Kontakt, it will load part or all the samples of your instruments into memory

When you get click and pops this mean your software does not have time to read all the samples.

If you see disk I/O during play you can improve this usind a sata III interface and a ssd

Originally Posted by: rockman413 Go to Quoted Post

Originally Posted by: Cyril Go to Quoted Post

Where are your samples, on what suport ?

 It's not a disk issue and I monited it.  There're clicks/pops or audio dropouts even for mic intput monitering at buffer size of 32 samples or 64 samples, while CPU is not full/ high/hot at all.

Posted on Mon, Jul 13 2015 13:16
by Cyril Blanc
Joined on Thu, Dec 19 2002, Paris France, Posts 2724

So you have I/O latency on your audio card

32 and 64 samples are very low and you do not get a delay playing live

 

Originally Posted by: rockman413 Go to Quoted Post

Originally Posted by: Cyril Go to Quoted Post

To check this  you can monitor the disk I/O in Activity Monitor

Depending of your setup in Kontakt, it will load part or all the samples of your instruments into memory

When you get click and pops this mean your software does not have time to read all the samples.

If you see disk I/O during play you can improve this usind a sata III interface and a ssd

Originally Posted by: rockman413 Go to Quoted Post

Originally Posted by: Cyril Go to Quoted Post

Where are your samples, on what suport ?

 It's not a disk issue and I monited it.  There're clicks/pops or audio dropouts even for mic intput monitering at buffer size of 32 samples or 64 samples, while CPU is not full/ high/hot at all.

MacBook Pro 2019 16" + 2 x Odisseey G9 49" Big Sur

MacPro 2010 12 core 2.93 ghz 64 GB Mac OS X 10.11 2722 Rocket Raid Sata III card with 8 x ssd

Kbd : P80 Yamaha, S88 and S25 Komplete Kontrol, DX7
I-Controls Pro, 2xMidi expression pedals
Synth : many....
--
Logic X , Dorico, Band In A Box, ORB Composer
VSL : MIR PRO, Appassionata Strings I, Solo strings , Wind and Brass Complete, Dimension Brass, Big Band Orchestra series, Many Synchronised libs
Kontakt, Omnisphere, QLSO, QLSC, CS 80, Arturia V5, Maximo, Realivox Blue. CS 80 V3, The Orchestra 2, Art Conductor, Genesis Children Choir, Lunaris, Lacrimosa

Final Cut pro
Camera full HD
Posted on Mon, Jul 13 2015 14:17
by rockman413
Joined on Thu, Dec 23 2010, China, Posts 77

I'm using Pro Tools 10 HD with Native card on board. I don't think it's an I/O latency ...

Originally Posted by: Cyril Go to Quoted Post

So you have I/O latency on your audio card

32 and 64 samples are very low and you do not get a delay playing live

 

Originally Posted by: rockman413 Go to Quoted Post

Originally Posted by: Cyril Go to Quoted Post

To check this  you can monitor the disk I/O in Activity Monitor

Depending of your setup in Kontakt, it will load part or all the samples of your instruments into memory

When you get click and pops this mean your software does not have time to read all the samples.

If you see disk I/O during play you can improve this usind a sata III interface and a ssd

Originally Posted by: rockman413 Go to Quoted Post

Originally Posted by: Cyril Go to Quoted Post

Where are your samples, on what suport ?

 It's not a disk issue and I monited it.  There're clicks/pops or audio dropouts even for mic intput monitering at buffer size of 32 samples or 64 samples, while CPU is not full/ high/hot at all.

Posted on Mon, Jul 13 2015 15:11
by Cyril Blanc
Joined on Thu, Dec 19 2002, Paris France, Posts 2724

Is it is no CPU, not I/O, no Audio card latency what could it be ?

I am happy with playing a full very complex ochestral piece at 256 samples

Originally Posted by: rockman413 Go to Quoted Post

I'm using Pro Tools 10 HD with Native card on board. I don't think it's an I/O latency ...

Originally Posted by: Cyril Go to Quoted Post

So you have I/O latency on your audio card

32 and 64 samples are very low and you do not get a delay playing live

 

Originally Posted by: rockman413 Go to Quoted Post

Originally Posted by: Cyril Go to Quoted Post

To check this  you can monitor the disk I/O in Activity Monitor

Depending of your setup in Kontakt, it will load part or all the samples of your instruments into memory

When you get click and pops this mean your software does not have time to read all the samples.

If you see disk I/O during play you can improve this usind a sata III interface and a ssd

Originally Posted by: rockman413 Go to Quoted Post

Originally Posted by: Cyril Go to Quoted Post

Where are your samples, on what suport ?

 It's not a disk issue and I monited it.  There're clicks/pops or audio dropouts even for mic intput monitering at buffer size of 32 samples or 64 samples, while CPU is not full/ high/hot at all.

MacBook Pro 2019 16" + 2 x Odisseey G9 49" Big Sur

MacPro 2010 12 core 2.93 ghz 64 GB Mac OS X 10.11 2722 Rocket Raid Sata III card with 8 x ssd

Kbd : P80 Yamaha, S88 and S25 Komplete Kontrol, DX7
I-Controls Pro, 2xMidi expression pedals
Synth : many....
--
Logic X , Dorico, Band In A Box, ORB Composer
VSL : MIR PRO, Appassionata Strings I, Solo strings , Wind and Brass Complete, Dimension Brass, Big Band Orchestra series, Many Synchronised libs
Kontakt, Omnisphere, QLSO, QLSC, CS 80, Arturia V5, Maximo, Realivox Blue. CS 80 V3, The Orchestra 2, Art Conductor, Genesis Children Choir, Lunaris, Lacrimosa

Final Cut pro
Camera full HD
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.