Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Bug in MIR
Last post Wed, Aug 10 2016 by tek0010, 4 replies.
Options
Go to last post
Posted on Tue, Aug 09 2016 07:18
by tek0010
Joined on Wed, Jun 17 2015, Posts 50

MIR plugin v5.4.14074

Reproducible in both Cubase 8.5.20 and Reaper 5.22. Steps to reproduce:

  1. Create new Reaper project.
  2. Create a track with a one-sample impulse at 1 second from the beginning.
  3. Add MIR as an insert.
  4. Turn on MIRx mode.
  5. Select MIRx Grosser Saal.
  6. Turn off Secondary Mic.
  7. Bypass all Room Equalizers.
  8. Turn on Wet Solo.
  9. In Reaper, render the track to a stereo stem.

The rendered audio includes an amplitude-attenuated, non-delayed one-sample impulse. See image: http://imgur.com/a/bc7Rw

I hadn't expected the appearance of this non-delayed impulse, so I try again:

  • In Reaper, render the track to a stereo stem.

The second time I render, the rendered audio includes no non-delayed one-sample impulse. Comparing the two renders by ear (subtracting one from the other), they sound identical except for the non-delayed impulse.

I get the same results when I use Cubase instead of Reaper: The first time I render, the rendered audio includes a non-delayed impulse; but the second time I render, it includes no non-delayed impulse. For rendering in Cubase, I'm routing the MIR track to a Group Track, and then I'm routing the Group Track to an Audio Track, and recording the Group Track's output on the Audio Track. This is the only way I know of in Cubase to render MIR's output to audio.

Please describe if there's a workaround to ensure consistent renders (without the superfluous non-delayed element in the wet signal)?

Posted on Wed, Aug 10 2016 15:23
by FlorianWalter
Joined on Thu, Sep 20 2007, Vienna / Munich, Posts 125

Thank you very much for your report, I just managed to reproduce this problem in Cubase, as you described it.

Some parameters in Vienna MIR Pro are being smoothed to avoid clicks, e.g. when you switch on an EQ or switch off the direct signal. This parameter smoothing is only performed while audio is running.

As soon as I was playing audio for a few seconds before recording the output signal, the output signal is fine. Loading a project and recording the output signal immediately works also fine, the only critical case is the one you've described: changing parameters after loading a project while audio is not running and then recording it immediately.

I'm afraid this problem occurs 'by design' and is not a bug that can be fixed. I'll look into it to confirm this, and I'll check why the parameter smoothing is not completed after one second - normally after 100ms all parameters should be completely up to date.

Best regards, Florian

Florian Walter
Vienna Symphonic Library GmbH
Posted on Wed, Aug 10 2016 15:46
by FlorianWalter
Joined on Thu, Sep 20 2007, Vienna / Munich, Posts 125

I just did another test:

In the menu entry  "Options -> Preferences" I disabled the option "Dynamic Processing". Now your test scenario works without any remaining direct signal. This might be a first option to make sure that you get consistent rendering results.

Best, Florian

Florian Walter
Vienna Symphonic Library GmbH
Posted on Wed, Aug 10 2016 23:30
by tek0010
Joined on Wed, Jun 17 2015, Posts 50

Originally Posted by: FlorianWalter Go to Quoted Post
...As soon as I was playing audio for a few seconds before recording the output signal, the output signal is fine. Loading a project and recording the output signal immediately works also fine, the only critical case is the one you've described: changing parameters after loading a project while audio is not running and then recording it immediately.

Thanks. In this case, I'll make sure audio is running for several seconds before I do any renders or freezes. (I just re-did the test in Reaper, this time playing audio for a few seconds before doing the initial render, and now the rendered audio includes no extraneous non-delayed impulse.)

Originally Posted by: FlorianWalter Go to Quoted Post
... I'll check why the parameter smoothing is not completed after one second - normally after 100ms all parameters should be completely up to date....

I see what you mean. That is odd. So the one second of silence I had before my impulse should have already worked around the issue, but it didn't for some reason that's still a mystery.

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.