Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
VEP6 - Logic and Cubase huge performance difference
Last post Fri, Aug 12 2016 by jon_wright, 5 replies.
Options
Go to last post
Posted on Wed, Aug 10 2016 11:40
by jon_wright
Joined on Sat, Jun 03 2006, Posts 26

Since installing VEP6 I've been refreshing the Cubase and Logic templates I run on my W10 PC slave.

I've found there to be a huge performance difference between the two DAWs. However I set them up in completely different ways, so I'm wondering if I've missed something obvious in the process.

Cubase 8.5

Connected to a VEP slave running 5 instances - one for each orchestral section - using Expression Maps to control articulations.

Logic X 10.2.4

Connected to VEP using one instance per instrument - using Skiswitcher to control articulations.

Both templates are set to run EW Hollywood Orchestra with exactly the same samples loaded and the same number of Play VI's.

Both templates, when unconnected, run at 0% CPU and take up around 19GB of RAM.

However when connected to Cubase at a buffer of 256, the CPU shoots up to 96% and stays there, I can only make any use of the template if I raise the buffer setting in Cubase to very high levels. Even then it can choke.

When I connect Logic at a buffer of 128, the CPU rises to just 3% and can handle the full orchestra playing without breaking a sweat. (The connection time is virtually instant now too, which is a huge bonus).

I've tried various different combinations of thread counts and buffer settings, as well as disabling a few instruments in VEP but it barely makes any difference in Cubase, it appears to be purely the act of connecting that causes the permanent CPU spike.

For there to be such a massive difference, I can only think I've done something wrong somewhere, any suggestions on what it could be?

Posted on Wed, Aug 10 2016 23:17
by Austin
Joined on Thu, Oct 31 2002, California, Posts 373

Hi Jon,

Make sure you have Asio Guard disabled in Cubase 8.5 for the Vienna Ensemble Pro 6 plugin as that can cause performance issues. To do this, go to Devices/Plug-in Manager and select Vienna Ensemble Pro that shows VST3.65 as the VST version and choose at the bottom "inactive" for Asio Guard. You may need to click on the small "i" on the bottom left for the bottom panel to display the Asio Guard information to change it from Active to Inactive.

Potato
Posted on Thu, Aug 11 2016 07:13
by jon_wright
Joined on Sat, Jun 03 2006, Posts 26

Hi Austin, thanks for the reply.

I already have ASIO Guard disabled, no difference there either unfortunately.

Posted on Fri, Aug 12 2016 01:50
by Austin
Joined on Thu, Oct 31 2002, California, Posts 373

I'm surprised to hear such a big difference in performance. What is your thread count set per instance in VE PRO 6? Make sure you are spreading your processor out properly on that front.

Potato
Posted on Fri, Aug 12 2016 08:06
by jon_wright
Joined on Sat, Jun 03 2006, Posts 26

Hey Austin,

Yep, I've tried every variation of thread count I can think of. It doesn't really seem to make much difference.

After much testing, it appears it's only when VI's are loaded into VEP that the problem occurs in Cubase. If the instances are empty there isn't a dramatic rise in CPU usage.

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.