Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
[SOLVED] VE Pro 6 Logic X Multiport issue
Last post Thu, Jan 19 2017 by eirikbj, 3 replies.
Options
Go to last post
Posted on Tue, Jan 17 2017 18:32
by Ben Willan
Joined on Sat, Jun 11 2016, Posts 7

I have set up a new template with the 6x16 Multiport Logic X session. I plan on using 6 instances all held within a VE server project. So far the first instance of VE works correctly with all the midi ports and midi channels responding correctly to the corresponding midi channels in Logic.

I have connected to the second instance via Logic and cannot get any sample playback from the second instance in VE. For some reason changing the midi ports to "All" in VE or selecting the instrument track "VE Pro Main 2" which has the inserted VE pro plugin works for sample playback. This means I can't use all 16 midi ports x 16 channels for sample play back which is what the multiport is designed to do.

Also, if this helps, if I open the midi envirment and re route VE Pro 1 ports 1-16 to VE Pro Main 2,3,4...the samples play back correctly and I can choose which ever ports I like in VE for playback. So there may be an issue with the routing in the Logic session.

How can I fix this so that all instances work correctly with the Multiport session?

Thanks.

Mac OS 10.12.2
Logic Pro X 10.2.4
Tags: VE Pro 6
Posted on Tue, Jan 17 2017 22:45
by Ben Willan
Joined on Sat, Jun 11 2016, Posts 7

SOLVED

The 6x16 Logic X multiport template has been routed using up to 48 ports. Creating a second instance in the same VE server project will mean that your first midi channel, listed under VE Pro Main 2, will be sent to midi port 17 in VE, not 1, despite it being labelled as port 1 in the Logic multiport template. The same is true for a third instance going to port 33, not 1.

The VE Pro 6 manual does say to increase the ports but only for the 2x48 Logic multiport template.

The midi channels just need relabeling in Logic if you're using the 6x16 template.

If you are using 6x16. Change ports per instance to 48 and bear in mind that:

VE Pro Main 1 > routes to port 1 in VE

VE Pro Main 2 > routes to port 17 in VE

VE Pro Main 3 > routes to port 33 in VE

VE Pro Main 4 > routes to port 1 in VE

VE Pro Main 5 > routes to port 17 in VE

VE Pro Main 6 > routes to port 33 in VE

Mac OS 10.12.2
Logic Pro X 10.2.4
Tags: VE Pro 6
Posted on Thu, Jan 19 2017 18:40
by eirikbj
Joined on Wed, Nov 18 2015, Posts 29

Does this happen to you?

https://vsl.co.at/community/posts/t42455-Instruments-behave-as-one-in-Multiport#post255911

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.