Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Instruments in Logic Pro X
Last post Sat, Nov 25 2017 by synergy543, 6 replies.
Options
Go to last post
Posted on Sat, Nov 18 2017 21:13
by americo
Joined on Thu, May 07 2015, Posts 10

Hello fellows, I'm having an issue, I've noticed a difference when playing any Vsl instruments in stand alone mode ad using the same instrument in logic pro, it is like logic don't have enough power to process the instrument performace. Is that possible?

Posted on Tue, Nov 21 2017 12:37
by Paul McGraw
Joined on Mon, Feb 29 2016, Georgia, USA, Posts 422

Originally Posted by: americo Go to Quoted Post

Hello fellows, I'm having an issue, I've noticed a difference when playing any Vsl instruments in stand alone mode ad using the same instrument in logic pro, it is like logic don't have enough power to process the instrument performace. Is that possible?

I have no experience with Logic Pro, but I have occasionally had performance issues in Cubase 8.5 and found there are two possible sources of trouble. 

1) Try increasing the preload size in the Directory Manager, even if using SSD. This will eliminate stutters and other artifacts.

2) Use "Task Manager" or the Apple equivalent to determine if you have enough RAM and CPU power to run both Logic Pro and VSL.

Good luck,

Paul

Posted on Wed, Nov 22 2017 07:45
by RLD
Joined on Thu, Jan 26 2017, Posts 68

You must check that in the Activity Monitor /Memory , Swap Used is = 0

If not you must either add more memory or reduce pre-load buffer size.

To reduce pre-load buffer size you must use Raid 0 of HD or SSD or Raid 0 of SSD

Posted on Wed, Nov 22 2017 18:03
by PaoloT
Joined on Tue, Dec 27 2016, Posts 675

Paul,

Is there a preferred preload size in VIPRO? I've left it unchanged, but if there is a better setting, I'll change it.

Paolo

Posted on Thu, Nov 23 2017 13:43
by Paul McGraw
Joined on Mon, Feb 29 2016, Georgia, USA, Posts 422

Originally Posted by: PaoloT Go to Quoted Post

Paul,

Is there a preferred preload size in VIPRO? I've left it unchanged, but if there is a better setting, I'll change it.

Paolo

Hi Paolo,

I am currently using 3172, but the best thing to do, in my opinion, is trying different settings and see which works best for you. If the problem is stuttering and unwanted artifacts, like a hard knocking sound, the solution is going to be the preload size. I am certain that different CPU and RAM configurations and different DAW software will use more or fewer resources within the DAW itself, so the perfect setting for you in Logic Pro is not likely to be the same as it is for me in Cubase.

Another possibility is to run your samples through Vienna Ensemble within Logic Pro. I have experimented with VE and it is much more efficient in the use of memory and CPU power. However, in my case, I just have not had to use it as I found good settings working directly in Cubase. You can get more help about VE in the software forum.

Paul

Posted on Sat, Nov 25 2017 22:29
by synergy543
Joined on Fri, Apr 01 2005, Posts 132

Paul, thanks for enlightening me on optimizing VSL for SSDs and regular drives.  Nice tip!  And clever method of managing this with the Directory Manager.

Although, it makes me wonder how this can be done for Kontakt too?  Without a Directory Manager, it seems Kontakt would be either global for all drives or a per Kontakt instance.  In any case, this is a discussion for another forum.  I've posted the question here:

https://vi-control.net/community/threads/optimizing-kontakt-preload-settings-for-both-ssds-regular-drives.66823/

Greg (Gregory D. Moore)
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.