Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Some Waves Plugins not showing up in VSL Server (64 Bit)
Last post Wed, Oct 10 2018 by beatpete, 13 replies.
Options
Go to last post
Posted on Sun, Aug 05 2018 06:53
by xiexiema
Joined on Wed, Jul 25 2018, Dubai, Posts 7

Windows 10 (latest)

Some of my Waves plugins are not showing up in VEP

  • These plugins all show and work perfectly within Cubase, Nuendo, Wavelab, Vegas Pro
  • They are all Waves V10 - (I do use V9) and all have vaild licenses
  • I Double checked that the correct paths are in VEP
  • I tried removing Waves Cache
  • Also tried removing the VSL Cache: C:\Users\USERNAME\AppData\Roaming\VSL\Vienna Ensemble Pro
  • This forced a rescan (again) - Still no sign of the missing plugins. Very odd.
  • Have removed the VST folders (in VEP) and added again etc. many times
  • Reinstalled the missing Waves plugins
  • Rescanned many times under various scenarios

The plugins appear to have been scanned as I see them in the VSL Log C:\Users\USERNAME\AppData\Roaming\VSL\Vienna Ensemble Pro\logs\app

Example:

2018-08-05 10:26:54.763 INFO  [9348] [VESplashScreen::] VESplashScreen: Testing VST plugin: Waves Abbey Road Chambers Stereo

2018-08-05 10:26:54.764 INFO  [9348] [VstPlugin::] Creating VST Plugin: C:/Program Files/VSTPlugIns/WaveShell2-VST 10.0_x64.dll

2018-08-05 10:26:54.767 INFO  [9348] [VstPlugin::] Destroying VST Plugin: C:/Program Files/VSTPlugIns/WaveShell2-VST 10.0_x64.dll

But those certain few plugins just do not appear in VEP at all (above Waves "Abbey Road Chambers Stereo" is an example).

Where does VEP store its list of plugins, maybe I can edit that list manually?

Any other ideas appreciated.

Thanks in advance.

P.

DAW: Windows 10: Cubase / Nuendo / Wavelab / VEP / Vegas Pro (All 64 Bit Latest). Hardware: i7:64GB RAM / RME Fireface UCX / UAD.
Posted on Mon, Aug 06 2018 07:20
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 10180

Hello P., 

Here is a possible solution:

Place WaveShell-VST 9.6_x64.dll & WaveShell-VST 9.7_x64.dll onto shell2vst64.exe and a folder called 'Waves' will be produced: inside will be the plugins you have purchased and you may move these to where ever is most convenient. Hope this clarifies. Shell2, 32bit and 64bit is available here

Best, 
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Mon, Aug 06 2018 07:22
by xiexiema
Joined on Wed, Jul 25 2018, Dubai, Posts 7

Originally Posted by: Paul Go to Quoted Post

Hello P., 

Here is a possible solution:

Place WaveShell-VST 9.6_x64.dll & WaveShell-VST 9.7_x64.dll onto shell2vst64.exe and a folder called 'Waves' will be produced: inside will be the plugins you have purchased and you may move these to where ever is most convenient. Hope this clarifies. Shell2, 32bit and 64bit is available here

Best, 
Paul

Thanks Paul. I did see that thread when seraching but I thought that was for older versions. I'll give it a go anyway.

Ahh, unofortunately the zip link is 404 :-/

Ok found it here: http://www.xlutop.com/buzz/zip/shell2vst.zip (non https link).

:-)

DAW: Windows 10: Cubase / Nuendo / Wavelab / VEP / Vegas Pro (All 64 Bit Latest). Hardware: i7:64GB RAM / RME Fireface UCX / UAD.
Posted on Mon, Aug 06 2018 07:47
by xiexiema
Joined on Wed, Jul 25 2018, Dubai, Posts 7

Hi again,

Ok so I ran the procedure using command line as drag and drop didn't seem to work.

Put all files (64 bit) into a new folder: C:\Program Files\VSTWaves

Added that path to VEP and removed the original folder withe the Waveshells. VEP seemed to scan them but they don't show up in VEP at all. even after restarting and rescanning a couple of times.

I'll keep trying...

Thanks again,

Phil.

DAW: Windows 10: Cubase / Nuendo / Wavelab / VEP / Vegas Pro (All 64 Bit Latest). Hardware: i7:64GB RAM / RME Fireface UCX / UAD.
Posted on Mon, Aug 06 2018 08:04
by xiexiema
Joined on Wed, Jul 25 2018, Dubai, Posts 7

More info:

There are two Waveshells:

WaveShell1-VST 10.0_x64 / WaveShell2-VST 10.0_x64

The missing plugins are all contained in WaveShell2-VST 10.0_x64

If I remove WaveShell1-VST 10.0_x64 frome the VSTPuginst folder then the plugins from WaveShell2-VST 10.0_x64 show up.

As soon as I put WaveShell1-VST 10.0_x64 back, only the WaveShell1-VST 10.0_x64 plugins show up.

I will contact Waves again with this info.

DAW: Windows 10: Cubase / Nuendo / Wavelab / VEP / Vegas Pro (All 64 Bit Latest). Hardware: i7:64GB RAM / RME Fireface UCX / UAD.
Posted on Mon, Aug 06 2018 08:47
by xiexiema
Joined on Wed, Jul 25 2018, Dubai, Posts 7

OK more, more info:

I installed Studio Rack. Which is WaveShell-VST 9.7_x64.dll. I was reluctant to do this as I did not want any V9 shells.

Anyway, now:

Non of the V10 plugins show up in VEP but they all appear in Studio Rack. So it seems that VEP will only read 1 Waveshell and that is all.

In Cubase etc. everything is fine, all V10 plugins show and studiorack.

DAW: Windows 10: Cubase / Nuendo / Wavelab / VEP / Vegas Pro (All 64 Bit Latest). Hardware: i7:64GB RAM / RME Fireface UCX / UAD.
Posted on Mon, Aug 06 2018 10:33
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 10180

Hi, 

Could be that a WaveShell always gets the same Plug-in ID, which would explain this behaviour. 

We will investigate this, but unfortunately I cannot give you an estimate at this point. 

Best, 
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Mon, Aug 06 2018 11:01
by xiexiema
Joined on Wed, Jul 25 2018, Dubai, Posts 7

Originally Posted by: Paul Go to Quoted Post

Hi, 

Could be that a WaveShell always gets the same Plug-in ID, which would explain this behaviour. 

We will investigate this, but unfortunately I cannot give you an estimate at this point. 

Best, 
Paul

Thanks Paul at least you are aware. I will PM you some other info that may be useful. If you need any logs etc. let me know.

DAW: Windows 10: Cubase / Nuendo / Wavelab / VEP / Vegas Pro (All 64 Bit Latest). Hardware: i7:64GB RAM / RME Fireface UCX / UAD.
Posted on Fri, Aug 31 2018 00:21
by JamesPDX
Joined on Fri, May 01 2015, USA, Posts 31

Yeah, I wish I saw this post before I "repaired" my Waves v10 plugins. Oddly, they show up and all work on a Mac running High Sierra. Not so (except for Codex) on a Windows 10 PC.

James Long
Posted on Tue, Oct 09 2018 14:59
by beatpete
Joined on Thu, Oct 01 2009, Posts 50

Me too, because there are 2 versions of the waveshell 10, VEP can only see 1 and "shell2vst" doesn't work with waveshell 1. Anyone actually go this working on Windows?

Comp1: Windows 10 64 bit, Asus X99-A USB 3.1, I7 5930K (running at 4500 MHz), 32 gb Corsair Vengeance DDR4 ram, Radeon HD5450 graphics, RME Digiface, Steinberg UR824 and MR816x (X2)
(connected to Digiface), Cubase 9.0.20 64bit
Comp 2: Windows 7 64bit, I5 3450,16 gb ram, VEPro.
Posted on Tue, Oct 09 2018 20:12
by T.K.
Joined on Sat, Oct 16 2010, Japan, Posts 9

I previously posted the same topic, but the same symptoms seem to be increasing.

If "WaveShell1-VST 10.0_x64"  and "WaveShell2-VST 10.0_x64" are at the same time, 1 will be ignored and only 2 will work.
If 2 is deleted, 1 is recognized normally.
In my DAW, I recognize all the WAVES plugins. Is this a bug in the Waves plugin?

In addition, in my environment, it seems that "Abbey Road Chambers" is not recognized only when comparing VEP and DAW.

T.K

* This sentence uses Google Translate.

T.K.
Win10Pro(64bit) (2Processo) 48GBRAM
CakeWalk(by BandLab)
MIRPro/SUITEPro/VEP6
Posted on Tue, Oct 09 2018 22:19
by beatpete
Joined on Thu, Oct 01 2009, Posts 50

Yes, this is the same with me, VEP can only see waveshell 1 OR 2 but not both. I spoke to Waves and they claim VEP is not supported and it's up to them to figure it out.

Comp1: Windows 10 64 bit, Asus X99-A USB 3.1, I7 5930K (running at 4500 MHz), 32 gb Corsair Vengeance DDR4 ram, Radeon HD5450 graphics, RME Digiface, Steinberg UR824 and MR816x (X2)
(connected to Digiface), Cubase 9.0.20 64bit
Comp 2: Windows 7 64bit, I5 3450,16 gb ram, VEPro.
Posted on Wed, Oct 10 2018 16:32
by beatpete
Joined on Thu, Oct 01 2009, Posts 50

I believe I just found a workaround. The file "shell2vst64.exe" worked in Windows 7 so I ran it in Windows 10 with "Windows 7 comatability" and "Run as Administrator" and it worked! Just drag both waveshells on to the "shell2vst64.exe" and it creates a "Waves" folder with all the .dll files (just as in Windows 7).

Hope this helps...

Comp1: Windows 10 64 bit, Asus X99-A USB 3.1, I7 5930K (running at 4500 MHz), 32 gb Corsair Vengeance DDR4 ram, Radeon HD5450 graphics, RME Digiface, Steinberg UR824 and MR816x (X2)
(connected to Digiface), Cubase 9.0.20 64bit
Comp 2: Windows 7 64bit, I5 3450,16 gb ram, VEPro.
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.