Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
T2 Mac issues
Last post Sun, Apr 26 2020 by RCMusic23, 2 replies.
Options
Go to last post
Posted on Mon, Jan 13 2020 18:52
by lupine
Joined on Sun, Feb 14 2016, Posts 17

Hello,

have anyone encountered issues with T2-equipped Macs?
I have a MacBook Pro 15" mid-2018 and often I get hangs and crashes with Cubase and VE Pro during bouncing.
Sometimes I even get clicks in bounced audio (!).
Have you ever get this kind of problems?

Thanks

Posted on Sun, Apr 26 2020 20:37
by RCMusic23
Joined on Wed, Apr 30 2014, Posts 26

Hi Lupine,

Yes. I had a MBP 15 2018, i7 8th Gen, 32GB RAM. Lovely machine. But...I sometimes got clicks and pops too, with using around 25 - 35 Special Editions instruments (not the Synchron player new Special Editions) and some other libraries together, such as LASS Lite. So not too heavy for it. But still, some issues. I had to up the buffer as 128/256 weren't always stable and still gave me good low latency times.

I would have thought it would have been able to handle all that without any issues at all. To be fair, it did most of the time. But I never felt I got my value for what I paid for it. I since learnt from others here and in general, that laptops aren't great at managing heavier orchestral workloads, even high spec ones. After 3 years of Apple, I realised that I'm paying over the top for an equivalent PC/Windows system and have always been more comfortable with Windows (conversly to most I'd expect).

Anyway, laptops just don't seem powerful enough in comparison to desktop builds unfortunately. So I've just finished building my first PC from using a i9 CPU pre-installed gaming motherbord, adding my own RAM and SSD parts. It works much better. I may get a laptop to use away from the desk or to share the load as I have 2 VEP 7 licenses or even within a master/slave setup. The next laptop it will be one where I can install more RAM and SSD storage in myself later on. Not a MacBook basically.

I did hear about the T2 chip causing issues. I can't remember what it was though. Are there specific T2 chip issues going on with music software?

i9-9900K
64GB RAM

VE Pro 7 / MIR Pro / Sibelius Ultimate / Cubase Pro 10.
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.