Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Options
Go to last post
Posted on Sat, Jun 13 2020 22:35
by PaoloT
Joined on Tue, Dec 27 2016, Posts 1189

Hi,

I've created some Logic's articulation sets for the BBO libraries I own. They work smoothly and as expected when playing the sequence back.

Also, there are no problems when manually selected an articulation in the Synchron Player, and playing it from the master keyboard.

When starting to record, however, the default articulation in the articulation set is selected. I would like, instead, to be able to record with the last manually selected articulation.

It also happens sometimes when playing with a high velocity on the keyboard.

Is this an issue to be solved on Logic's side, or is it something that can be checked on the Synchron Player's side?

Paolo

Posted on Sat, Jun 13 2020 23:28
by Dewdman42
Joined on Tue, Feb 27 2018, Posts 809

make sure the first articulation on the articulation Set list is a dummy articulation with nothing configured in the output section (no keyswitches)

LogicPro has an annoying "feature" where if there are notes without any articulationID assigned, then it will send the output keyswitches of the first articulation in the articulation set list...  

If you use a dummy without any keyswitches, then no keyswitches will get sent by that annoying feature, so your notes without an articulationID will just play through without any Keyswitch and you'll hear the last one.

I usually set the first articulation on the list with id=254 and that is my dummy articulationID.  the only downside is that in the articulation pulldown menus, you always see this dummy id at the top of the list...which is yet another annoyance.  

Make sure to submit your annoyance to Apple bug report...

Posted on Sat, Jun 13 2020 23:46
by PaoloT
Joined on Tue, Dec 27 2016, Posts 1189

Originally Posted by: Dewdman42 Go to Quoted Post

make sure the first articulation on the articulation Set list is a dummy articulation with nothing configured in the output section (no keyswitches)

Dewdman, as usually you have the right answer!

Yes, adding the dummy articulation at the beginning of the list does the job.

I'll be sure to file the bug (again) with Apple.

Thank you for the hint!

Paolo

Posted on Sat, Jun 13 2020 23:51
by Dewdman42
Joined on Tue, Feb 27 2018, Posts 809

happy to help.  You can make your dummy articulation less annoying by labeling it as "-" or something so that at least your articulation pull down menu will just have a "-" at the top of the list rather then "dummy".

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.