Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Synchron player introduces insane amount of latency
Last post Sun, Jun 28 2020 by Paul, 8 replies.
Options
Go to last post
Posted on Fri, Jun 26 2020 22:07
by Ziobello
Joined on Wed, Nov 25 2009, Posts 27

Hi there,

I'm using VEPro 7 on a satellite computer. Without Synchron Player - that I use exclusively with the Synchronized special editions - the latency is acceptable, but as soon as I instantiate a Synchron player it becomes unacceptably big, sometimes without showing any difference in the bottom right of VEPro.

Is there any setting I have to tweak to avoid this?

Thanks

Posted on Sat, Jun 27 2020 04:50
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12232

Hi Ziobello, 

That shouldn't be the case, of course. Synchron Player should behave like any other plug-in. 

Which other plug-ins are you using in VE Pro, and can you please share a few more details about your system?

Best, 
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Sat, Jun 27 2020 06:19
by Ziobello
Joined on Wed, Nov 25 2009, Posts 27

Hi Paul,

thanks for your reply.

I have a late 2012 MacMini 2.3 GHz Quad-Core Intel Core i7 with 16GB of RAM as the main machine, running Nuendo 10.3, with MacOS 10.15.5

For the server I have a Apple Mac Pro 5,1"Westmere" 3.46GHz 12 Core 64GB of RAM, with MacOS 10.12.6 running VEPro 7.

In my template I have one instance with all the orchestral sections, plus some electronic sounds, when it's fully loaded, the RAM is around 70% full. I set the threads in the preferences at 21 threads per instance, since I only have one.

In Nuendo the buffer size is at 512, and I use 1 buffer in the VEPro VST instrument.

I see the plugin latency compensation going up to 584 with 1 or more SYN Player, but as soon as I remove them, it goes down to 471. Still the latency is pretty high when playing, and I was wondering which setting should I tweak in order to make it work better.

I attached the screenshot of the VEPro, Synchron and Audio System in Nuendo

File Attachment(s):
ScreenU0020ShotU00202020-06-26U0020atU002011.04.01U0020PM.png (329kb) downloaded 2 time(s).
Ziobello attached the following image(s):
ScreenU0020ShotU00202020-06-26U0020atU002011.16.20U0020PM.png (46kb) downloaded 1 time(s).
ScreenU0020ShotU00202020-06-26U0020atU002011.05.17U0020PM.png (154kb) downloaded 1 time(s).

You cannot view/download attachments. Try to login or register.
Posted on Sat, Jun 27 2020 06:29
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12232

Hi Ziobello, 

I'd definitely choose higher streaming and loading thread settings in Synchron Player (4/4 should be good to start). 

The latency you see displayed in the lower right corner is the plug-in induced latency (with SYNCHRON-ized products, that's because of the used Impulse Responses). But that shouldn't affect the real-time latency when you are playing. 

Does it improve when you set the network buffers in the VE Pro Plug-in to 0?

Best,
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Sat, Jun 27 2020 06:38
by Ziobello
Joined on Wed, Nov 25 2009, Posts 27

Thanks Paul.

My computer can't handle 512 with 0 buffers. I had to go back to 1024 - which I assume is the same as 512 with 1 buffer?

I'll try that with the Synchron player. But as a whole, what could be the reason of such a noticeable latency when playing? Do you think it's normal that a system like mine can't handle 512 as a buffer?

Do you have any suggestion about tweakings that I should check to make thing faster?

Posted on Sat, Jun 27 2020 13:47
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12232

Hi, 

Yes, switching from 512 to 1024 has the same effect.

What exactly are you playing back, and how much latency do you get?

Best, 
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Sat, Jun 27 2020 16:41
by Ziobello
Joined on Wed, Nov 25 2009, Posts 27
Playing back the music, once recorded or after manual input in Nuendo works fine.

It’s the live performance trying to record that is problematic, since the latency is so high.

Any suggestions on how to reduce that. Just to make sure I was clear, that’s the latency I was talking about in the title of the post. And that is made higher by introducing the SYN player in the template.
Posted on Sun, Jun 28 2020 12:59
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12232

Hi Ziobello. 

Thanks. I'm trying to find out how much latency we are talking about... Synchron Player latency should be exactly the same for live playing as all other plug-ins. 

Best, 
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.