Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Options
Go to last post
Posted on Sat, Apr 17 2021 20:47
by Yannick82
Joined on Fri, Apr 09 2021, Belgium, Posts 16

On my desktop, I hardly notice any loading time for the smart orchestra. It's almost instantaneous while on my laptop (surface book 2) it takes 2 to 3 minutes before the samples are loaded. 

On my desktop the library is installed on an NVMe HD and Synchron shows a reading speed of around 600MB/s

On my laptop I use an external USB 3.0 SSD and syncrhon shows a reading speed of around 450MB/s 

I would expect some difference between my desktop and laptop but not that much... For comparison, I also have a subscription on composer cloud and those libraries are known to be slow loaders but the difference between desktop and laptop is not that big so that's why I feel something else is going on... 
The smart orchestra takes much longer to load on my laptop than the EWQL Hollywood orchestra while on my desktop the smart orchestra loads in less than a second while the Hollywood orchestra loads in around 15 to 20 seconds. 

Is there anything I can do to make it load faster? Or what would be causing this big difference? 

Posted on Mon, Apr 19 2021 11:09
by Andreas8420
Joined on Mon, Dec 02 2019, Vienna, Posts 64

Hello Yannick82,

Is it possible that your external SSD is formated with an exFAT file system? That would slow down performance tremendously.

https://www.vsl.info/en/tutorials/faqs/technical#hard-drive-format

Best regards,
Andreas

Technical Support - Vienna Symphonic Library
Posted on Mon, Apr 19 2021 11:21
by Yannick82
Joined on Fri, Apr 09 2021, Belgium, Posts 16

I just checked and it's NTFS so don't think that's the problem. 

Posted on Tue, Apr 20 2021 08:22
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12787

Hello Yannick, 

NTFS on Windows, correct? Did you check the cable and connection?

Best, 
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Tue, Apr 20 2021 21:07
by Yannick82
Joined on Fri, Apr 09 2021, Belgium, Posts 16

NTFS on windows correct.

The USB cable is a USB 3.2 gen2 cable with speeds up to 10Gbps. 

I did a few tests with other libraries and measured them vs my NVMe in my desktop. 

With some heavy libraries from EWQL, the load times are 3 times longer on my SSD vs NVMe on my desktop which is expected but Smart Orchestra goes from around a second to more than 2 minutes! That's not normal, right? 

I am planning to buy synchron-ized special edition but I am worried that these load times will be even much higher since it needs to load much more samples... 

I also monitored my resources while he is loading. None of my CPU cores is at 100%. I believe none even went higher than 50%. 

The SSD only showed a read speed of 4MB/s during that time with most of time between 2 and 3. The active time is at 100% so that is causing the bottleneck. The average response time is 18ms

When I copy the library folder from the SSD to my internal HD, the SSD performs much better with 115MB/s and response time of 8ms and active time around 95% 

When I load an East West library, the response time is <2ms and read speed goes up to 14MB/s with active time around 60%. 

These numbers clearly show something in the syncrhon player is causing that bottleneck on my SSD which makes the response time go up and the read speed go down

Posted on Tue, Apr 27 2021 08:58
by Andreas8420
Joined on Mon, Dec 02 2019, Vienna, Posts 64

Hello Yannick82,

You can run a detailed disk speed check with CrystalDiskMark / AmorphousDiskMark - and also, please turn off any antivirus software. Some antivirus software may be trying to scan everything read by the Vienna Synchron Player. And in that case, that 3rd party AV would be the most likely culprit here.

Best regards,
Andreas

Technical Support - Vienna Symphonic Library
Posted on Tue, Apr 27 2021 20:41
by Yannick82
Joined on Fri, Apr 09 2021, Belgium, Posts 16

Thanks for the tip. I did a test on my external SSD and notice I " only" got 118MB/s read speed. It's weird because I actually thought I bought a faster one but it's a model from 2019 so maybe I forgot... 

Also weird because Syncron player measured 621MB/s so that's why I though I was good and the issue wasn't my SSD. 

I will probably go to the shop tomorrow and buy a Samsung T5. That should provide me with much better performance. 

Yannick82 attached the following image(s):
Capture.PNG (52kb) downloaded 0 time(s).
Capture2.PNG (11kb) downloaded 0 time(s).

You cannot view/download attachments. Try to login or register.
Posted on Wed, Apr 28 2021 18:17
by Yannick82
Joined on Fri, Apr 09 2021, Belgium, Posts 16

Today I bought the sandisk extreme SSD which is an NVMe portable disk if I'm not mistaken. It gives around 1000MB/s read speed and indeed... It solved my problem :) 
Synchron libraries now load in a second or so... 

Glad to have figured it out thanks to the tip for the disk speed analyzer..

That being said... Maybe it's worth investigating why Sychron thinks my slow external disk has 600+MB/s read speed instead of around 110. 

I did a test on my desktop as well and crystalDiskMark rates my internal NVMe around 2200MB/s but Syncrhon also measures around 600MB/s so something isn't correct there. 

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.