Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
VE Pro 7 max CPU usage on idle
Last post Thu, Aug 12 2021 by Macker, 5 replies.
Options
Go to last post
Posted on Tue, Aug 03 2021 07:33
by lupine
Joined on Sun, Feb 14 2016, Posts 55

Hello,

as soon as I start playback on my DAW (connected to a VE Pro 7 server project) I notice VE Pro 7 filling up CPU usage (626% on a 10 cores CPU!) and my computer fan spinning like crazy at maximum speed.
Buffer size is set to maximum and all of my VSL instruments preload are set to maximum too.
Stopping playback does not turn my computer back to normal: VE Pro usage remains at 276% and fan continues spinning at maximum speed.
The only thing to do to stop that is closing VE Pro/DAW project 

My computer is using an Intel 10 cores CPU, 128GB RAM and internal NVME drive to store instruments samples.
Hope you can help.

Posted on Mon, Aug 09 2021 06:13
by Falcowe
Joined on Mon, Nov 06 2017, Nashville, Posts 16

Hello lupine,

Have you had this working in the past without this behavior? 

Without knowing more precisely what is in your VEPro session etc I do find a few things odd.

1. If your DAW is set to it’s maximum buffer size (either 1024 or 2048? I’m assuming?) then having such high CPU usage is strange indeed.

2. 626% out of a 1000% right? To be honest that doesn’t completely impossible but hard to know with the info you gave. 

3. Are you running your VEPro session locally on your DAW machine or is it on another computer? Do you have another computer to test with if the former?

4. I would say when you have stopped playback 275% seems normal. But only if your buffer size was something in the 256 samples neighborhood (@ 48k) not at maximum buffer settings.

5. What is the sample rate of your project? 

6. What is your RAM usage? 

And finally I am sadly not familiar with VSL sample libraries so they may be more CPU demanding, I just don’t know as I don’t own/use any of their libraries in my work. I do find it possible that they could be more CPU intensive and that the behavior you describe could be normal for VSL’s libraries but I suspect not. If you are running your DAW on the same machine, and depending on what is in your DAW the 600% CPU usage could be absolutely normal. It’s impossible to give you a definitive answer with out more specific information. And even then you’ll need to do some more troubleshooting to figure out if maybe it’s your DAW causing the high CPU usage or VEPro, or even a background takes in Windows (well I’m assuming your are running Windows… is that correct?) If your are running OSX then maybe you are thermally throttling if you are on a Laptop? If you are on a desktop, (i.e. 2013 MacPro) then maybe the CPU is inefficient and what you are trying to run needs a newer more efficient CPU? (Although I find that unlikely). Maybe faster RAM would help, what is your RAM specs? Maybe you are trying to load too much into RAM and that is causing problems? Conversely maybe you are trying to stream too much from disk and that is causing problems? Maybe if you are running VEPro locally your DAW is hogging RAM causing a RAM shortage in VEPro even though it looks like it should be fine. I’m literally grasping at straws here, but all of that to say, troubleshoot some more, and provide some more details and hopefully you can find your problem. I realize it can be frustrating, but unfortunate there is not magic solution or guide I can give you to solve your problems. My own year and a half of Troubleshooting ended up with me realizing that I needed A LOT more RAM than I had. And the 256GB+ that I have is still not quite enough for what I would like to do. But I have made it work. 

ProTools 2021.7 Ultimate - DAW Machine: MacPro7,1 128GB Ram 16-core AMDW5700X - Slave 1: Windows 10, AMD 1950X 4.2GHz, NVIDIA GT710, 64GB 2666MHz - Slave 2: Windows 10, Intel 7820X 4.7GHz, NVIDIA GT710, 64GB 3666MHz.
Posted on Tue, Aug 10 2021 15:45
by lupine
Joined on Sun, Feb 14 2016, Posts 55

Hello Falcowe,

thanks for your reply.

These are the characteristics of my computer:
• iMac 27" 2020
• Intel i9-10910 3.6 GHz 10-core
• 128 GB 2667 MHz DDR4 RAM (~35 GB free RAM during project running)
• Internal NVMe SSD with both OS, applications and libraries samples
• DAW tested: Cubase 11 Pro and Studio One 5.3 Pro
• Sample rate: 44100
• Bit depth: 32 float

These are VE Pro 7 settings:
• 7 running instances on
• 3 threads per instance
• 23 MIDI ports per instance
• 8 audio outputs per instance
• 4 audio inputs per instance
• MIR Pro latency: 1024
• MIR Pro IR cache: 2 GB

I tried using a different computer (laptop) with lower specs but the issue is still there.
I have installed a third-party CPU monitor application and the strange thing is that the usage indicator of each virtual thread is always incredibly low, but the fan keep spinning like crazy and macOS internal activity indicator application shows the posted numbers (~300% idle - ~600% playback).
Looking at my computer specs it should not have those kind of problems, and it should not have as much thermal throttling since the the CPU usage never reaches full cores 100%.
I noticed that the CPU frequency is always around ~4.4GHz, could be that the culprit?

Posted on Thu, Aug 12 2021 15:50
by Falcowe
Joined on Mon, Nov 06 2017, Nashville, Posts 16

Yep I would say your last sentence is your culprit. iMacs are notoriously noisy under load. And since your CPU is staying at 4.4GHz the entire time while your DAW is connected to your VEPro session that would be why the fans are spinning up. To prevent the CPU from thermal throttling. If they didn’t spin up that loud you’d likely be stuck at a CPU clock speed that is below base clock rather than the turbo you have now. I am not aware of a setting that could help reduce the turbo under load but. Then that would likely cause other issues if you were able to disable turbo.

All that to say, I think you have found the “problem” but I am not sure there is actually a problem. It sounds like the computer is behaving normally. And if you are not having any issues with VEPro and playback (pops, click, dropouts, etc) then I would say that this is just he way the computer functions. Maybe try networking your VEPro machine and sticking it in another room? Fingers crossed that it isn’t your DAW causing the permanent Turbo boost.

ProTools 2021.7 Ultimate - DAW Machine: MacPro7,1 128GB Ram 16-core AMDW5700X - Slave 1: Windows 10, AMD 1950X 4.2GHz, NVIDIA GT710, 64GB 2666MHz - Slave 2: Windows 10, Intel 7820X 4.7GHz, NVIDIA GT710, 64GB 3666MHz.
Posted on Thu, Aug 12 2021 18:30
by Macker
Joined on Tue, Aug 21 2018, London, Posts 356

Lupine, I concur with Falcowe - your CPU seems to be running at max turbo boost and the fans blowing hard as hell is evidence of that. However, I too am very puzzled that your CPU monitor is not showing much evidence of cores being pushed to the limit.

I've sometimes used the (free) Intel Power Gadget to monitor CPU clock speed and thermal stress.

It is significant that you've found the same thing happening with this project running in your laptop instead of your iMac; because that appears to eliminate the possibility that your iMac has a system fault.

I'm currently running a VEPro-based project probably not greatly different from your project, in my 2017 iMac (4.2 GHz 7700K 4 core CPU), but I've never encountered the CPU mayhem on idle that you've described. Idle on my system is pretty relaxed. Most of my virtual instruments in VEPro are in VSL Synchron Players, with a couple of dozen Kontakts. But I don't have MIR Pro. Also, in all my Synchron Players the convolution reverb is switched off on every mixer channel - because large numbers of them can very easily demand far too much CPU.

One investigative procedure I'd suggest you try is to disable VEPro instances, one at a time, until you have none enabled. If then there's still CPU mayhem on idle, obviously we need to look elsewhere. If there's one VEPro instance that seems to be the culprit, disable each of its channels, one by one, to see if the problem can be localised in that way. Also, try completely disabling MIR Pro - indeed try that before anything else.

[Edit] I wonder if it might help to run your iMac's Activity Monitor, with CPU HIstory enabled (in the Window menu of the top menu bar). Although even on fastest refresh rate these CPU History graphs can't show any very fast intermittent spikes of activity (which I suspect may be what is happening in your project), they might nevertheless give you some additional insight.

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.