Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Mac Studio Ultra / P Tools / Best strategy
Last post Thu, Apr 07 2022 by glasswing, 7 replies.
Options
Go to last post
Posted on Mon, Apr 04 2022 12:59
by glasswing
Joined on Fri, Feb 15 2013, Vancouver Island, Posts 23

I'm reinstalling my world after ten years on two 5.1 Mac Pros.  One machine was a VEP slave -  with Pro Tools HDX on the other.  Over time and with the expanding libraries (Spitfire etc) things got very unpredictable, so I bought a Mac Studio Ultra / 128 RAM / 2TB internal / 6TB NVMe (2XSonnet Echo Dual.Thunderbolt)  One NVMe = a 4 TB Raid for VI libraries.  The other for Pro Tools sessions.  I'm wondering if I should still use VEP on the Mac Studio Ultra?  It seems to make better use of hyper threading / cores etc.  Any Pro Tools VEP users out there who can comment?
It would all be running via Rosetta, so I'm HOPING VEP will work.  
Thanks

Posted on Mon, Apr 04 2022 16:05
by Macker
Joined on Tue, Aug 21 2018, London, Posts 589

Sounds like a great adventure - wishing you the very best of luck! Please do keep us posted. (Not a PT user, but hell I'm keen to know about your new rocket ship!)

One thing about Mac Studio and Ultra that grabs my fancy big time is the insane leap up in memory-cycle speed! Years ago I recall being so proud that I'd bought a new Mac that had 1 GHz memory bus bandwidth. But now the Ultra operates with unified memory at 800 GB/s !!! Nothing else comes close.

It may be a bit uncomfortable for us now that there's no possibilty of RAM expansion later on. But this astronomical memory bus speed requires extremely close coupling between the M1 Ultra silicon wafers and unified RAM chips. 'Long' copper tracks on a printed circuit board just can't handle that kind of speed (transmission-line physics being what it is). The Ultra's SSD is also super damn fast, and also is necessarily plumbed in very closely (and permanently) to the main silicon cluster.

When VEPro eventually goes full-on M1 native, oh man, that'll be a truly splendid rig you'll have there for streaming instrument samples.

"Music embodies feeling without forcing it to contend and combine with thought, as it is forced in most arts and especially in the art of words."
~ Franz Liszt
Posted on Mon, Apr 04 2022 16:55
by glasswing
Joined on Fri, Feb 15 2013, Vancouver Island, Posts 23

Thanks for the encouraging words and really cool info.  Now I understand that Pro Tools, and most DAWS, use only a few cores at a time.  Based on that, I'm not sure about how Pro Tools parses out VI's across cores, so my question is about how VEP uses cores - and whether it's smart to continue using VEP in one fast machine - no slave.  My understanding is that VEP can make good use of the 20 available cores.  Now... maybe I've answered my own question and I WILL go ahead and install it on the Mac Studio Ultra.  

I'm not terribly worried about RAM at this point because I've never had more than 48 GIGs in the past!!!  And I don't use enormous libraries usually.   BBCSO is the biggest I have right now and I only use small sections of that. 
Thanks again

Posted on Mon, Apr 04 2022 21:55
by murphy761
Joined on Fri, May 01 2015, USA, Posts 65

Proceed with caution: The Vienna Assistant installer for (VEP7 Server iLok) does not install VEP7 Server AAX v.7.1.1245 into the Avid Plugins folder, so you'd have to open an instance for every instrument you want to use.

murphy761
Pro Tools 2021.12
VEP 7
UAD Apollo 8
Posted on Tue, Apr 05 2022 05:13
by kurt
Joined on Mon, Jan 15 2007, Belgium, Posts 60

Hi,

I think one benefit of using VEP on your ultra, is that loading time of songs is faster because it's already in memory. 

I'm curious to know how your ultra will perform.  VSL is not M1 native yet, so probably more memory usage than normal (for the intel emulation) and a bit slower in response for now ? 

I also ordered an ultra 128 GB RAM. I will put the VSL libraries on external SSD. 

Posted on Wed, Apr 06 2022 22:55
by glasswing
Joined on Fri, Feb 15 2013, Vancouver Island, Posts 23

So far so good.  Straight, no instrument Pro Tools seems to work quite well.  I've been installing giant spitfire, Ivory, Omnisphere etc (instruments to a 4TB NVMe Raid0 drive) and a ton of plugins today.  Haven't tested most that I've downloaded today - and it's the plugins that drive P Tools crazy. I have only tested a few of the main audio plugins I use.  Rosetta seems to be working.  HDX - the PCIe card and I/Os seem to be working very well. 
As far as VE Pro not installing an AAX server - this is new territory for me.  I've worked with a slave machine for so long and I'm so gun shy about learning anything I don't need to learn (brain overload) that it's going to be all new.  IN the past I hosted Omnisphere, Trillian, Ivory and a few Kontakt instruments in VEPro.  
I should know more over the next few days.  I'll try to do an update on progress soon. 

Posted on Thu, Apr 07 2022 21:26
by glasswing
Joined on Fri, Feb 15 2013, Vancouver Island, Posts 23

Originally Posted by: murphy761 Go to Quoted Post

Proceed with caution: The Vienna Assistant installer for (VEP7 Server iLok) does not install VEP7 Server AAX v.7.1.1245 into the Avid Plugins folder, so you'd have to open an instance for every instrument you want to use.



Just installed VEP7 and it's working just fine with a server!!!  All within the Mac Studio Ultra - and the system is barely lifting a finger!  I downloaded it directly from Vienna and installed from the download thinking the Vienna Assistant might be the culprit.  It recalled sessions from Pro Tools data like no time had passed - and this session is a few months old. Now the server is on the desktop and I don't know what that means.  Is it running via Rosetta or not?  So far Rosetta has been invisible. 
I'm a very happy camper so far.  Most of the weirdness I've encountered hasn't been from any glitch in the works as much as me remembering to set preferences and filter MIDI coming into Pro Tools.  Any program change stuff - which seems to leap out of the Doepfer Mk4 when I change presets - throws Pro Tools into a serious funk.  Quit - Restart etc.  
Now that I've cleared up most of those it's running like a rabbit!

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.