Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Running VI on Vista 64: "no licenses installed"
Last post Fri, Sep 28 2007 by pjak, 3 replies.
Options
Go to last post
Posted on Fri, Sep 28 2007 19:53
by pjak
Joined on Sat, Mar 17 2007, Posts 49

I decided to give Vista 64 Bit a try, as I want to use more RAM. Most programs work without

problem. e.g. Cubase SX 3 just works. However, I am having trouble to get VI working.

Though the Synchrosoft dongle driver seems to be installed properly, I get "No licenses are installed"

with VI. (My licenses are all listed from within the Synchrosoft Control Center). I tried to reinstall

the dongle driver, the VI instrument again and again. Tried to use VI from within Cubase or

stand-alone, tried to run with or without administrator privileges. But VI doesn't show my Special

Edition. The weird thing is, that yesterday at night, after endless reinstall attempt it suddenly worked.

Then I moved on to work on other things. Now I just tried to load project and suddenly the licenses

have disappeared again.

(Yes, I ran the Directory Manager, to tell where the SE files are located)

Does anybody have any idea what could cause this?  Or do I just have to wait for the next VI release?

Thanks in advance,

Peter

Posted on Fri, Sep 28 2007 20:44
by DG
Joined on Wed, May 12 2004, Posts 8608

I think that there are two issues here.


1) VI finds no licences

2) VI finds no content.


2) can be fixed by Directory Manager, but 1) is a Syncrosoft problem. The only time that I've had this was when I was using a version of the Syncrosoft software that was too old for the sample Collection. I would suggest that you first check that the licences are on the dongle (via LLC) and then make sure that you have installed the correct version of the software. I have it all running flawlessly on XP64, so the 64 bit driver is not a problem. With Vista I can't say.....


D

Nuendo 6.03, 4.3
2 x Intel Xeon x5675 3.07GHz Hex Core
48GB RAM
Windows 7 (x64)Pro
RME Multiface II
Intensity
ATI HD5400 series graphics card
Posted on Fri, Sep 28 2007 23:05
by pjak
Joined on Sat, Mar 17 2007, Posts 49

Thanks DG for your help!

The actual problem however was neither the installation of the dongle driver, nor the setup in Directory Manager.

The problem was caused by Vista's firewall:

By default the firewall is only enabled for inbound traffic. I decided to enable the firewall for outbound connections too. It turned out that this even blocks traffic for local loopback, which seems to be used by VI to communicate with the VSL daemon and/or the dongle driver. Once I setup a rule that allows outgoing connections to "127.0.0.1", VI immediately worked as expected.

It is odd that I had to define a rule for outbound traffic, but not for inbound. Local loopback is not only used by VSL - many programs use this to establish communication with other processes.

Watch out, Vista will (optionally) show a notification if an inbound connection requests, but never on outgoing connections!

I need a replacement for Vista's firewall immediately! If I just could find something like the good old Tiny Personal Firewall for Vista 64... 

Peter
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.