Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Vienna instruments, Vienna Ensemble and Snow Leopard
Last post Mon, Oct 11 2010 by Paul, 19 replies.
Options
Go to last post
Posted on Sun, Aug 30 2009 02:41
by ross.harris
Joined on Thu, Sep 13 2007, New Zealand, Posts 18

I suspect I have missed an announcement about the compatibility of VI and VE with Snow Leopard. Could VSL please confirm that there are no problems updating to Snow Leopard?

Many thanks,

Ross Harris

Ross
Tags: Snow Leopard
Posted on Sun, Aug 30 2009 03:20
by mpower88
Joined on Thu, Aug 12 2004, Posts 729

The general rule of thumb is to not upgrade your operating system until it has been tried and tested. This is particularly true of music software, and even more true of software such as VSL whose engineers favour writing for windows ;)

On top of that I think there are some problems with hosts under snow leopard, and drivers for hardware, and plug ins. So DEFINITELY wait until six months from now at least, or until people start to generally agree it's good to go, and even then, check any "must have" plug ins and make sure they are ok with the upgrade. And do a back up before you do so you can reverse it if it doesn't work.

XI Machines 2687W, 64Gb Ram, Win 10
Angelbird SSD's..VEPro 7/MIR, Cubase 11 Pro
Almost the Full Vienna Collection.
SSL 2 Interface. Adam Audio S3A monitors
One half of Seraphonica.
Posted on Sun, Aug 30 2009 04:39
by ross.harris
Joined on Thu, Sep 13 2007, New Zealand, Posts 18

Thanks mpower88,

I was hoping that VSL would make an announcement along the lines that Sibelius have:

"We are pleased to announce the availability of a free update for Sibelius 6 users that provides compatibility with Mac OS X 10.6 Snow Leopard.

Ross Harris 

Ross
Posted on Sun, Aug 30 2009 10:25
by cm
Joined on Fri, Dec 20 2002, vienna, Posts 9120

mpower88 wrote:
even more true of software such as VSL whose engineers favour writing for windows ;)
 

not really the truth - they prefer to write C++ instead of objectiveC so beeing able to provide cross-platform applcications.

 

compatibility: generally yes (there is no big talking about supporting newer versions of operating systems like OS X 10.6 or windows 7), however some new features - like exceeding the 4 GB barrier on OS X with VE PRO - will depend on other prerequisites.

for VE PRO one of them is to run on an intel based macPro and if you want to run it in 64 bit your plug-ins have also to be 64 bit.

christian

and remember: a CRAY is the only computer that runs an endless loop in just four hours ...
Posted on Sun, Aug 30 2009 11:31
by mpower88
Joined on Thu, Aug 12 2004, Posts 729

:christian, I was just having a little jibe there :) just kidding. 

XI Machines 2687W, 64Gb Ram, Win 10
Angelbird SSD's..VEPro 7/MIR, Cubase 11 Pro
Almost the Full Vienna Collection.
SSL 2 Interface. Adam Audio S3A monitors
One half of Seraphonica.
Posted on Sun, Aug 30 2009 17:09
by julian
Joined on Fri, Jan 07 2005, UK, Posts 720
cm wrote:

mpower88 wrote:
even more true of software such as VSL whose engineers favour writing for windows ;)
 

not really the truth - they prefer to write C++ instead of objectiveC so beeing able to provide cross-platform applcications.

compatibility: generally yes (there is no big talking about supporting newer versions of operating systems like OS X 10.6 or windows 7), however some new features - like exceeding the 4 GB barrier on OS X with VE PRO - will depend on other prerequisites.

for VE PRO one of them is to run on an intel based macPro and if you want to run it in 64 bit your plug-ins have also to be 64 bit.

christian

I heard that Snow Leopard defaults to 32 Bit kernel but can be booted 64 bit if the hardware (for example post Jan 2008 MacPro) supports this. I'm not sure if this would have any effect, if any on the performance of true 64 bit apps?

Also, in this case, there is a pressure to move to Snow Leopard if you are having memory issues. I have Logic songs that only just load - in fact in the transition from Logic 8 to 9 some won't load due to the increased RAM requirement of Logic 9 - this is not because of lack of space for Vienna Instruments but because the Logic song takes the Logic RAM allocation to it's limits.

I guess with a release of a 64 bit version of Logic along with the pro version of QuickTime X this limit will disappear. Thus the urgency to make the shift. Also it will be great if VSL have 64 bit versions of Vienna Instruments and Vienna Ensemble in au form.

Julian

Posted on Tue, Sep 01 2009 15:49
by geronimo
Joined on Sun, Jun 21 2009, Posts 4
Hosted by LOGIC 8 OR DP6.02 under Snow Leopard, the Vienna Instruments window does not appear in plug-in while running in Standalone mode !
Posted on Wed, Sep 02 2009 16:03
by quartz3d
Joined on Tue, Feb 26 2008, Posts 22

I've recently upgrade to running Snow Leopard, and the difference in speed is really amazing. I can now load an entire orchestra without having Logic break a sweat. The only thing I've noticed that seems a little weird is that when I close Logic 8 Vienna Special Edition does not quit automatically. Rather, the instances stay loaded, just like they would if the Logic program was still loaded. Other than that, works wonderful.

Posted on Wed, Sep 02 2009 18:06
by cgernaey
Joined on Mon, Apr 04 2005, Detroit-Michigan, Posts 1062

Well for me it's a few things positve and few things negative.  But the positive out ways the negative at the moment.

Negative:

1.  The stand alones do not let me change sample rate.  I get an error message and the engine fails to start.

2.  Vienna Ensemble stand alone doesn't even load up for me, but I get no error message.

Positive:

1.  Within Logic BOTH of the above load up and work properly.

2.  The CPU and memory usage is simply unfricken believable.  I normally can't play 1-2 instruments back without needing to freeze tracks.  I am able to play back my entire 10 piece mini orchestra at the moment, with no tracks frozen, at 50-60% CPU utilization (you can see my specs in my signature).  This is with Channel EQ's on ALL channels, Power Pan plug-in on all channels, compressor on all channels and 2 complete Space Designer Reverb channels going at once.

Also, it's nice to see my project not locking up with spinning balls (yet).  I am running the most current version of both VI and VE.

So far the results are promising.

Maestro2be

Windows 10 Pro 64-bit, 128GB RAM, AMD 3970X 32-core
Gigabyte TRX40 Aorus Xtreme, Radeon RX 5500 XT
Studio One 5.1.1, Cubase 10.5, Nuendo 10
RME Multiface 2, All NVMe SSD Drives (OS & Samples)
Posted on Wed, Sep 02 2009 18:14
by cgernaey
Joined on Mon, Apr 04 2005, Detroit-Michigan, Posts 1062

Also for the record.  The way I am doing it is like this.

1.  Installed Snow Leopard and the updates.  Then run Time Machine to get your backup done.

2.  Imported all my user settings from Leopard using migration assistant.  Tested all apps and OS for stability.  Did another Time Machine Backup.

3.  Installed Logic 8 Studio.  Only the applications, not the extended content.  Tested it all.  Worked perfeftly.  Time Machine Backup.  (I have not done ANY updates to Logic at this point period).

4.  Installed Pianoteq 3.  Tested.  Worked perfectly in stand alone and in Logic 8.  Time machine Backup.

5.  Installed VSL VI and VE3.  Tested.  Stand alones do not work.  AU plug-in versions work excellent inside Logic.  Time machine backup.

Now I am in the middle of my time machine backup from step 5.  After it finishes, I will do all the apple updates (Logic studio update 8.0.2 is really all it offers right now for me).

I will come back and edit the rest of the steps.  So far it's working like a champ but been a bear getting here.  That is why I am posting the exact steps that DO work so you don't waste your time doing it wrong.

*****PART TWO PICKING UP AFTER THE ABOVE STEPS

6.  Right after I loaded all the OS X updates (Logic pro 8.0.2, Soundtrack Pro, Mainstage, Pro kit 1 and 2 and all the others that were on the list) I rebooted.  Brought up Logic and instant lockup and crash with the same project that worked perfectly before updating.  I force quit Logic and opened it again (but another project) and it worked perfectly.  It then let me open the one that had crashed.  Now it seems to open just fine.

7.  I did a repair permissions on the drives and it found one wrong permissions setting.  It had nothing to do with Logic etc but still thought it worth while to run a permissions repair.  So far today it hasn't crashed once and it running incredibly smoothly.  It is balancing the two cores on my MacBook Pro almost completely evenly.

I am going to test for a little while longer and if it locks up and freezes and crashes etc I am going to revert back to my Time Machine backup from Step 5.  Then install each update 1 at a time until I find the problem child (I suspect it's logic update 8.0.2).

*****PART THREE - PICKING UP AFTER STEP 7 - Day 3

8.  Well things are working very well so far.  I have installed all the rest of my applications with the exception of Sibelius 5.  It isn't compatible and they don't know if they will make an update to it so I ordered the version 6 upgrade today.

9.  VE3 over the network is working better then it ever has for me.

I am having few issues though that may appear pretty severe, but I have a work around and it's not preventing me from getting things done.

a.  My Expresscard RME Hammerfall isn't working (I use a dual systems adapter with the older PCMCIA card).  Dual Systems was shocked 10.6 didn't build a driver for it since they built one in 10.5.  So right now my main Audio interface is not working and I am having to work with the built in audio (which is fine for now).  I am getting very good results and low latency.  MY midi devices are now routed through my Axiom 25 instead of the Hammerfall so I haven't lost any real functionality that is show stopping at this point.  It will be nice to have it back at some point though.

b.  I have 3 external drives (2 USB and 1 Firewire) and it seems to always leave one out everytime.  I simply unplug the one that doesn't connect and reconnect it and it works.  But it's slightly annoying.

The speed and stability so far was worth the upgrade.  I can live with the few strange oddities, it's still more stable and faster then it ever has been.  This completes my process for now as I have nothing else to install until Sibelius 6 gets here in 2 weeks or so.  I have no intentions of loading Garritan GPO etc anymore as I never use them and don't need to waste the space and resources anymore.  Now I just sit back and wait for Apple or Dual Systems to write a driver for my adapter.

Time to do my final backup and get back to music making.

Maestro2be

Windows 10 Pro 64-bit, 128GB RAM, AMD 3970X 32-core
Gigabyte TRX40 Aorus Xtreme, Radeon RX 5500 XT
Studio One 5.1.1, Cubase 10.5, Nuendo 10
RME Multiface 2, All NVMe SSD Drives (OS & Samples)
Posted on Thu, Sep 03 2009 06:29
by dbudde
Joined on Sun, Mar 02 2003, Seattle,WA USA, Posts 450
cgernaey wrote:

1.  The stand alones do not let me change sample rate.  I get an error message and the engine fails to start.

If you are still having trouble changing the sample rate, try setting the sample rate and latency on the input first.  I was able to change the sample rate and latency on the output after setting them on the input first.  This is an old old problem, just seems to have taken on a different form.  See here:

http://community.vsl.co.at/forums/p/10285/77031.aspx#77031

Once the sample rate and latency are set, then the standalone seems to work fine.

Posted on Thu, Sep 03 2009 13:37
by cgernaey
Joined on Mon, Apr 04 2005, Detroit-Michigan, Posts 1062
dbudde wrote:
cgernaey wrote:

1.  The stand alones do not let me change sample rate.  I get an error message and the engine fails to start.

If you are still having trouble changing the sample rate, try setting the sample rate and latency on the input first.  I was able to change the sample rate and latency on the output after setting them on the input first.  This is an old old problem, just seems to have taken on a different form.  See here:

http://community.vsl.co.at/forums/p/10285/77031.aspx#77031

Once the sample rate and latency are set, then the standalone seems to work fine.

 

 I'll be damned, that fixed that issue.  That is strange but none the less is working now, both VE3 and VI.  Thanks!

Ok so as stated in my above post yesterday, Logic crashed and burned and froze up on me ONCE after doing all the updates so VSL interface does not play well with Logics updates.  It hasn't happened since but I am almost scared to move ahead with installs knowing that VI and VE crashed after applying Logic updates.  The updates make all the rest of my projects rock solid and fix many necessary bugs in Logic as well.  I am going to try the updated version that Maya sent me and see how it goes for a few days.

So far today it has run smoothly.  Perhaps it will run even better now that VI and VE have actually had their audio configurations set properly.  I will post more this afternoon after more testing.

Maestro2be

Windows 10 Pro 64-bit, 128GB RAM, AMD 3970X 32-core
Gigabyte TRX40 Aorus Xtreme, Radeon RX 5500 XT
Studio One 5.1.1, Cubase 10.5, Nuendo 10
RME Multiface 2, All NVMe SSD Drives (OS & Samples)
Posted on Fri, Sep 04 2009 02:23
by cgernaey
Joined on Mon, Apr 04 2005, Detroit-Michigan, Posts 1062

I edited my previous post a few up and added my last steps.  I am done for now and all the results are posted in that post.

Maestro2be

Windows 10 Pro 64-bit, 128GB RAM, AMD 3970X 32-core
Gigabyte TRX40 Aorus Xtreme, Radeon RX 5500 XT
Studio One 5.1.1, Cubase 10.5, Nuendo 10
RME Multiface 2, All NVMe SSD Drives (OS & Samples)
Posted on Sat, Sep 05 2009 08:46
by geronimo
Joined on Sun, Jun 21 2009, Posts 4
geronimo wrote:
Hosted by LOGIC 8 OR DP6.02 under Snow Leopard, the Vienna Instruments window does not appear in plug-in while running in Standalone mode !


Sorry for my previous statement: Finally, it works _
Posted on Mon, Sep 07 2009 14:06
by cgernaey
Joined on Mon, Apr 04 2005, Detroit-Michigan, Posts 1062

Well just an update that every thing is working great here.  I haven't had one single issue since the one lockup on the first initial load, on the first day.  It has been rock solid and stable and very fast.

Very pleased with this.  I certainly hope VE Pro works as stable with this because I will be one hell of a happy man.

Maestro2be

Windows 10 Pro 64-bit, 128GB RAM, AMD 3970X 32-core
Gigabyte TRX40 Aorus Xtreme, Radeon RX 5500 XT
Studio One 5.1.1, Cubase 10.5, Nuendo 10
RME Multiface 2, All NVMe SSD Drives (OS & Samples)
Posted on Wed, Sep 09 2009 20:22
by jeancello
Joined on Tue, May 13 2008, Québec Canada, Posts 40

Is there anyone using cubase 4 tried to swith to snow leopard?

My system is somewhat stable right now but it seems that there is a speed increase benefit using "snow leopard so I would consider switching.

Thanks!

Jean

Jean Roy
Mac Pro 2013 8 * 3.0 64GB
Special edition + ex, Solo string bundle, Chamber String bundle,
App String 1, Harps, Vienna Imperial, Soprano Choir, Dimension brass, Dimension strings + several download instruments
VE Pro, VI Pro, V Suite, MIR
Kontakt 5 Omnisphere
Cubase 9.5
Synchron String soon..
Posted on Wed, Sep 09 2009 21:38
by DG
Joined on Wed, May 12 2004, Posts 8608

 Perhaps you would like to visit www.cubendo.com where you will find all sorts of benchmarks for Cubase and Nuendo.

DG

Nuendo 6.03, 4.3
2 x Intel Xeon x5675 3.07GHz Hex Core
48GB RAM
Windows 7 (x64)Pro
RME Multiface II
Intensity
ATI HD5400 series graphics card
Posted on Mon, Oct 11 2010 19:59
by guavaberry
Joined on Thu, Apr 20 2006, Posts 3
I can't find the pathway on the VSL site (or anywhere else) to upgrade my Ensemble and VSL plugins for Snow Leopard. Can you direct me?
Thanks!
Posted on Mon, Oct 11 2010 22:37
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12987

Hi,

User Area => Software!

Best,

Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.