Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
VE Pro 5 idling at 80% CPU load
Last post Thu, Feb 02 2012 by Crescendo, 11 replies.
Options
Go to last post
Posted on Mon, Jan 30 2012 23:44
by Crescendo
Joined on Wed, Jul 16 2008, Posts 36

I am currently trying out VE Pro 5 - attempting to take advantage of the environment layer that allows multiple ports.

I have one large VE Pro instance with 16 instances of Kontakt. It is - when not connected - idling around 5% but as soon as I connect it to Logic it jumps to 80% (with no further action, no playing or editing in Logic). Can someone please explain to me why this occurs and how I could possibly lower the CPU usage? Obviously something is not quite right. The total memory usage for VE Pro is 10.2 GB on a 18GB system. I still have plenty of headroom.

VE Pro is currently set to 1 processor per instance - if I choose 2 or more the CPU percentage goes even further up dramatically. Kontakt is set to multiprocessing.

____________________________________________________________
Mac Pro 3.1 8 core, Mac OS 10.6.8, Logic 9.1.6, 18GB RAM, all is 64 bit.

Posted on Tue, Jan 31 2012 00:06
by Cyril Blanc
Joined on Thu, Dec 19 2002, Paris France, Posts 2629

What are your audio setting in Logic ?

What audio card ?

MacPro 2010 12 core 2.93 ghz 64 GB Mac OS X 10.11 2722 Rocket Raid Sata III card with 8 x ssd
VSL lib on a Raid 0 of 4 x 256 GB ssd Sata III - Raid 0 of 4 x 64 GB for other libs
System on a 1 TB ssd
Audio Motu PCI system 84 ins / 64 outs
Kbd : P80 Yamaha, S88 and S25 Komplete Kontrol, DX7
I-Controls Pro, 2xMidi expression pedals
Synth : many....
---
Macbook pro Retina 2.7 ghz 16 GB
---
Mac Mini server 10.10 (server EyeTV, Itunes, WEB, and Backup )
--
Logic X , Dorico, Band In A Box, ORB Composer
VSL : MIR PRO, Appassionata Strings I, Solo strings , Wind and Brass Complete, Dimension Brass, Overdrive
Kontakt, Omnisphere, QLSO, QLSC, CS 80, Arturia V5, Maximo, Realivox Blue. CS 80 V3, The Orchestra, Art Conductor 5, Genesis Children Choir, Lunaris, Lacrimosa

Final Cut pro
Camera full HD
Posted on Tue, Jan 31 2012 00:35
by Crescendo
Joined on Wed, Jul 16 2008, Posts 36

Sound card: MOTU Ultralite
I/O Buffer: 256
Process Buffer: medium
Processing Threads: Automatic

Any more things that you think would be relevant?

BTW. When I click to go into the preferences dialog on VE Pro the CPU usage drops to 30%. As soon as I leave the preferences window, the CPU usage goes back up.

Posted on Tue, Jan 31 2012 01:11
by Cyril Blanc
Joined on Thu, Dec 19 2002, Paris France, Posts 2629

Try this :

I/O Buffer: 1024
Process Buffer: large
Processing Threads: to Maximum (8???)

also :

What is the value of "buffers" in VE

MacPro 2010 12 core 2.93 ghz 64 GB Mac OS X 10.11 2722 Rocket Raid Sata III card with 8 x ssd
VSL lib on a Raid 0 of 4 x 256 GB ssd Sata III - Raid 0 of 4 x 64 GB for other libs
System on a 1 TB ssd
Audio Motu PCI system 84 ins / 64 outs
Kbd : P80 Yamaha, S88 and S25 Komplete Kontrol, DX7
I-Controls Pro, 2xMidi expression pedals
Synth : many....
---
Macbook pro Retina 2.7 ghz 16 GB
---
Mac Mini server 10.10 (server EyeTV, Itunes, WEB, and Backup )
--
Logic X , Dorico, Band In A Box, ORB Composer
VSL : MIR PRO, Appassionata Strings I, Solo strings , Wind and Brass Complete, Dimension Brass, Overdrive
Kontakt, Omnisphere, QLSO, QLSC, CS 80, Arturia V5, Maximo, Realivox Blue. CS 80 V3, The Orchestra, Art Conductor 5, Genesis Children Choir, Lunaris, Lacrimosa

Final Cut pro
Camera full HD
Posted on Tue, Jan 31 2012 04:02
by Crescendo
Joined on Wed, Jul 16 2008, Posts 36

Unfortunately there is no change if I set it to the above numbers. except that the CPU usage increases dramatically when setting the processing threads from 1 to 8.

Regardless of these settings, when idling, shouldn't VE-Pro not be around a very low number, like 2-3%? I mean what on earth would have to be processed there?

Posted on Tue, Jan 31 2012 06:40
by Cyril Blanc
Joined on Thu, Dec 19 2002, Paris France, Posts 2629

Do you have a VE that contains only VI ?

Does it behave the same ?

MacPro 2010 12 core 2.93 ghz 64 GB Mac OS X 10.11 2722 Rocket Raid Sata III card with 8 x ssd
VSL lib on a Raid 0 of 4 x 256 GB ssd Sata III - Raid 0 of 4 x 64 GB for other libs
System on a 1 TB ssd
Audio Motu PCI system 84 ins / 64 outs
Kbd : P80 Yamaha, S88 and S25 Komplete Kontrol, DX7
I-Controls Pro, 2xMidi expression pedals
Synth : many....
---
Macbook pro Retina 2.7 ghz 16 GB
---
Mac Mini server 10.10 (server EyeTV, Itunes, WEB, and Backup )
--
Logic X , Dorico, Band In A Box, ORB Composer
VSL : MIR PRO, Appassionata Strings I, Solo strings , Wind and Brass Complete, Dimension Brass, Overdrive
Kontakt, Omnisphere, QLSO, QLSC, CS 80, Arturia V5, Maximo, Realivox Blue. CS 80 V3, The Orchestra, Art Conductor 5, Genesis Children Choir, Lunaris, Lacrimosa

Final Cut pro
Camera full HD
Posted on Tue, Jan 31 2012 09:05
by flashman
Joined on Sun, Mar 20 2005, Posts 140

I think the MIDI part of the VSL5 is quite expensive in terms of CPU. I was struggling with DP on the Mac side  (using PC slaves with as Macpro DAW) with very high CPU load and eventually swapped to external MIDI with VSL server using Midi over Lan and it reduced the CPU load by a lot. 

Posted on Tue, Jan 31 2012 15:24
by Crescendo
Joined on Wed, Jul 16 2008, Posts 36
Cyril wrote:

Do you have a VE that contains only VI ?

Does it behave the same ?

Not in this template - only Kontakt instances.

Posted on Tue, Jan 31 2012 15:36
by Crescendo
Joined on Wed, Jul 16 2008, Posts 36
flashman wrote:

I think the MIDI part of the VSL5 is quite expensive in terms of CPU. I was struggling with DP on the Mac side  (using PC slaves with as Macpro DAW) with very high CPU load and eventually swapped to external MIDI with VSL server using Midi over Lan and it reduced the CPU load by a lot. 

What I am doing is all on the main computer. No slaves in this setup.

Still, when there is absolutely no action, when it is all idle, it should not consume a lot of CPU - I think at this point it would be nice if one of the VSL developers would chime in in with some clarifying words and perhaps some advice what to do on the user side.

BTW, my VE Pro instances (I have 2 - one monster instance with 16 ports, one extra for one single PLAY instance (loaded with 2 instruments - I thought it would be wise to keep PLAY separate?) are decoupled, using two buffers (increasing/decreasing the buffers do not change the scenario).
It certainly is not about the size of the template, i have been using similarly large (and bigger) templates before in different setups.

If I can't get this worked out so I can use multiple ports without the high CPU usage, I will have decide against VE Pro 5 and go with version 4 and set it up in the "old" ways. Sure would be nice with multiple ports and v5...

Posted on Wed, Feb 01 2012 03:41
by delaplanemusic
Joined on Tue, Jan 25 2011, Posts 26
I have yet to try out VEP5, so take this for what it's worth. I am running the previous version on my sequencer (Cubase - 8 core mac pro, 16 gigs, OS10.6.8) and I was having a similar problem. My CPU was around 60% and my sequencer would misbehave as a result. I know you said you changed the buffer settings, but are you referring to the buffer settings on your slave machine? Make sure your buffer setting on your host (your plug-ins) is set to 2 as opposed to one. Also, if you have instances that consist entirely of Kontakt instruments, set the VEP multiprocessing to the MINIMUM, and activate the Kontakt multiprocessing instead. I recently did this and noticed a huuuuuge improvement in CPU usage.
If you are on a mac, find your activity monitor in Applications -> Utilities -> Activity Monitor. When you open it, there are several tabs at the bottom of the window (DO NOT START quitting processes, btw. Just observe with this app. Trust me.) select the CPU tab, and double click on the CPU Usage window. this should open a CPU History window where you can view your computer's CPU usage. (Christ, I hope you are on a mac) Open your template and let it idle for about 10 minutes. Take a screen grab. Then go into your VEP prefs and set multiprocessor to 1 thread. Also check your "Instances" prefs. Only allow as many midi channels and audio channels per instance that you will actually use. Adding 32 audio ports per instance when you only need 8 or 16 will increase your CPU load as well.
Open Kontakt in stand alone mode and in options -> Engine ...set the multiprocessing to the maximum. Quit Kontakt. Then open your VEP template again, and the changes should apply within your VEP Kontakts automatically. Wait another 10 minutes and take another screengrab of your CPU history and compare them. You should find that your CPU improves drastically when using Kontakt's multiprocessing as opposed to (ahem...) VEP's. If you notice over the course of this process that you had both VEP and Kontakt's multiprocessing activated...that could be your problem. You have to activate one or the other. If both are activated they start fighting each other for system resources and things get a little funky. Hope this helps. Please post your findings...I would like to know how this goes before I upgrade ;)

N
Posted on Thu, Feb 02 2012 17:47
by Crescendo
Joined on Wed, Jul 16 2008, Posts 36
delaplanemusic wrote:
I know you said you changed the buffer settings, but are you referring to the buffer settings on your slave machine?

As stated above, in this particular setup I am not using any slave machines (though sometimes I do).

delaplanemusic wrote:
Make sure your buffer setting on your host (your plug-ins) is set to 2 as opposed to one. Also, if you have instances that consist entirely of Kontakt instruments, set the VEP multiprocessing to the MINIMUM, and activate the Kontakt multiprocessing instead. I recently did this and noticed a huuuuuge improvement in CPU usage.
If you are on a mac, find your activity monitor in Applications -> Utilities -> Activity Monitor. When you open it, there are several tabs at the bottom of the window (DO NOT START quitting processes, btw. Just observe with this app. Trust me.) select the CPU tab, and double click on the CPU Usage window. this should open a CPU History window where you can view your computer's CPU usage. (Christ, I hope you are on a mac) Open your template and let it idle for about 10 minutes. Take a screen grab. Then go into your VEP prefs and set multiprocessor to 1 thread. Also check your "Instances" prefs. Only allow as many midi channels and audio channels per instance that you will actually use. Adding 32 audio ports per instance when you only need 8 or 16 will increase your CPU load as well.
Open Kontakt in stand alone mode and in options -> Engine ...set the multiprocessing to the maximum. Quit Kontakt. Then open your VEP template again, and the changes should apply within your VEP Kontakts automatically. Wait another 10 minutes and take another screengrab of your CPU history and compare them. You should find that your CPU improves drastically when using Kontakt's multiprocessing as opposed to (ahem...) VEP's. If you notice over the course of this process that you had both VEP and Kontakt's multiprocessing activated...that could be your problem. You have to activate one or the other. If both are activated they start fighting each other for system resources and things get a little funky. Hope this helps. Please post your findings...I would like to know how this goes before I upgrade ;) N

(Yes I am on a Mac (8 core)) I am already running VE-Pro with one thread - adding more results only in higher CPU usage - I think I stated this already above.

What I am finding now is that when I use only one VE-Pro instance, I can get the CPU down to about 30%. As soon as I add another instance (Even if this instance is loaded with only one Kontakt instance and one single instrument) it jumps to about 50%. A third instance will add again about 20% more.

Still, why would any software that is idling ever use 80% of the CPU power, regardless the configuration? That is my question here.

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.