Welcome Guest! To enable all features please Login or Register.



Forum Jump  
Audio Glitch & Drop Out on Tempo Changes
Last post Wed, Sep 01 2021 by dterry, 12 replies.
Go to last post
Posted on Mon, Feb 09 2015 05:02
by kriepl
Joined on Sat, Jun 17 2006, Posts 9

I found a thread that was from a little while back but nothing seemed to be addressed or a solution found. 
So I will post my request here to see if someone can shed some light on this issue.

Here is my situation and set up. I am running DP8 and VEPro5 on the same Mac system. I also have a VEPro server running on a satellite PC.

No matter how many instruments or kinds of instruments in kontakt5 I have playing at the time of  tempo change in DP, the audio pops, glitches, & drops out for a brief second.
For example in this one instance, I have VEPro loaded up with 15 instances housing KONTAKT5 with a total of about 26G of samples loaded in RAM, in which i have 64G of.
The only instruments/samples that are being played are a piano patch and a pad. As it plays back over a tempo change the glitch happens. 
I've tested bringing in the SAME Kontakt multi into a kontakt housed in DP and the glitch does not happen.
Mind you, the glitch also happens on all my orchestral samples on the satellite PC as well. 

seems the more I have loaded into VEPro the more severe the problem is.

by removing 1 instance in VEPro the problem seems to lessen, by removing 2 instances in VEPro the problem only happens every once and a while, but i can't be sure this has anything to do with it, as it still occurs when ever the hell it wants to.

Tried trashing preferences, didn't cure it.

ANY HELP on this is greatly appreciated.
Scoring films and tv it is nearly impossible to avoid using tempo changes. 
Knowing this is happening to other users especially using a DAW other than DP, goes to show that it is in fact VEPro's issue and NEEDS to be fixed. ASAP!

Many thanks in advance for any help that can be shared. 


Kevin Riepl Music, Inc.
OSX 10.8.5 | 2x2.66GHz Quad-Core | 64GB RAM
DP8 | VEPro5 | KONTAKT5 (all latest updates)
Posted on Mon, Feb 09 2015 09:05
by DG
Joined on Wed, May 12 2004, Posts 8608

My understanding is that it's a Kontakt problem, and until NI changes things, there is no permanent fix. However there are things that can be done to make it better:

  1. Turn off tempo sync in Kontakt, unless you absolutely need to have it on (tempo synced patches, for example)
  2. Don't use tempo ramps. Use jumps instead

FWIW I believe that the glitch doesn't happen on mixdown/bounce (whatever it is called in DP), only on playback so it should be possible to work. It's just inconvenient.

I would recommend getting on to NI about this issue, because it affects lots of people in multiple DAWs. You can check whether or not it is a Kontakt issue by loading your VEP instances with something other than Kontakt and seeing if it still happens.


Nuendo 6.03, 4.3
2 x Intel Xeon x5675 3.07GHz Hex Core
Windows 7 (x64)Pro
RME Multiface II
ATI HD5400 series graphics card
Posted on Mon, Feb 09 2015 15:42
by kriepl
Joined on Sat, Jun 17 2006, Posts 9

Hey DG, Thanks for the response.  I assumed it wasn't Kontakt causing it because the glitch wouldn't happen when any Kontakt instance was loaded straight into DP.  I haven't tried testing the glitch out on anything other than NI instruments. (I do believe it happens to Massive & Zebra too) I'll have to double check that. 

re: Tempo Sync, yeah I need this on and I do use a quick tempo change, no ramps

The glitch actually does not happen when I 'freeze' the tracks to audio. That is currently my only possible work around. Inconvenient with how I create stems but for the time it it works. 

I'll go bark up NI's tree about this and also see if others have reported on this issue there. 

But i am still open for any input here if anyone wants to share.

Thanks again,


Kevin Riepl Music, Inc.
OSX 10.8.5 | 2x2.66GHz Quad-Core | 64GB RAM
DP8 | VEPro5 | KONTAKT5 (all latest updates)
Posted on Tue, Feb 10 2015 21:37
by civilization 3
Joined on Sat, May 16 2009, SF Bay Area, Posts 1957

Per the other thread, I was able to reproduce the particular issue of Scarbee Clavinet, sync to host activated, a delay activated, with  tempo change from Cubase. It created a real show-stopper here, either ramp or jump. It wasn't limited to audio dropouts, I actually had to force-quit everything it was such a strain.

But I use what I would suppose is an extreme amount of tempo change - albeit with sync rarely - and I never had this issue until I replicated that one. At the time I participated in that thread my project relied on a [Kontakt] sync to host patch from Soundiron 'Angklung' with rolls and timing things in its sequencer w. no issues at all.

So like a lot of things, the issue probably is at an intersection of patch, plugin, host and VE Pro and even OS rather, it seems to me. I only ever heard of it vis a vis Kontakt, though.

Apple M1 - Mac OS 14
Posted on Sun, Oct 27 2019 20:55
by synthetic
Joined on Mon, Mar 14 2005, Posts 281

Bumping this old thread. I still get glitches in VE Pro 6.0.17966. It happens with Kontakt and Spitfire BBC. It's especially noticable when you ramp the tempo change, like from 70 to 50 in two bars. I'm using Cubase 10 for Mac as my DAW, VE Pro Server on Windows 10. Has anyone ever found a fix for this? Disabling tempo in Kontakt helps a bit, but this isn't possible in the Spitfire player. 

Posted on Mon, Oct 28 2019 07:51
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 13900


I'd avoid ramps with Cubase (and some other sequencers) in general, it will lead to troubles with most plug-ins. If possible. Steps will work much better. 


Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Wed, Oct 30 2019 03:10
by synthetic
Joined on Mon, Mar 14 2005, Posts 281
“Doctor, it hurts when I do this...” “Don’t do that.”

No problems when the plug-in is hosted in the DAW, only through VE Pro.
Posted on Wed, Oct 30 2019 08:20
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 13900

Hi synthetic,

Originally Posted by: synthetic Go to Quoted Post
“Doctor, it hurts when I do this...” “Don’t do that.”

No problems when the plug-in is hosted in the DAW, only through VE Pro.


Communication through a network socket is different from hosting a plug-in directly. 

With a few things we have to agree with the famous doctor's advice. 


Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Thu, Nov 07 2019 14:59
by NRK
Joined on Tue, Apr 08 2014, Posts 9

I find raising the buffer in my DAW (DP) helps playback with those kind of glitches.

I have had in the past to print a mix up to the tempo change, and then the mix after, and then joining the two.

A "PIA", but hey, whatever works.

Sometimes it's plugins, not VE Pro, that are the problem.

And stuff like Omnisphere, if there is tempo-sync stuff, will glitch.

I still think that the problem is in the DAW, not Vienna Pro.

Posted on Thu, Jul 01 2021 23:37
by edshearmur_22031
Joined on Mon, Jun 26 2006, Los Angeles, Posts 6

Can't believe this is still an issue. Have the same problem here. Glitches on tempo ramps in Cubase. In my case, it's coming from a single instance of VEPRO, my strings instance. I have a mix of Kontakt and Spitfire libraries. The glitches come from both sources, so I'm inclined to think this is a Vienna issue. I'm used to plug ins that are time-based, like delays etc to exhibit these issues, but that's not the case here. Frankly, advising a composer to not use gradations in tempo is absurd. One might as well say "don't write any music and the problem will disappear."

Please can this be sorted out? 

Posted on Mon, Aug 23 2021 03:58
by magelic
Joined on Fri, Feb 15 2019, Posts 6

I've had this problem since day 1 on my VEP server. I've figured out some unorthodox workarounds, but they take time. In Omnisphere we have a similar problem, however it affects only parameters like delays, since changing the tempo modifies those delay times. But in the case of VEP this happens on any instrument, as dry as can be.

Posted on Wed, Sep 01 2021 15:31
by dterry
Joined on Thu, Jan 30 2003, Posts 72

I ran into this years ago with Kontakt, but finding it a significant problem with VSL Elite and Synchron Strings in Synchron player.  I assume this is baked into the player's time-stretching. In the past, turning of tempo sync in Kontakt was the workaround, but I can't find a way to do this in Synchron.  The only tempo sync option I can find (Edit - Stretch) is already off.  I have customized all of my Elite Strings and Synchron Strings presets with the included reverb off, so that isn't the culprit. It is the dry samples distorting. 

Nuendo 11 - ramped tempo changes cause distorted playback.  Stepped is fine, but a very cumbersome, and inadequate workaround.

Studio One 5 - bezier curve tempo changes are fine, though probably sending stepped changes while using a curve-based graphical representation - still light years better than Nuendo. 

Digital Performer 10 - uses stepped tempo changes when drawing curves, so no distortion problems Synchron instruments. 

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.