Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
VEP6 and Kontakt Loading Hang Problem
Last post Fri, Sep 22 2017 by amadeus1, 14 replies.
Options
Go to last post
Posted on Tue, Aug 29 2017 17:51
by amadeus1
Joined on Tue, Jun 19 2012, Posts 31

Hello all,

 

I'm trying to build a template consisting of woodwinds, strings, brass, and percussion.

I am loading multi patches. VEP6 works with 2 instances of 6 patches. When I create a 3rd instance for strings, loading hangs after adding a couple more of kontakt multis. Been a problem for several days. Any suggestions. Can't proceed with my template otherwise.

 

Thanks,

 

Bill  

Using a 12 core mac pro with 64 gigs and Sierra OS

Posted on Tue, Aug 29 2017 21:01
by amadeus1
Joined on Tue, Jun 19 2012, Posts 31

I've given up on VEP6 for now and will see if VEP5 will work.

Maybe a solution will emerge in the mean time.

 

Bill

Posted on Tue, Aug 29 2017 23:12
by amadeus1
Joined on Tue, Jun 19 2012, Posts 31

Don't seem to have the hang problem in VEP5.  It seems VEP6 has a bug that causes Kontakt multis to hang.

VEP5 is slower and causes more more cpu strain though. Hopefully the Vep6 problem will be resolved.

All this testing is exhausting.

 

Bill

Posted on Wed, Aug 30 2017 05:06
by amadeus1
Joined on Tue, Jun 19 2012, Posts 31

Will stick with Vep6, Vep5 is too slow comparitively. Will work with the community to resolve the problem with Vep6. There must be people who have large templates with Vep6 and don't have the hanging issue.

Posted on Wed, Aug 30 2017 07:29
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12661

Hi amadeus1, 

Sorry to hear about these troubles.

I assume that you are using the latest VE PRO version, is that correct?

Which multis are causing the hang (which product)? 

Also, go to Options/Memory, turn OFF the "Use Memory Server" option under the "KMS - KONTAKT Memory Server" tab, then turn ON the "Override Instrument's Preload Size" under the "Instrument Preload buffer size" tab.

Multithreading should also be turned off in Kontakt (VE PRO takes care of that). 

Best, 
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Wed, Aug 30 2017 09:48
by amadeus1
Joined on Tue, Jun 19 2012, Posts 31

Hi Paul,

Yes, I have the latest version of Vep6. Are there any optons under Load/Import that I should have checked?

I turned off most of the Load/Import options except, "Load samples in background" and "Map bult-converted single samples".

I did have the "Use Memory Server" checked. I have now unchecked that. I also have now checked the "Override Instrument's preload size".

The hang happened for different samples randomly. It had more to do with reaching over 10  to 20 plugin channels.

I'm implementing those changes that you suggested.

Thank you so much and waiting to hear about recommended Load/Import options suggestions.

Bill

Posted on Wed, Aug 30 2017 10:50
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12661

Hi Bill, 

Some library developers (like, e.g., Orchestral Tools) are very demanding regarding thread processing, and there is a hard limit of 2048 threads in OS X that can cause any application to free when it is reached.

So before going too big, keep that in mind!

EDIT: No thread limit in windows, BTW. So a Windows-based computer might be a great addition for the fans of HUGE templates. 

Best,
Paul 

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Wed, Aug 30 2017 11:05
by amadeus1
Joined on Tue, Jun 19 2012, Posts 31

Hi Paul,

Good to know about the thread count limit in Mac OS. With your suggestions the template seems to be working, no more hangs so far. I do have some Orchestral Tools Libraries as well as many others. I have almost all of the VSL libraries, they're so crisp and clear :)  Is there any way to find out what the thread count is? Also, are there any options in the Load/Import option in Kontakt that should be checked to avoid problems?

Thanks,

Bill

Posted on Wed, Aug 30 2017 11:59
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12661

Hi Bill, 

No options in Load/Import for Kontakt that I know of...

You can check the thread count for each application in the Activity Monitor. 

Best, 
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Wed, Aug 30 2017 12:52
by amadeus1
Joined on Tue, Jun 19 2012, Posts 31

HI Paul,

Vep6 is working with a large template on one computer. Will use slaves next to continue the template. Template is approaching Ram limits so everything is working. Total thread count is 2294 and  system seems stable. Other applications are running also. I'll try and keep the thread below 2048 if anything freezes.

Thanks so much,

Bill

Posted on Tue, Sep 05 2017 12:49
by brett
Joined on Fri, Aug 19 2005, Australia, Posts 87
Try reordering the instances, moving the problematic 3rd instance to the first slot then save. Quit, then reload and see how you go

Otherwise try batch re saving all the patches loaded in the problematic 3rd instance then remove and then reload each patch within Kontakt so every patch is now the freshly resaved patch matching the version of Kontakt you're currently using (feel free to backup your original patches for safety of course)

Both these suggestions have worked for me when faced with the issue you've encountered

Posted on Tue, Sep 05 2017 14:00
by amadeus1
Joined on Tue, Jun 19 2012, Posts 31

Thanks Brett. I did batch resave libraries in question. Solution was Presented by Paul above. It's worked consistently ever since. The Kontakt server seemed to be the problem that was causing the hang.

Here's the essense:

Also, go to Options/Memory, turn OFF the "Use Memory Server" option under the "KMS - KONTAKT Memory Server" tab, then turn ON the "Override Instrument's Preload Size" under the "Instrument Preload buffer size" tab.

Multithreading should also be turned off in Kontakt (VE PRO takes care of that). 

Best,

Bill

Posted on Thu, Sep 21 2017 20:37
by RJH_MUSIC
Joined on Mon, Sep 20 2010, Posts 9

Can anyone tell me the corect process to undertake remiving VEP Pro 6 and re-installing VEP Pro 5? I have had it with VEP Pro 6 and don not have the time to troubelshoot it anymore.

 

ThankS

 

RJ

RJH
Posted on Fri, Sep 22 2017 03:49
by amadeus1
Joined on Tue, Jun 19 2012, Posts 31

Hi RJ,

 

If you're having the problem that Kontakt instruments are partially loading, check out the previous thread for the solution.

I just about gave up on VEP6 as well a couple of weeks ago.

 

Best,

 

Bill

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.