Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
CFX for live use...optimization!?
Last post Mon, Jul 02 2018 by johnstaf, 9 replies.
Options
Go to last post
Posted on Sun, Jul 01 2018 13:04
by theohjorth
Joined on Thu, May 03 2018, Posts 20

Hi, 

Im using the Yamaha CFX for live concerts, and have made a sound using Close 1, Close 2 and the Sorround microphone. Im using Ableton Live Lite as a host, and have set the buffer for 256.

I have the latest Macbook pro 15" with touchbar, 2.9GHz core i7, 16GB RAM, 512GB SSD, and while playing I have an user-account on my mac with only Ableton Live opened so it can use all its power for the piano samples. 
I use an apollo twin sound interface for the outputs.

The last two nights I was gigging with my latin band, and the first night there was some serious dropouts in some of my solos when I was playing the most. So for the 2nd set I put the buffer for 512 and that helped but made a tiny bit of latency that made it annoying to play with.

Before the second gig I looked at the problem and found that it helped to turn down the "Max Voices / Mic", so I turned it down from 128 (defaullt) to 52. And tested it at home and I was able to hold down the pedal and slide my hands up and down with no problems.. But in the nighs gig it, once agin, dropped out, so I disabled the Sorround mic to play the rest without dropouts - but with a less enjoyable sound.

 

Do you have any suggestions for me to lower the cpu-load and keep from having the glitches and dropouts? Or should I sell my Kawai VPC1 and buy a stagepiano with built-in sounds again?

 

Thanks in advance, :-)
Theo

Salsa- and jazzpianist. Kawai VPC1
Posted on Sun, Jul 01 2018 16:04
by johnstaf
Joined on Thu, Apr 21 2011, EI, Posts 216

Is it possible you have a streaming issue? Perhaps you could try increasing the preload size of samples in RAM. Are you using an external USB3/Thunderbolt drive? 

I have no problem running Close1 and an abient mic on a five year old Samsung laptop with with a twin core i5 processor, but I can't get the latency as low as I'd like on more than one mic pair. 

Perhaps you could try a different DAW, such as Reaper (which is free to try) to make sure the problem isn't related to Ableton.

Cubase (OS agnostic). Various VSL bits and pieces.

Posted on Sun, Jul 01 2018 17:22
by theohjorth
Joined on Thu, May 03 2018, Posts 20

Ah maybe that could be an option. 

My "Default Preload size" was set to 4096, should I just max it out? Im having the files locally on my SSD drive.
What about "Streming Threads" and "Loading Threads", they are both at 4. Would I gain something by raising those too? :-)

 

Thanks for your answer!

Salsa- and jazzpianist. Kawai VPC1
Posted on Sun, Jul 01 2018 17:59
by johnstaf
Joined on Thu, Apr 21 2011, EI, Posts 216

I'd go higher than that. Try doubling it. You could max it out, but it will take quite a while to load. Streaming from the system disc isn't considered a great idea, but that's much less of an issue with an SSD. Go up in the thread count too, as it can improve streaming performance.

Cubase (OS agnostic). Various VSL bits and pieces.

Posted on Sun, Jul 01 2018 18:11
by bbelius
Joined on Sat, Mar 14 2015, Posts 883

Hi Theo,

I also experienced a lot of drop-outs in real-time performance and figured following out:

- If you have enough RAM, try to set the preload size to the max.

- The value of the Streaming Threads should be equal or less to your CPU core count, not counting the Hyper-Threading "Cores".

- With very low buffer sizes in my interface the SSDs are capable to handle the amount of requested Data, but the ssd-latency is still to high when reading a lot of small chunks of data. A possible fix for that could be the use of a NVMe SSD like the Samsung 970 EVO.
 It will also help to increase the interface buffer size as high as possible without noticing the audio-latency.

- Try to use as few Mic-Positions as possible but still achieve the sound you want (Don't just mute them, deactivate them in the Mix view).

- Disable the algorithmic reverb (also in the Mix view). It takes a fair amount of your CPU.
 I noticed that it uses nearly constant CPU time, but just enough that short CPU-utilization spikes couldn't be processed in time.
 If you need additional reverb, try using hardware reverb.

Additional points to troubleshoot:

- The "CPU Real-Time Display" (see manual page 14 label 5) is a good starting point to see how your CPU is handling the calculations. If the graph is very high you should consider upgrading your CPU. If there is a small spike whenever a dropout accurs, it could be the ssd-latency.

- Also check the Task-Manager. Maybe there are running processes in the background you don't need. If you don't need internet during performance, disable all anti-virus software just for the performance. Disable everything else like OneDrive / Dropbox eg synchronization, Messenger-software...

- Set the priority of the process hosting the VST to high to give it more CPU time

I hope this will help you.

Best, Ben

Ben
Vienna Symphonic Library
Posted on Sun, Jul 01 2018 20:16
by stephen limbaugh
Joined on Tue, Feb 23 2016, Los Angeles, Posts 278

bbelius,

On your machine, does the in-player CPU meter differ from the performance tab in your Task Manager?  My differs by 20%+.  Why is that?

2019 MacBook Pro, 8 core i9, 32gb RAM. Heavy Digital Audio PC slave, 6 core Xeon E5-1650, 128gb RAM. Logic 10.6.3. Big Sur & Windows 10.
Posted on Sun, Jul 01 2018 22:55
by bbelius
Joined on Sat, Mar 14 2015, Posts 883

Hi Stephen,

yes it differs. This is for two reasons:
The resolution of the CPU utilization readings in Synchron Player is finer and therefor shows small spikes I can't see in the Taskmanager (I did not try to change the resolution there, maybe this will help to show them).
And if I am not wrong the CPU meter in Synchron player only shows the CPU utilization by the Synchron player. Therefor your overall CPU utilization is higher then shown in the SP CPU meter (just my guess).

Best, Ben

Ben
Vienna Symphonic Library
Posted on Sun, Jul 01 2018 23:37
by stephen limbaugh
Joined on Tue, Feb 23 2016, Los Angeles, Posts 278

Actually for me, the CPU meter in the Synchron Player is 20%+ higher (peaks and blue CPU reading) than my task manager.  When I'm playing Rachmaninoff and have a bunch of mics on, my task manager will say around 30-40%, whereas the Synchron Player meter will be capped out at 90-100%.

2019 MacBook Pro, 8 core i9, 32gb RAM. Heavy Digital Audio PC slave, 6 core Xeon E5-1650, 128gb RAM. Logic 10.6.3. Big Sur & Windows 10.
Posted on Mon, Jul 02 2018 23:07
by johnstaf
Joined on Thu, Apr 21 2011, EI, Posts 216

I got a new Dell XPS 15 today. I've been putting the CFX through its paces (using my old Apogee Mini-Me). This is an upgrade from my old Samsung i5. 

Anyway, I think glitches are probably more to do with disk latency than bandwidth. With four pairs plus the centre tree mic, the throughput is actually very small. I'm using the 8k sample preload. I use a 2014 Samsung SSD in a Startech enclusure through usb 3.0.

I do get spikes that correspond to small spikes in the system CPU meter. This is probably power management or something that can be turned off.

Cubase (OS agnostic). Various VSL bits and pieces.

You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.