Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Plugin Delay Compensation (PDC) in VEP?
Last post Fri, May 10 2019 by Dewdman42, 6 replies.
Options
Go to last post
Posted on Sun, May 05 2019 23:24
by Dewdman42
Joined on Tue, Feb 27 2018, Posts 294

I have a question about Plugin Delay Compensation in VEP.  Is it doing it?  I realize the VEP plugin is reporting back to the DAW some amount of latency so that the DAW can compensate for the time it takes to communicate with VEP server back and forth.  That's all fine, but what about inside VEP if there are some channels with latent plugins that are producing more latency then others?  I see an option in preferences to enable PDC, so I have it enabled, but in a few short tests I'm doing, it doesn't appear to be handling it...

I would expect, that if the round trip communication and everything normal to VEP is taking, let's say for example 1000 samples.  Then VEP plugin reports 1000 seconds back to the host.  SO the host knows to use its own PDC to make sure VEP channels play in sync with other channels in the DAW.  That part is fine.  But if I put a latent plugin inside VEP channel that is reporting 100 samples..  Then I would expect that VEP would delay all the other channels to match the latency of that one channel and report back to the DAW 1100 as the latency.  Or something along those lines...

But I'm not getting that behavior.  In fact VEP does not appear to be taking any of the plugin latency into consideration at all..

Am I missing a step, or is VEP missing a feature?

5,1 MacPro 12core X 3.33ghz, 128gb ram, RX580 video, OSX Mojave, VSL (almost everything), LogicPro, Cubase10, StudioOne, DP9, Reaper, Dorico, Finale, MuseScore, Notion6, EW Hollywood Orch, Kirk Hunter, GPO, much more..
Posted on Mon, May 06 2019 15:17
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 11034

Hi, 

Plug-in delay compensation is integrated in VE Pro. 

Best,
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Mon, May 06 2019 16:42
by Dewdman42
Joined on Tue, Feb 27 2018, Posts 294
Any idea why or when it might not be working?
5,1 MacPro 12core X 3.33ghz, 128gb ram, RX580 video, OSX Mojave, VSL (almost everything), LogicPro, Cubase10, StudioOne, DP9, Reaper, Dorico, Finale, MuseScore, Notion6, EW Hollywood Orch, Kirk Hunter, GPO, much more..
Posted on Mon, May 06 2019 16:48
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 11034

Hi,

It should always be working. I think that the only trouble is if you set the MIR PRO plug-in latency to "0", IIRC. 

You can always send an example to , if you found any troubles. The less exotic your plug-ins, the more likely it will work.

Best,
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Mon, May 06 2019 16:54
by Dewdman42
Joined on Tue, Feb 27 2018, Posts 294
Not sure what you mean by mir pro latency set to zero but I will look into that tonight. I have a test frame with a couple free voxengo plugins and no mir. I will send it to you guys later tonight! Thanks!
5,1 MacPro 12core X 3.33ghz, 128gb ram, RX580 video, OSX Mojave, VSL (almost everything), LogicPro, Cubase10, StudioOne, DP9, Reaper, Dorico, Finale, MuseScore, Notion6, EW Hollywood Orch, Kirk Hunter, GPO, much more..
Posted on Fri, May 10 2019 23:31
by Dewdman42
Joined on Tue, Feb 27 2018, Posts 294

fixed in 7.0.807

5,1 MacPro 12core X 3.33ghz, 128gb ram, RX580 video, OSX Mojave, VSL (almost everything), LogicPro, Cubase10, StudioOne, DP9, Reaper, Dorico, Finale, MuseScore, Notion6, EW Hollywood Orch, Kirk Hunter, GPO, much more..
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.