Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
VEPro 7 stops loading template?
Last post Wed, Sep 15 2021 by toodamnhip, 11 replies.
Options
Go to last post
Posted on Sun, Mar 01 2020 17:36
by Id45
Joined on Sun, Nov 20 2011, Posts 3

More often than not, whenever I load a big project or a big template (multiple instances on a local server, not an external machine), VEPro would stop loading the template (or perhaps freeze) and then I need to force quit VEPro and try to load it again.

Usually, it gets it by the fourth or fifth time. Is anybody else experiencing this?

VEPro 7 latest version, on the new Mac Pro 28-core 192 RAM macOS Catalina.

 

Thanks!

Posted on Mon, Mar 02 2020 03:57
by holywilly
Joined on Mon, Jul 08 2013, Posts 65

Same thing happening here today!
VEP stuck at 27% permanently, nothing's changed after restarting computer or VEP 7.

The template was loaded successfully until today (March 2nd, 2020).

I'm running the latest VEP7 on Mac Pro 6,1 12-core, 128GB Ram MacOS Mojave.

Posted on Mon, Mar 02 2020 09:13
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12789

Hi, 

Sounds to me like a loading process in one of your used plug-ins is hanging. 

You can send us a sample from the hang, to

=> Open Activity Monitor

=> Choose Vienna Ensemble PRO

=> Click the small "i" in the upper left corner

=> Click "Sample" in the lower left corner

=> Save the file and send it to us 

There's a good chance we can tell you what is causing the hang (but we cannot change the loading procedure of a plug-in, VE Pro is only the host) => so you can contact the producer of the plug-in and check what can be done. 

Best, 
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Thu, Mar 05 2020 00:34
by adriaantaylor
Joined on Tue, Sep 30 2014, Boston MA US, Posts 57

Yes this seems to be happening to me.. i found if i open VEpro server first then do a file open. i have more luck if that sheads any light on things.. 

Posted on Thu, Mar 05 2020 02:32
by Id45
Joined on Sun, Nov 20 2011, Posts 3

Yeah, I'm seeing the same behavior here too...

This is really weird...

Posted on Sat, Mar 07 2020 18:30
by dlpmusic
Joined on Sun, Jan 19 2003, Posts 283

I see this all the time on one of my machines.  Never does it after a fresh computer restart....but loading a file a second time is 50/50 if it will freeze or not.  Then I have to force quit in task manager and try again.  Sometimes it can take 4 or 5 tries before it finally fully loads.  It does always get stuck in the same spot so I suspect it is aparticular plugin.

Posted on Sat, Mar 07 2020 21:46
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12789

Hi,

If you can find a way to reproduce this scenario, we can at least point to the culprit... any step-by-step instructions / samples (as described above) and setup information will be helpful: !

Best, 
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Fri, Feb 12 2021 12:43
by toodamnhip
Joined on Sat, Jun 09 2012, Posts 84

Is there no trick available to somehow bypass something in VE Pro to allow the files to open , for ex- without audio? It seems like we need a protocol to be able to look inside a stuck file so we could at least bypass the culprit. Otherwise, with large templates especially, if any ONE company changes something, it kills an entire sound library. Wow. Thats a true aqxuiles heel is it not?

OS 10.10.3 DP 9.0
Posted on Fri, Feb 12 2021 16:12
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12789

Hi toodamnhip, 

It is mostly the dynamic loading processes that get in the way of each other, and VE Pro cannot influence that, being "just" the host. 

The plug-in standards / names etc are VERY rarely changed... none of your sequencer projects would open those plug-ins, no matter where they are hosted. 

Best, 
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Tue, Sep 14 2021 21:21
by houseofnoise_9498
Joined on Mon, Nov 08 2004, Los Angeles, Posts 2

Same issue on my system. Every few days my template freezes while trying to open. It is completely inconsistent and happens at different stages.

Best of luck!

VEPro 7 latest version, on the new Mac Pro 16-core 160 RAM, macOS Big Sur.

Posted on Wed, Sep 15 2021 01:44
by toodamnhip
Joined on Sat, Jun 09 2012, Posts 84

As a long time user and Fan, For me, if VE Pro wants to be a truly DEPENDABLE hosting format, it needs to forget what is "possible", and instead, realize that users desperately need CERTAINTY that One stupid sub program cannot FREEZE an entire template. So, VE Pro needs to build into its capabilities a diagnostic tool of some sort.

There are many possible levels to this:

It can be a timed out based approach, where if VE Pro does not hear back from a program that's trying to load it will bypass and move on.

It can be a special opening mode where audio is shut off allowing a user to see which programs aren't loading and bypass them before turning on the audio aspect back on. And it can be many other approaches, all equating to isolating any hanging VI, bypassing it, and NOT HANGING!

I am not a programmer, I do not care one iota about programmers or their "needs" or "limitations" I care about what end users NEED.

As of this moment, VE Pro is an extremely vulnerable program to rely on for the sole source of one's orchestral or VI library. It is subject to the weakest link of any 3rd party VI that goes retarded. If you have 60 VIs, realize that any one of their "updates" can potentially sink Vienna and therefore one's whole template or song.  If Toontrack screws up its naming protocol like once happened to me, VE Pro is sunk. If ever problematic Mach 5, with its low IQ method of searching for its sounds can't find its brain when trying to load, 99 other working VIs can ALL be stopped dead in their tracks. Terrible terrible terrible! 

This is the REAL #1 issue users need addressed. I believe it can be done. It starts with a no excuses attitude and THREE- realizations:

1) that VE Pro is extremely vulnerable.

2) That it is completely unacceptable for any one malfunction of a VI to stop the entire template from loading. 

3) That something CAN be done about it.

OS 10.10.3 DP 9.0
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.