Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
VEP7 - Using groups causing performance latency
Last post Fri, Jun 05 2020 by sottovoceprods, 3 replies.
Options
Go to last post
Posted on Thu, Jun 04 2020 17:58
by sottovoceprods
Joined on Thu, Dec 17 2015, los angeles, Posts 2

Hello, Paul and co. I hope all is well.
 
I have sent you a very small and simple Nuendo/Cubase project file as well as a VEP server, which simply and effectively demonstrates the latency issue I am experiencing. I am using VEP 7.0.973 on a MacPro with OS Mojave 10.14.5.
 
The VEP instance has three subgroups (aka 'busses'), whose outputs 1/2, 3/4 and 5/6, respectively, are routed into Nuendo. No additional VSTs are used within VEP or the host DAW. Once you have the project file configured to your audio outputs, you will quickly find that, if you route the VEP Kontakt instance to bus 1 in VEP (output 1/2) there is no latency; however, if changing the routing of the Konatkt VST to output to bus 2 (output 3/4), or bus 3 (output 5/6)--latency occurs while performing on the keyboard.
 
Also, if you could, please better explain the role of assigning threads to instances of VEP. So far, with my large template, I am not noticing a difference in performance whether I set threads to 12, 24, 40 or 50. What should I be on the lookout for—to know it is time to try adjusting the thread count up or down? There are 56 threads available in my MacPro.
 
Thanks
Posted on Fri, Jun 05 2020 12:52
by marnix
Joined on Tue, Mar 16 2004, Vienna, Posts 987

Hi sottovoceprods,

I loaded your Nuendo project into Cubase, since I do not have Nuendo installed here at home.

No difference in Latency whatsoever, no matter wether I route the Kontakt signal into Bus 1, Bus 2 or Bus 3 in the VE Pro Server instance.

I also asked two of my colleagues with different systems to see if they could possibly reproduce your problem and they were unable to do so either.

Please review your Audio Connections routing (F4)in Nuendo, especially in the Control Room tab - this is a constant source of various latency oddities, for example when you are using listening busses or duplicate assignments...etc...

Also, please check wether "Constrain Latency Compensation" is enabled in Nuendo - this also might be causing the problems you are experiencing when not properly configured.

As for Threads per instance setting: unfortunately, there is no "one setting to rule them all", as this depends on so many factors. Please find more information about multiprocessing in VE Pro 7 at https://www.vsl.info/en/manuals/vep7/vep-server?q=multiprocessing#multiprocessing

Best, Marnix

Posted on Fri, Jun 05 2020 19:53
by sottovoceprods
Joined on Thu, Dec 17 2015, los angeles, Posts 2

Hi, Marnix. Please kindly removed the previously attached file, if you wouldn't mind. I would rather not leave it public.


Thank you so much for having a look at the file, and for leading me to further troubleshooting. As it turns, I located a plug-in (Sound Radix “Pi”) that was hiding out on the Cubase MIDI channel’s “Audio Inserts” tab. This particular plug-in had a look-ahead buffer; once I removed this plug-in, the latency went away.
 
With the plug-in enabled, turning on “Constrain Delay Compensation” on the lower left-hand side of the project window also solved the problem—so I have options. In fact, I will mostly be using this feature from here on out—until it is time to mixdown my project.
 
I cannot tell you how pleased I am to finally move past this issue. Thank you and the team immensely for your support. Thanks also for referring me to the article about threads. I will experiment with that as needed, to find what works best for me.
 
[SOLVED]
 
All the best!
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.