Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Very High CPU usage on VEP7
Last post Mon, Mar 29 2021 by Cyril Blanc, 7 replies.
Options
Go to last post
Posted on Tue, Mar 23 2021 15:26
by gcorcella
Joined on Mon, Sep 23 2019, Posts 7

Hello

It seems like I’m having issues using VEP on my new slave windows pc. It’s an MSI Bravo 15 with AMD Ryzen 7 4800H, 8 cores, 16 threads, 64 GB RAM 3200 MHz. The Master’s is instead an iMac Late 2015 27” i5 32 GB RAM. 

VEP is on the MSI, Cubase on the iMac. I’m working on a mock-up of the preludio to I Due Foscari by Verdi. I have 1 instance with 35 Synchron Player tracks. Buffer size 2048 on Cubase . 16 threads assigned to the instance. 4 buffers on the VEP plugin in Cubase.

The computers are connected via Ethernet to the router. 

While not playing it takes 15-16% CPU usage on VEP. When I play it , CPU usage goes to 70-80% in some parts  In the project I am working on there is a Tutti part with a several fast notes in which the sound is not clear and some instruments keep playing a fixed note even after this part has ended and I have to disconnect the instance. Does anyone have any idea of what is going on and how I could fix this? It seems to me like the samples are not properly loaded into the RAM memory during this passage. Also, the fact that the CPU usage jumps to 70/80% sounds weird to me. 

Thank you

Posted on Tue, Mar 23 2021 16:38
by Macker
Joined on Tue, Aug 21 2018, London, Posts 276

You haven't said what instrument libraries you're using. Do they include Sy Dimension Strings by any chance? These can get extremely heavy on CPU if you use factory Mix presets and the Synchron Players are using the 'heavy' Convolution setting (i.e the "Use Light Convolution" option is not ticked in Synchron Player Engine preferences).

I've had similar difficulty (although all in one iMac) using Sy Dim Strings in a Wagner piece that has lots of divisi string parts. I brought down VEPro's CPU usage from about 60% or more to about 20 to 25% by removing the factory convolution reverb presets (by loading the "99 Mir Unprocessed" Mix preset) and then using my own algorithmic spatialisation plugins in VEPro.

As for the hanging notes, perhaps that's a result of a CPU core becoming completely overwhelmed momentarily when it would otherwise be responding to MIDI Note-Offs; just a guess, impossible to say for sure, although you did mention that "the sound is not clear" in the busy parts.

I could be very wrong here, this is pure speculation on my part. If you let us know some more about your instruments and presets and your hard drive(s), then perhaps others may provide suggestions more relevant to your setup.

Posted on Tue, Mar 23 2021 16:47
by gcorcella
Joined on Mon, Sep 23 2019, Posts 7

Thank you for your reply. 

You're right, I'm sorry. I'm using VSL Synchron-IZED SE for Winds, Brass and Strings divisi. Brass and Strings Divisi include actually some Dimension instances. Always close preset, Reverb bypassed and also Impulse Response bypassed. Unison strings are Synchron Strings Pro. As a room verb I'm using MIR Pro 24 inside Cubase. 

The libraries I am using right now are momentarily stored in the internal MSI's disk (1TB SSD PCIe) because I only have external hard drives. I'm probably going to purchase an external SSD in a few days/weeks. 

Posted on Tue, Mar 23 2021 17:22
by Macker
Joined on Tue, Aug 21 2018, London, Posts 276

Hmm, looks like you've got all the main bases pretty well covered. Not sure if a separate SSD will provide all the relief you're looking for, although it's recommended for library storage. Sorry, but I'll duck out at this point and hope others (especially VSL) may help you solve this one.

Posted on Tue, Mar 23 2021 17:49
by gcorcella
Joined on Mon, Sep 23 2019, Posts 7

Yeah, I'm not sure either but I have 3,16 TB of libraries so I need to store all of them on some external SSD :'D

Posted on Sat, Mar 27 2021 22:54
by BasariStudios
Joined on Mon, May 14 2012, NYC, Posts 66

Try connecting the Computers directly, it will speed up a lot.
I tried on mine thru the Router and stuff but it was a lot slower,
direct connection is the best.

Reality is due to Lack of Weed
Posted on Mon, Mar 29 2021 06:49
by Cyril Blanc
Joined on Thu, Dec 19 2002, Paris France, Posts 2686

You are right, I was very surprised moving files of VSL from one computer to another using Ethernet thru a Netgear  router ! VERY SLOW ---> 2 days

Connecting directly on the Orange box router it was done in a few hours 

MacBook Pro 2019 16" + 2 x Odisseey G9 49" Big Sur
MacPro 2010 12 core 2.93 ghz 64 GB Mac OS X 10.11 2722 Rocket Raid Sata III card with 8 x ssd
VSL lib on a Raid 0 of 4 x 256 GB ssd Sata III - Raid 0 of 4 x 64 GB for other libs
System on a 1 TB ssd
Audio Motu PCI system 84 ins / 64 outs
Kbd : P80 Yamaha, S88 and S25 Komplete Kontrol, DX7
I-Controls Pro, 2xMidi expression pedals
Synth : many....
---
Macbook pro Retina 2.7 ghz 16 GB
---
Mac Mini server 10.10 (server, Itunes, WEB, and Backup )
--
Logic X , Dorico, Band In A Box, ORB Composer
VSL : MIR PRO, Appassionata Strings I, Solo strings , Wind and Brass Complete, Dimension Brass, Big Band Orchestra series
Kontakt, Omnisphere, QLSO, QLSC, CS 80, Arturia V5, Maximo, Realivox Blue. CS 80 V3, The Orchestra 2, Art Conductor 5, Genesis Children Choir, Lunaris, Lacrimosa

Final Cut pro
Camera full HD
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.