Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Forum Jump  
Error when adding Synchron player to VEP
Last post Mon, Apr 05 2021 by Ben, 11 replies.
Options
Go to last post
Posted on Wed, Mar 31 2021 15:14
by Mark K
Joined on Mon, Mar 29 2021, Posts 12

I have vienna ensemble pro 7 up and running on the network pc. I installed the epic library and the synchron player. This is all the latest version as of today. When I try to add synchron player to VEP channel, I get an error dialogue box with the following: "Plugin error--toolkit:---could not open plugin". It then creates a channel with nothing in it.

I am running it on windows 10, current version.

Mark K attached the following image(s):
error.PNG (59kb) downloaded 0 time(s).

You cannot view/download attachments. Try to login or register.
Posted on Wed, Mar 31 2021 21:23
by Ben
Joined on Sat, Mar 06 2021, Los Angeles, Posts 26

Hi,

Could you please post the exact version number of VEP and the Synchron Player?

Best, Ben

Ben @VSL
Posted on Wed, Mar 31 2021 22:16
by Mark K
Joined on Mon, Mar 29 2021, Posts 12

Here  it is.

Mark K attached the following image(s):
vepversion.PNG (109kb) downloaded 1 time(s).

You cannot view/download attachments. Try to login or register.
Posted on Thu, Apr 01 2021 00:20
by Ben
Joined on Sat, Mar 06 2021, Los Angeles, Posts 26

Thanks!

Please double check if you are running the x64 version of VEP (it has x64 in the file-name).
The Synchron Player is 64-bit only.

Best, Ben

Ben @VSL
Posted on Thu, Apr 01 2021 02:24
by Mark K
Joined on Mon, Mar 29 2021, Posts 12

Thank you for looking into this. I just double checked, it is the 64 bit version running.

Posted on Thu, Apr 01 2021 08:28
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12613

Hi, 

My suggestion is to uninstall both VE Pro 7 and Synchron Player and start again from scratch. Something must be twisted there. 

Best,
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Thu, Apr 01 2021 18:03
by Mark K
Joined on Mon, Mar 29 2021, Posts 12

I uninstalled both products and re-installed and received the same error. I hope there are some logs that can be reviewed or some sort of analytics that can be run on the vep server to get to the root of this. 

I was trying to figure out how to test the synchron player outside of VEP but I don't have a daw installed on it to do this. Any sugggestions of a free daw that can put some midi into synchron and see if it works in and of itself?

Posted on Thu, Apr 01 2021 18:34
by Paul
Joined on Sat, Aug 03 2002, Vienna, Posts 12613

Hi, 

Please post a picture that shows that the Vienna Ensemble Service is indeed 64 bit (it is visible in the header of the application). 

Best, 
Paul

Paul Kopf
Product Manager - Vienna Symphonic Library
Posted on Thu, Apr 01 2021 19:14
by Mark K
Joined on Mon, Mar 29 2021, Posts 12

Got a better screenshot.

Mark K attached the following image(s):
error.PNG (205kb) downloaded 2 time(s).

You cannot view/download attachments. Try to login or register.
Posted on Fri, Apr 02 2021 18:21
by Mark K
Joined on Mon, Mar 29 2021, Posts 12

There have been some developments--I feel like I am doing all the work here. When I ran the synchron stand alone, it reported an error of a missing vcruntime_1.dll. I googled this and found it can be cured by installing a pack of visual studio runtimes from microsoft. I installed that and the synchron stand alone worked.

So there is a problem with packaging of the synchron installer as it should ensure the runtime is there. Feeling good about things, I tried to insert it into a vep server instance and got the same error as I initially reported.

I have resolved the problem--or identified a work-around. I went into the vep server settings and looked at the settings for synchron player. I un-checked the surround 5.1 option and I was able to load the synchron player into vep. Looks to me like another packaging/install problem. Of course the softwre should have gracefully captured the error and returned an accurate error message.

Posted on Mon, Apr 05 2021 13:26
by Ben
Joined on Sat, Mar 06 2021, Los Angeles, Posts 26

Hi,

Glad to hear that you could get it to work.
Regarding the "missing" VS runtimes: Make sure to install both, the x64 and the x86 version, as both are required.
We added an additional check in the upcoming installer that should ensure these runtimes are installed.

Best, Ben

Ben @VSL
You cannot post new threads in this forum.
You cannot reply to threads in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.